summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-07-02 08:33:50 +0200
committerAlfredo Tupone <tupone@gentoo.org>2023-07-02 09:21:48 +0200
commitda9b36a15c72494c858157f976653be77bf6b08f (patch)
tree53db90a086877ff7172a8d1087d8dbbdae9a4dd4
parentdev-ml/ppx_module_timer: add 0.16.0 (diff)
downloadgentoo-da9b36a15c72494c858157f976653be77bf6b08f.tar.gz
gentoo-da9b36a15c72494c858157f976653be77bf6b08f.tar.bz2
gentoo-da9b36a15c72494c858157f976653be77bf6b08f.zip
dev-ml/ppx_stable: add 0.16.0
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
-rw-r--r--dev-ml/ppx_stable/Manifest1
-rw-r--r--dev-ml/ppx_stable/ppx_stable-0.16.0.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-ml/ppx_stable/Manifest b/dev-ml/ppx_stable/Manifest
index 7273ec1eb8d0..e5974b784c2e 100644
--- a/dev-ml/ppx_stable/Manifest
+++ b/dev-ml/ppx_stable/Manifest
@@ -1,2 +1,3 @@
DIST ppx_stable-0.14.1.tar.gz 12031 BLAKE2B 837a53206d3a8d651d53f665daebbcfde3a1b5d55f1ed13d3ac8feecbd9ba0fb24ad7bb1cf24a0bfa00a41a46c3ef0f84385bc8792685f42ef18facf88ce348f SHA512 1c99a61537a2ce7d40208c64efbf71c54726b228d3746f2afaf9e813b3fed9c8016bb2eb859be24993c7c922a34f574e1028db8e7ee922d4772336dc0496df74
DIST ppx_stable-0.15.0.tar.gz 18143 BLAKE2B cfd317f98c7683bd2faf29eb386939f07b30798f16e43abdfe9361f9f3d373d4b64ed13aa87f300e5f14052ad1bc636d402af84c9f15d9e26d7b2dc976c812af SHA512 1be50f061d55ea0fcb8bd846955da3ceb07b97986d74a06b41c0f6b5c0dfb3a55f9e39e47f64ae227ecce89dd31dc3b03082031748982419d4ce9a14b5cdb436
+DIST ppx_stable-0.16.0.tar.gz 18298 BLAKE2B 3308ecc99f3c5a6c9b5a270f04effc62dfdb52116b91255eb0383e3244a2710124a211a81d52954ee5ac94251f84847d12787dd79b7c3d96a68d1bd4abf52458 SHA512 bbc40494718d99228e194f766be75c67a657cb50fe6090d05ba30606be40406c93323b64ae3d2400ab6a1563c3e9fa04c2ba82da7db47b7c1cfec103f75d19cb
diff --git a/dev-ml/ppx_stable/ppx_stable-0.16.0.ebuild b/dev-ml/ppx_stable/ppx_stable-0.16.0.ebuild
new file mode 100644
index 000000000000..eaffd572aa50
--- /dev/null
+++ b/dev-ml/ppx_stable/ppx_stable-0.16.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Stable types conversions generator"
+HOMEPAGE="https://github.com/janestreet/ppx_stable"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ >=dev-lang/ocaml-4.14
+ dev-ml/base:${SLOT}
+ >=dev-ml/ppxlib-0.28.0:=
+ >=dev-ml/ocaml-compiler-libs-0.11.0:=
+"
+RDEPEND="${DEPEND}"