summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-04-02 10:34:53 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-04-02 10:34:53 +0300
commitdaafa9516a81d57464c46a3dd0494a1ae22c0baf (patch)
tree81b46a96c9378b8b36c1127c4a25391a25cd8fbb
parentdev-libs/nss: Stabilize 3.68.3 arm, #836621 (diff)
downloadgentoo-daafa9516a81d57464c46a3dd0494a1ae22c0baf.tar.gz
gentoo-daafa9516a81d57464c46a3dd0494a1ae22c0baf.tar.bz2
gentoo-daafa9516a81d57464c46a3dd0494a1ae22c0baf.zip
dev-python/boto3: add 1.21.32
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.21.32.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 46aa29e40967..71dab3cc9d04 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -7,4 +7,5 @@ DIST boto3-1.21.28.tar.gz 483052 BLAKE2B 89afa5ff7d9b8c256b525ef2d67a17de45fda8b
DIST boto3-1.21.29.tar.gz 483137 BLAKE2B fa753a52923d013a3c5b3981fb32614bc5cb7be1b7696d2b60df877b33814553c22eccaf8d66e4719922b4289181c2e8356a3b377b25e81c8bdf8496cd49d0a9 SHA512 6c916fce1097d226b865cebf2d8791bc40506d9dd5b2db49b61e038872fb2f51d9de727ab8c9da3accced2563e81314dbe87788af57d6366fb90c446d3b79555
DIST boto3-1.21.30.tar.gz 483635 BLAKE2B b42a3f647c2b609ac6604e4390d4c1c45757a15d420ea9f9710a0c469547bdb8c1fbc3e4737de88fa628e58b6021da5e470cb3a04f95f8dd383df0089fa0d13c SHA512 993c584e3cdad05436b88b2959cc359713b96a20e54be12d305544b8f1e059196caa76566c88d979490d40bb73a2ee213618ec3e4a20cc01328a00e9f160fd53
DIST boto3-1.21.31.tar.gz 484562 BLAKE2B f647e7eb053ed38a8c670073ba028e5cccbb540807d8f9a1c60aec1a1e557937f62391a33d63edb69c123cf832b9eaeaa8dbfebb673b554381d548d60995fbfd SHA512 229b4c95743b7e217b2698130fc86970eb346728bdc0bc3cc0f5a9dc48a7922c21d04234a2f9ff9da29fb2d1742e5cca5e42f11ec92d0dd6ee29b3e2baf34c52
+DIST boto3-1.21.32.tar.gz 485694 BLAKE2B da6fa6f38b234af9e67bfeb8182751f1ac533a2aea72d8d407aea21554501f598c9da71f3c30dd952248c1ab244c849b779a329fc941d05b53325fe46de2aba4 SHA512 d65cffa91ae1a29e69e4bac2fc0af704987e9bca914f3f905e00c383bc92127c6e41beed71e9445e3f484c6dadde2372aca69f550af600abbb42731275c53eda
DIST boto3-1.21.8.tar.gz 473069 BLAKE2B f08f76fb9c4e56e6ba5624c885973599505769d7f9eea6e20a06e1a641768b1f7b108fc7293282a55bf4c7d2b62eb34853f46b8c3ada9afb8fc25624daa60c12 SHA512 23ed88dcaefe3224db05959251befaae4f03859bf00daf649db1e838e5fb92e01a6da4bee8083366d804404aac358df19d7e4552d6aaf39f9c4b371ccc7f9088
diff --git a/dev-python/boto3/boto3-1.21.32.ebuild b/dev-python/boto3/boto3-1.21.32.ebuild
new file mode 100644
index 000000000000..6fcba460ab1d
--- /dev/null
+++ b/dev-python/boto3/boto3-1.21.32.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}