summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-08-11 02:35:30 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-08-11 03:13:23 +0200
commitdab1ecdf450876d52b7641706084b40153c904d4 (patch)
tree29387cd871795e3a4a096d22363af6f5ab035b25
parentnet-libs/libircclient: add USE=libressl (diff)
downloadgentoo-dab1ecdf.tar.gz
gentoo-dab1ecdf.tar.bz2
gentoo-dab1ecdf.zip
app-text/lesspipe: bump to v1.84
Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--app-text/lesspipe/Manifest1
-rw-r--r--app-text/lesspipe/lesspipe-1.84.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/app-text/lesspipe/Manifest b/app-text/lesspipe/Manifest
index f665b8790a09..b755f2674718 100644
--- a/app-text/lesspipe/Manifest
+++ b/app-text/lesspipe/Manifest
@@ -1 +1,2 @@
DIST lesspipe-1.83.tar.gz 115129 BLAKE2B 24d9e4a226537a44c01c316528e085c6d2d7889b2ae5166d70b85e12c5f0b34e825e039a70071d7e75947e1c63d527decb21973631e910de42c75ec3ee17436c SHA512 c6418ac2bfc2dee9d32d56b0ea4a94954b1431db54fef8b67a9cf7d961cf4a23d87b2f41b2a4560d2333029c6d4ed5c6f399cb635f857bd43f1603993b5cb55d
+DIST lesspipe-1.84.tar.gz 119657 BLAKE2B 671b504022bdba82eea03d7a83960d5ed148d851d0420f179967f46d38a88ab90c9928a462e01744134aedfe710dba741430e78743451b1b65e603e5d89ae139 SHA512 f11ef23610f722d62ddf7e084b03967ed59d21af6ac207d4456f625c93c3c58c87ec5907cf6bca00ae5550dcddfc9b7f0be5de51f9ff81044fcff1f1cde81267
diff --git a/app-text/lesspipe/lesspipe-1.84.ebuild b/app-text/lesspipe/lesspipe-1.84.ebuild
new file mode 100644
index 000000000000..4ecd47310905
--- /dev/null
+++ b/app-text/lesspipe/lesspipe-1.84.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DESCRIPTION="a preprocessor for less"
+HOMEPAGE="https://github.com/wofr06/lesspipe"
+SRC_URI="https://github.com/wofr06/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="dev-lang/perl"
+RDEPEND="${DEPEND}
+ !<sys-apps/less-483-r1"
+
+src_configure() {
+ # Not an autoconf script.
+ ./configure --fixed || die
+}
+
+src_compile() {
+ # Nothing to build.
+ :
+}
+
+src_install() {
+ emake PREFIX="${EPREFIX}/usr" DESTDIR="${D}" install
+ einstalldocs
+}
+
+pkg_preinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog "This package installs 'lesspipe.sh' which is distinct from 'lesspipe'."
+ elog "The latter is the Gentoo-specific version. Make sure to update your"
+ elog "LESSOPEN environment variable if you wish to use this copy."
+ fi
+}