summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-05-07 08:24:26 +0200
committerAlfredo Tupone <tupone@gentoo.org>2024-05-07 08:24:26 +0200
commitdabd41758b56d50990d48a39fd6b79128793ac1a (patch)
tree3002933383dda08ae3a253e7fc10a5bbd3f73eb0
parentsci-libs/onnx: add IUSE to disable static registration (diff)
downloadgentoo-dabd41758b56d50990d48a39fd6b79128793ac1a.tar.gz
gentoo-dabd41758b56d50990d48a39fd6b79128793ac1a.tar.bz2
gentoo-dabd41758b56d50990d48a39fd6b79128793ac1a.zip
sci-geosciences/xyzservices: add 2024.4.0
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
-rw-r--r--sci-geosciences/xyzservices/Manifest1
-rw-r--r--sci-geosciences/xyzservices/xyzservices-2024.4.0.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/sci-geosciences/xyzservices/Manifest b/sci-geosciences/xyzservices/Manifest
index fc450573a7a6..d14c2c24183a 100644
--- a/sci-geosciences/xyzservices/Manifest
+++ b/sci-geosciences/xyzservices/Manifest
@@ -1 +1,2 @@
DIST xyzservices-2023.10.1.tar.gz 1113019 BLAKE2B c239c244c7ffea836acfc2fdba284c2b2b0b8fbd7e915ddcc004f7735898760f8bac626c7f58329d5c5555753dbbfe13731494ef5948ffaf2cd36d1eb28e014d SHA512 5ab57caa160bbf926014da83f81108c7ae6c509831a94d38c2dde73067cb2cd624697902166eb5a0af5f55faef1b8f1d0786db4766f80b1bfe5cad889d9dc627
+DIST xyzservices-2024.4.0.tar.gz 1126163 BLAKE2B d725799b668ac0cbdc88fbd8a9f14db70d45b5ca665fe899b4cc57197321b6639590c29f47fb10e420b9f8ccfbfe4b867a9a9c8e090403f0c023c0e69295f5f9 SHA512 1fb991578275914a7b3ef8202dcb049116a423f2b645bbc52717485c76089615f988f9eb592e13399c30b2901630089188c4ed30276c68015a7f12661ac62331
diff --git a/sci-geosciences/xyzservices/xyzservices-2024.4.0.ebuild b/sci-geosciences/xyzservices/xyzservices-2024.4.0.ebuild
new file mode 100644
index 000000000000..14e1cb70572f
--- /dev/null
+++ b/sci-geosciences/xyzservices/xyzservices-2024.4.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+inherit distutils-r1
+
+DESCRIPTION="Source of XYZ tiles providers"
+HOMEPAGE="https://github.com/geopandas/xyzservices"
+SRC_URI="https://github.com/geopandas/${PN}/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test"
+
+BDEPEND="dev-python/setuptools-scm"
+
+# Need mercantile module
+# distutils_enable_tests pytest