summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Utkin <andrey_utkin@gentoo.org>2019-05-29 14:25:20 +0100
committerAndrey Utkin <andrey_utkin@gentoo.org>2019-05-29 15:29:32 +0100
commitdac9cddbd553d0650e84163a6531d6084a5fb004 (patch)
tree7039dbdea6b7219e67d15678d71e1ff3d529edaa
parentnet-libs/nodejs: Version 10.16.0 (diff)
downloadgentoo-dac9cddbd553d0650e84163a6531d6084a5fb004.tar.gz
gentoo-dac9cddbd553d0650e84163a6531d6084a5fb004.tar.bz2
gentoo-dac9cddbd553d0650e84163a6531d6084a5fb004.zip
dev-python/ruamel-yaml: add new version 0.15.96
Bug: https://bugs.gentoo.org/683078 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andrey Utkin <andrey_utkin@gentoo.org>
-rw-r--r--dev-python/ruamel-yaml/Manifest1
-rw-r--r--dev-python/ruamel-yaml/ruamel-yaml-0.15.96.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/ruamel-yaml/Manifest b/dev-python/ruamel-yaml/Manifest
index 7c1d51ac97c6..0bb606c556a2 100644
--- a/dev-python/ruamel-yaml/Manifest
+++ b/dev-python/ruamel-yaml/Manifest
@@ -1 +1,2 @@
DIST ruamel-yaml-0.15.35.tar.gz 344241 BLAKE2B 3e77f5da4e2a7f64099da1d79a108adfb093c5e47baaf11611462637ec6e29091924088e0ce261b21283a0ab07123da45a1ea7b0c522692d1e96cdcc27502541 SHA512 9e335d627db20b85ec0384f16d7ea03c310c01e84517e7b9bced1af9289fe542b87eb31da8ad960b17d26f35f2cc33a87a5a5b976e0e5ca587339b21b4b53fca
+DIST ruamel-yaml-0.15.96.tar.gz 399206 BLAKE2B e17f25d9501dad9fd17688b003d33fb0015b700f3c51d405710ccc0635263ced7a86140a3ed7a4aecaaf9e2e73f2eff17b99e96fbd9d9c1be3e9110c28758a62 SHA512 be76a03c46ce8826eda365791e212783243b64781318a998cc48c201bafb9af6b318e7544241fa10ce211e25bd6b26d3e57ef6a1fcb0c1be6dc4552c341e5492
diff --git a/dev-python/ruamel-yaml/ruamel-yaml-0.15.96.ebuild b/dev-python/ruamel-yaml/ruamel-yaml-0.15.96.ebuild
new file mode 100644
index 000000000000..156a753c41eb
--- /dev/null
+++ b/dev-python/ruamel-yaml/ruamel-yaml-0.15.96.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{5,6} )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="YAML parser/emitter that supports roundtrip comment preservation"
+HOMEPAGE="https://pypi.org/project/ruamel.yaml/ https://bitbucket.org/ruamel/yaml"
+MY_PN="${PN//-/.}"
+SRC_URI="https://bitbucket.org/${MY_PN/.//}/get/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+"
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/flake8[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/ruamel-std-pathlib[${PYTHON_USEDEP}]
+ )
+"
+
+python_install() {
+ distutils-r1_python_install --single-version-externally-managed
+ find "${ED}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ # This file produced by setup.py breaks finding system-wide installed
+ # ruamel.std.pathlib due to shared namespace
+ rm "${BUILD_DIR}/lib/ruamel/__init__.py" || die
+
+ py.test -v _test/test_*.py || die
+}