summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2018-07-26 16:00:29 -0400
committerVirgil Dupras <vdupras@gentoo.org>2018-07-26 16:00:29 -0400
commitdacc2876210a48f65a0f8db6e838b290e6d7873f (patch)
tree77d632169f53628f682724adc4608ee717042e97
parentmedia-video/dvbackup: Drop old (diff)
downloadgentoo-dacc2876.tar.gz
gentoo-dacc2876.tar.bz2
gentoo-dacc2876.zip
dev-python/olefile: bump to 0.45.1
* EAPI 7 * Add python3_7 * Drop python3_4 Package-Manager: Portage-2.3.43, Repoman-2.3.10
-rw-r--r--dev-python/olefile/Manifest1
-rw-r--r--dev-python/olefile/olefile-0.45.1.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/olefile/Manifest b/dev-python/olefile/Manifest
index c3ee87e8b998..765ba6aebf63 100644
--- a/dev-python/olefile/Manifest
+++ b/dev-python/olefile/Manifest
@@ -1 +1,2 @@
DIST olefile-0.44.tar.gz 57903 BLAKE2B 2df4078c147ff737b845fe4ca57b6520c39776efe6bac399b0b8acb4ca62f946a653f85ad0511f5fa42d8b544d539474d226fe144bc2604737f3b16e5edd5ff2 SHA512 92b6ad1bced5b2c8e5332a01e5a2e59527ec2303046d0babd665b0f02fe56966574eff56619de168c50f1ea40df2e61ce589ee61b634222146d049b129514c65
+DIST v0.45.1.tar.gz 97969 BLAKE2B 246198e69cde316f24a183fdf07872edf9b1db2a168571eedb7efdb91166d4ad2658acaaa90e733950e437ef5c6ab8d1bb275cd1b24283b95497e254a39c9b26 SHA512 72d40056cac1d9566aa8e32b7b5484f61958a689130e71fa86bc0b9fed98f27a8cf34b824971357d42ec3dfd2d5bfa86d0f212727ff91d8daa3967969ff576e9
diff --git a/dev-python/olefile/olefile-0.45.1.ebuild b/dev-python/olefile/olefile-0.45.1.ebuild
new file mode 100644
index 000000000000..73a28b8fd2cf
--- /dev/null
+++ b/dev-python/olefile/olefile-0.45.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python package to parse, read and write Microsoft OLE2 files"
+HOMEPAGE="https://www.decalage.info/olefile"
+SRC_URI="https://github.com/decalage2/${PN}/archive/v${PV}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND=""
+BDEPEND="
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+python_compile_all() {
+ if use doc; then
+ emake -C doc html
+ HTML_DOCS=( doc/_build/html/. )
+ fi
+
+}