summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-08-30 00:13:37 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-08-30 00:21:04 +0200
commitdae32498157df177d12c2a439190460094532312 (patch)
tree86e9dfc10ccf215ba1e82d30231c2a20c6ef3949
parentapp-dicts/aspell-da: add 4.1 (diff)
downloadgentoo-dae32498.tar.gz
gentoo-dae32498.tar.bz2
gentoo-dae32498.zip
dev-libs/intel-compute-runtime: add 22.34.24023
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--dev-libs/intel-compute-runtime/Manifest1
-rw-r--r--dev-libs/intel-compute-runtime/intel-compute-runtime-22.34.24023.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/dev-libs/intel-compute-runtime/Manifest b/dev-libs/intel-compute-runtime/Manifest
index 14a7f8dd4f7e..42af4bc19d06 100644
--- a/dev-libs/intel-compute-runtime/Manifest
+++ b/dev-libs/intel-compute-runtime/Manifest
@@ -2,3 +2,4 @@ DIST intel-compute-runtime-22.29.23750.tar.gz 5613298 BLAKE2B 7c662c85732d2053d6
DIST intel-compute-runtime-22.30.23789.tar.gz 5625283 BLAKE2B 0a59926453ae8a58afbd49a40d8b94ac9171d23a141f967c6d908b26ab66decbd082d42fe6e75bf9fd2b4327cbe5b4c71f6ef390a8a62435c06b749078d67cd4 SHA512 8f2caee7376a9a489efc7ee5b907786d1fc04ed3143dfc66e28069f4d19c13393c64cf6ea0159ce269ee2198dadddd7ef967a11efac90e616ce1f1c996b07153
DIST intel-compute-runtime-22.31.23852.tar.gz 5644386 BLAKE2B 90eb629187d0aba7a713c600234f18a5472d7ad4e9a7c1130e61011970a9247165f17dab936abb875ee4dd9b4ba167135d158a1b19fce9f20d2bd1c23c9d065b SHA512 66fae1c0e3173f45f0565906d455d4511d40bc392a966625f60315e6a72daa30c741dddc799c50b8e020092577af6aa03810cd5a5e3e729ab19815cdb5e6a27a
DIST intel-compute-runtime-22.32.23937.tar.gz 5656306 BLAKE2B 82cc631b69d24d2b845d6c9abc0525f06de8314c7915e651db3c800527244c94104eea6083acdde194cc51f9a68bdfcd39f3f4d296c96338e9f05c05d71cc21c SHA512 729d29c09624ae81ca1e8a455d4e3665fcb31cac87e9776730c038a3393e91e1a00e2079e2587adf4b9ab1797179f49fafd48ac5b855dab722837f1f3b77e0f0
+DIST intel-compute-runtime-22.34.24023.tar.gz 5696775 BLAKE2B 8a70751b54e2aaea51eb69d45ef1bed09198023b72b34354cbd87f73a91481f4c7c5a4e5d23815b8ab3d05d4525cb08136929c4b9c0c69b6bcb917b560d88c49 SHA512 592dbf4bad4898c2a5d7a95cd7f41d23cf2f7ab97a33d55f2322b8243a88a3b61ea28d0af1d853324456c5919082fa236fee5fa9cbfcebf248a791617e1533ad
diff --git a/dev-libs/intel-compute-runtime/intel-compute-runtime-22.34.24023.ebuild b/dev-libs/intel-compute-runtime/intel-compute-runtime-22.34.24023.ebuild
new file mode 100644
index 000000000000..af9f16456a1e
--- /dev/null
+++ b/dev-libs/intel-compute-runtime/intel-compute-runtime-22.34.24023.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CMAKE_BUILD_TYPE="Release"
+MY_PN="${PN/intel-/}"
+MY_P="${MY_PN}-${PV}"
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="Intel Graphics Compute Runtime for oneAPI Level Zero and OpenCL Driver"
+HOMEPAGE="https://github.com/intel/compute-runtime"
+SRC_URI="https://github.com/intel/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+l0 +vaapi"
+
+RDEPEND=">=media-libs/gmmlib-22.1.7:="
+
+DEPEND="
+ ${DEPEND}
+ >=dev-libs/intel-metrics-library-0_pre20220526:=
+ dev-libs/libnl:3
+ dev-libs/libxml2:2
+ >=dev-util/intel-graphics-compiler-1.0.11485
+ >=dev-util/intel-graphics-system-controller-0.8.0:=
+ media-libs/mesa
+ >=virtual/opencl-3
+ l0? ( >=dev-libs/level-zero-1.8.5:= )
+ vaapi? (
+ x11-libs/libdrm[video_cards_intel]
+ x11-libs/libva
+ )
+"
+
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( "README.md" "FAQ.md" )
+
+PATCHES=( "${FILESDIR}/${PN}-22.24.23453-remove-fortify-sources.patch" )
+
+src_prepare() {
+ # Remove '-Werror' from default
+ sed -e '/Werror/d' -i CMakeLists.txt || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ # See https://github.com/intel/compute-runtime/issues/531
+ filter-flags -flto=* -flto
+
+ local mycmakeargs=(
+ -DCCACHE_ALLOWED="OFF"
+ -DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
+ -DCMAKE_INSTALL_LIBDIR="$(get_libdir)"
+ -DBUILD_WITH_L0="$(usex l0)"
+ -DDISABLE_LIBVA="$(usex !vaapi)"
+ -DNEO__METRICS_LIBRARY_INCLUDE_DIR="${ESYSROOT}/usr/include"
+ -DKHRONOS_GL_HEADERS_DIR="${ESYSROOT}/usr/include"
+ -DOCL_ICD_VENDORDIR="${EPREFIX}/etc/OpenCL/vendors"
+ -DSUPPORT_DG1="ON"
+ -Wno-dev
+
+ # See https://github.com/intel/intel-graphics-compiler/issues/204
+ # -DNEO_DISABLE_BUILTINS_COMPILATION="ON"
+
+ # If enabled, tests are automatically run during
+ # the compile phase and we cannot run them because
+ # they require permissions to access the hardware.
+ -DSKIP_UNIT_TESTS="1"
+ )
+
+ cmake_src_configure
+}