summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKeri Harris <keri@gentoo.org>2021-05-29 14:21:53 +0000
committerKeri Harris <keri@gentoo.org>2021-05-29 14:22:21 +0000
commitdae3e41c425ed30b5ee18401cb715ee4eaa2db9b (patch)
tree829201c12d05dea1c76d4691f8e0781a5014c575
parentnet-dns/bind: fix rndc keygen (diff)
downloadgentoo-dae3e41c.tar.gz
gentoo-dae3e41c.tar.bz2
gentoo-dae3e41c.zip
net-misc/pedro: version bump
Closes: https://bugs.gentoo.org/792714 Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Keri Harris <keri@gentoo.org>
-rw-r--r--net-misc/pedro/Manifest2
-rw-r--r--net-misc/pedro/pedro-1.12.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/net-misc/pedro/Manifest b/net-misc/pedro/Manifest
index 72dc13f047c8..e6352a903816 100644
--- a/net-misc/pedro/Manifest
+++ b/net-misc/pedro/Manifest
@@ -1,2 +1,4 @@
+DIST pedro-1.12.tgz 1181678 BLAKE2B ed882ab3dae0912519283229d10ff6f12ef4f623d72beaf22b8467e8072752fbd57836a0ebbad0f0ce3da1b4837049161bcb12673e3c38c94eb167e16c0c0a1e SHA512 936b2c6cac526d9d3c0e146b53dc65ed0508c6abd1b66c97656fa5b4011d7dd11912d1c0bf091a29b56e13c3e19ec3e0ad7760d44d4887b939699cdd2389c819
DIST pedro-1.6.tgz 711856 BLAKE2B 5027dd438995e212889786996debb5765d49828d38ce715672e44776b5fb63db0d6bca0e72339fd5067254aed0b731d3f77656ad510d978e4f456af45d6cf008 SHA512 263f53e447d4b3baab405a1d7313fc397f8a62958957688265c7485a5697b642138636659b5515b9010341655ba8045e5d85f69a86c20baa28edc0dcff0aef42
DIST pedro-manual-1.6.tar.gz 222863 BLAKE2B 085b118585808aced9217a8001080b589d9dad958ad14787f929a4808b10bb2be80ae7bc04c07b676e41aed9e2ec916215c5d15dda2317f71ecebbc7c1737d96 SHA512 87f8e07e3a687d12e366f1974398996f2346e417680ab534622f901c0c7e1efeb171f0c0dadad46b578122c9e98531570c303d2d3ce04b1cd8150816d6138f99
+DIST pedro-manual-1.x.tar.gz 222863 BLAKE2B 085b118585808aced9217a8001080b589d9dad958ad14787f929a4808b10bb2be80ae7bc04c07b676e41aed9e2ec916215c5d15dda2317f71ecebbc7c1737d96 SHA512 87f8e07e3a687d12e366f1974398996f2346e417680ab534622f901c0c7e1efeb171f0c0dadad46b578122c9e98531570c303d2d3ce04b1cd8150816d6138f99
diff --git a/net-misc/pedro/pedro-1.12.ebuild b/net-misc/pedro/pedro-1.12.ebuild
new file mode 100644
index 000000000000..050a58794d6a
--- /dev/null
+++ b/net-misc/pedro/pedro-1.12.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Pedro is a subscription/notification communications system"
+HOMEPAGE="https://staff.itee.uq.edu.au/pjr/HomePages/PedroHome.html"
+SRC_URI="https://staff.itee.uq.edu.au/pjr/HomePages/PedroFiles/${P}.tgz
+ doc? ( https://dev.gentoo.org/~keri/distfiles/pedro/${PN}-manual-1.x.tar.gz )"
+S="${WORKDIR}"/${P}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc examples"
+
+RDEPEND="dev-libs/glib:2"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-portage.patch
+)
+
+src_configure() {
+ tc-export PKG_CONFIG
+
+ default
+}
+
+src_install() {
+ default
+
+ if use doc ; then
+ dodoc "${WORKDIR}"/${PN}.pdf
+ fi
+
+ if use examples ; then
+ docinto examples
+ dodoc src/examples/*.{c,tcl}
+
+ docinto examples/java_api
+ dodoc src/java_api/*.java
+
+ docinto examples/python_api
+ dodoc src/python_api/*.py
+ fi
+}