summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexys Jacob <ultrabug@gentoo.org>2019-12-12 23:22:44 +0100
committerAlexys Jacob <ultrabug@gentoo.org>2019-12-12 23:23:57 +0100
commitdae775967e700cfc6ff5700b6a2f3a205236cf4c (patch)
treeef0ae79b51a93f7b50aafeca1880fa65dcbeca4a
parentx11-misc/py3status: version bump (diff)
downloadgentoo-dae775967e7.tar.gz
gentoo-dae775967e7.tar.bz2
gentoo-dae775967e7.zip
sys-cluster/crmsh: version bump, fix #669568
Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Alexys Jacob <ultrabug@gentoo.org>
-rw-r--r--sys-cluster/crmsh/Manifest1
-rw-r--r--sys-cluster/crmsh/crmsh-4.1.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/sys-cluster/crmsh/Manifest b/sys-cluster/crmsh/Manifest
index eb3270395248..5be72de14fac 100644
--- a/sys-cluster/crmsh/Manifest
+++ b/sys-cluster/crmsh/Manifest
@@ -1,2 +1,3 @@
DIST crmsh-2.1.1.tar.gz 733302 BLAKE2B 6b6afdb1c3144eccf432e52a16910e7b427384458e720e042900e115d3e2986f2d08ec77acc9ad288e59070d55065e05c46770b0eeaad49a01b17bd93f593051 SHA512 556190e4e8da009d5f84f6356eeae2f5a18d8ca19d8c384c01d4d8526f7a20bb9545a08a6abe7cb6d9c33d9ae62ba0ea5df9ff0ae90341a53d9f7b201f5788ae
DIST crmsh-3.0.3.tar.gz 948573 BLAKE2B b4acb4420a7f447f0d50115ba449d506d2017e6f29221bd0b1ba45eb790e6472eadc62ff5ac6af367f4d5f2631cae162e770c0a6735dea42367248f2302cdcb4 SHA512 9dcb9560f8e23791340454e20f4e1ccd090230337357b93c2029f58ff9754756bc1eca5991c00290b937eeb3b42554989b5d6cc85a2eef5107f250d7acf570d3
+DIST crmsh-4.1.0.tar.gz 1002842 BLAKE2B 02505d9f10e2ac9525692a727d40a925d99f0035d1e372f0840b3072c4c016b55fced7ccaea8dbad9e475d7868e483e62944dbe45e5533eb4028eeda08b99c58 SHA512 3522a28c86069216222eb2efbb258014d74ce838e49885cd527a69d890415ea0899632b4cec095d2fde802b26cd7e673b0e9ea20e8d023fc7c4df140be600ef9
diff --git a/sys-cluster/crmsh/crmsh-4.1.0.ebuild b/sys-cluster/crmsh/crmsh-4.1.0.ebuild
new file mode 100644
index 000000000000..493af7ad63b2
--- /dev/null
+++ b/sys-cluster/crmsh/crmsh-4.1.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+AUTOTOOLS_AUTORECONF=true
+KEYWORDS=""
+SRC_URI=""
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/crmsh/crmsh"
+ inherit git-2
+ S="${WORKDIR}/${PN}-${MY_TREE}"
+else
+ SRC_URI="https://github.com/crmsh/crmsh/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~hppa ~x86"
+fi
+
+inherit eutils python-r1
+
+DESCRIPTION="Pacemaker command line interface for management and configuration"
+HOMEPAGE="https://crmsh.github.io/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ >=sys-cluster/pacemaker-1.1.9"
+RDEPEND="${DEPEND}
+ dev-python/lxml[${PYTHON_USEDEP}]"
+
+src_configure() {
+ ./autogen.sh || die
+ econf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ python_foreach_impl python_optimize
+}