summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-02-07 09:35:31 +0100
committerHans de Graaff <graaff@gentoo.org>2021-02-07 10:14:49 +0100
commitdafd743705bcd12710cc6a05ddac21940c7148a4 (patch)
tree66efb2a00fdccf9347915cf308a755539f3f9355
parentdev-libs/libsecp256k1: add curly brackers to local variable (diff)
downloadgentoo-dafd7437.tar.gz
gentoo-dafd7437.tar.bz2
gentoo-dafd7437.zip
dev-ruby/brotli: fix extension install
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/brotli/brotli-0.4.0-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-ruby/brotli/brotli-0.4.0-r1.ebuild b/dev-ruby/brotli/brotli-0.4.0-r1.ebuild
new file mode 100644
index 000000000000..a871349f521a
--- /dev/null
+++ b/dev-ruby/brotli/brotli-0.4.0-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_GEMSPEC="brotli.gemspec"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/brotli/extconf.rb)
+
+inherit ruby-fakegem
+
+DESCRIPTION="Brotli compressor/decompressor"
+HOMEPAGE="https://github.com/miyucy/brotli"
+SRC_URI="https://github.com/miyucy/brotli/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND+=" >=app-arch/brotli-1.0.7"
+DEPEND+=" >=app-arch/brotli-1.0.7"
+
+# Depends on the test data in app-arch/brotli
+RESTRICT="test"
+
+all_ruby_prepare() {
+ sed -e 's/git ls-files -z -- spec/find spec -print0/' \
+ -e 's/git ls-files -z/find . -print0/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}