summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-08-28 23:47:45 +0100
committerSam James <sam@gentoo.org>2023-08-28 23:47:45 +0100
commitdafdf8f41fe242a8b2b51d2b8982a6e447115a58 (patch)
treed2716cf975abde1e4fcaa59b8d780771bf2b6eb7
parentdev-lang/python: avoid confused LTO configure test w/ cross CBUILD Python (diff)
downloadgentoo-dafdf8f41fe242a8b2b51d2b8982a6e447115a58.tar.gz
gentoo-dafdf8f41fe242a8b2b51d2b8982a6e447115a58.tar.bz2
gentoo-dafdf8f41fe242a8b2b51d2b8982a6e447115a58.zip
app-emulation/qemu: BDEPEND on dev-python/pip for now
Better to do pip than python[ensurepip] given that's a heavier build. Hope to be able to avoid pip entirely but this is a cheap add for now. Bug: https://bugs.gentoo.org/913084 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-emulation/qemu/qemu-8.1.0.ebuild2
-rw-r--r--app-emulation/qemu/qemu-9999.ebuild2
2 files changed, 4 insertions, 0 deletions
diff --git a/app-emulation/qemu/qemu-8.1.0.ebuild b/app-emulation/qemu/qemu-8.1.0.ebuild
index 9fb08f07e76f..e46b8dd200ce 100644
--- a/app-emulation/qemu/qemu-8.1.0.ebuild
+++ b/app-emulation/qemu/qemu-8.1.0.ebuild
@@ -268,10 +268,12 @@ PPC_FIRMWARE_DEPEND="
)
"
+# See bug #913084 for pip dep
BDEPEND="
$(python_gen_impl_dep)
dev-lang/perl
>=dev-util/meson-0.63.0
+ dev-python/pip[${PYTHON_USEDEP}]
virtual/pkgconfig
doc? (
>=dev-python/sphinx-1.6.0[${PYTHON_USEDEP}]
diff --git a/app-emulation/qemu/qemu-9999.ebuild b/app-emulation/qemu/qemu-9999.ebuild
index e9ea36363d60..cca0a24a89c0 100644
--- a/app-emulation/qemu/qemu-9999.ebuild
+++ b/app-emulation/qemu/qemu-9999.ebuild
@@ -268,10 +268,12 @@ PPC_FIRMWARE_DEPEND="
)
"
+# See bug #913084 for pip dep
BDEPEND="
$(python_gen_impl_dep)
dev-lang/perl
>=dev-util/meson-0.63.0
+ dev-python/pip[${PYTHON_USEDEP}]
virtual/pkgconfig
doc? (
>=dev-python/sphinx-1.6.0[${PYTHON_USEDEP}]