summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2024-03-28 17:09:36 -0400
committerMike Gilbert <floppym@gentoo.org>2024-03-28 17:12:06 -0400
commitdafe17091a2bfa128ee7f706d63e76cc42e4c58f (patch)
treee3366abf2173e3e05b2c343b40d4085f2de815c2
parentdev-util/pkgcheck: add 0.10.29 (diff)
downloadgentoo-dafe17091a2bfa128ee7f706d63e76cc42e4c58f.tar.gz
gentoo-dafe17091a2bfa128ee7f706d63e76cc42e4c58f.tar.bz2
gentoo-dafe17091a2bfa128ee7f706d63e76cc42e4c58f.zip
sys-apps/systemd-utils: disable auto-cleanup of /tmp and /var/tmp
This can go awry when people have non-standard mount options for these paths. Closes: https://bugs.gentoo.org/910233 Bug: https://bugs.gentoo.org/916623 Closes: https://bugs.gentoo.org/917777 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
-rw-r--r--sys-apps/systemd-utils/files/tmp.conf2
-rw-r--r--sys-apps/systemd-utils/systemd-utils-254.10-r1.ebuild (renamed from sys-apps/systemd-utils/systemd-utils-254.10.ebuild)4
-rw-r--r--sys-apps/systemd-utils/systemd-utils-254.8-r1.ebuild (renamed from sys-apps/systemd-utils/systemd-utils-254.8.ebuild)4
-rw-r--r--sys-apps/systemd-utils/systemd-utils-255.4.ebuild4
4 files changed, 8 insertions, 6 deletions
diff --git a/sys-apps/systemd-utils/files/tmp.conf b/sys-apps/systemd-utils/files/tmp.conf
new file mode 100644
index 000000000000..9f3d19bb7a2d
--- /dev/null
+++ b/sys-apps/systemd-utils/files/tmp.conf
@@ -0,0 +1,2 @@
+q /tmp 1777 root root
+q /var/tmp 1777 root root
diff --git a/sys-apps/systemd-utils/systemd-utils-254.10.ebuild b/sys-apps/systemd-utils/systemd-utils-254.10-r1.ebuild
index 93436b880f05..80c11bee8adc 100644
--- a/sys-apps/systemd-utils/systemd-utils-254.10.ebuild
+++ b/sys-apps/systemd-utils/systemd-utils-254.10-r1.ebuild
@@ -517,8 +517,8 @@ multilib_src_install_all() {
insinto /usr/share/zsh/site-functions
doins shell-completion/zsh/_systemd-tmpfiles
insinto /usr/lib/tmpfiles.d
- doins tmpfiles.d/{tmp,x11}.conf
- doins "${FILESDIR}"/legacy.conf
+ doins tmpfiles.d/x11.conf
+ doins "${FILESDIR}"/{legacy,tmp}.conf
fi
if use udev; then
doheader src/libudev/libudev.h
diff --git a/sys-apps/systemd-utils/systemd-utils-254.8.ebuild b/sys-apps/systemd-utils/systemd-utils-254.8-r1.ebuild
index b73e1d640a89..bbe8dec823b3 100644
--- a/sys-apps/systemd-utils/systemd-utils-254.8.ebuild
+++ b/sys-apps/systemd-utils/systemd-utils-254.8-r1.ebuild
@@ -518,8 +518,8 @@ multilib_src_install_all() {
insinto /usr/share/zsh/site-functions
doins shell-completion/zsh/_systemd-tmpfiles
insinto /usr/lib/tmpfiles.d
- doins tmpfiles.d/{tmp,x11}.conf
- doins "${FILESDIR}"/legacy.conf
+ doins tmpfiles.d/x11.conf
+ doins "${FILESDIR}"/{legacy,tmp}.conf
fi
if use udev; then
doheader src/libudev/libudev.h
diff --git a/sys-apps/systemd-utils/systemd-utils-255.4.ebuild b/sys-apps/systemd-utils/systemd-utils-255.4.ebuild
index b258f5748243..a4f60f47e7f3 100644
--- a/sys-apps/systemd-utils/systemd-utils-255.4.ebuild
+++ b/sys-apps/systemd-utils/systemd-utils-255.4.ebuild
@@ -517,8 +517,8 @@ multilib_src_install_all() {
insinto /usr/share/zsh/site-functions
doins shell-completion/zsh/_systemd-tmpfiles
insinto /usr/lib/tmpfiles.d
- doins tmpfiles.d/{tmp,x11}.conf
- doins "${FILESDIR}"/legacy.conf
+ doins tmpfiles.d/x11.conf
+ doins "${FILESDIR}"/{legacy,tmp}.conf
fi
if use udev; then
doheader src/libudev/libudev.h