summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-09 19:29:14 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-09 19:48:44 +0100
commitdb013de66cbba982e8593968217afbb7d390e59e (patch)
treeeb0cd4cf44d5aee5596b7d625e87c154116975d9
parentdev-php/sebastian-type: bump to v1.1.4 (diff)
downloadgentoo-db013de6.tar.gz
gentoo-db013de6.tar.bz2
gentoo-db013de6.zip
dev-python/joblib: Bump to 1.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/joblib/Manifest1
-rw-r--r--dev-python/joblib/joblib-1.0.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/joblib/Manifest b/dev-python/joblib/Manifest
index 3a282f1ad230..9cddcefb58be 100644
--- a/dev-python/joblib/Manifest
+++ b/dev-python/joblib/Manifest
@@ -1 +1,2 @@
DIST joblib-1.0.0.tar.gz 346996 BLAKE2B 6f31dba31e451fe1d05e7a34bc211b641e10a6dda21cc6a4d283a594744caa3434748a2c2c661c468931e509d815596db18ce1cbed287ae6b0da287490256dec SHA512 3fad2f3d4d6651d2c0376403b3658defc9ae1acf08b2e187f77b440040ad414bf723241d685df862c08b88d784ded915f5794d0e0c29841d9acae4db200d7213
+DIST joblib-1.0.1.tar.gz 347176 BLAKE2B 046ec87d446eb3075d867e41bb87039062531294d9b6c0be8d3cb42ccdf47dd58f1bc46a599ade64fc210e93fcad6e3007af82dbc670e1eaec1c67b425f87712 SHA512 39b1579efad44d6e51db501dbaa8378e7c8a423822ee3264a8bed44b720f59e6d08993a00f995c45beada3dd59b8e4101c47e587c9bf72027b01723838b533ab
diff --git a/dev-python/joblib/joblib-1.0.1.ebuild b/dev-python/joblib/joblib-1.0.1.ebuild
new file mode 100644
index 000000000000..3a8beae1a370
--- /dev/null
+++ b/dev-python/joblib/joblib-1.0.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Tools to provide lightweight pipelining in Python"
+HOMEPAGE="https://joblib.readthedocs.io/en/latest/
+ https://github.com/joblib/joblib"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+ dev-python/cloudpickle[${PYTHON_USEDEP}]
+ dev-python/loky[${PYTHON_USEDEP}]
+"
+# joblib is imported by setup.py so we need ${RDEPEND}
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/threadpoolctl[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # unbundle
+ rm -r joblib/externals || die
+ sed -e "s:'joblib.externals[^']*',\?::g" -i setup.py || die
+ find -name '*.py' -exec \
+ sed -e 's:\(joblib\)\?\.externals\.::' \
+ -e 's:from \.externals ::' \
+ -i {} + || die
+
+ # https://github.com/joblib/joblib/issues/1115
+ sed -e 's:test_parallel_call_cached_function_defined_in_jupyter:_&:' \
+ -i joblib/test/test_memory.py || die
+
+ distutils-r1_python_prepare_all
+}