summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-09-03 01:34:57 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-09-03 01:35:32 +0200
commitdb2672a8b41d7cade4debe4d1e82cdeb0d25ada4 (patch)
treed4dcd06a45e4ae23e1f916c826af4763f1b32a2d
parentsys-apps/usbguard: 1.1.2 + EAPI 8 (diff)
downloadgentoo-db2672a8.tar.gz
gentoo-db2672a8.tar.bz2
gentoo-db2672a8.zip
sys-auth/AusweisApp2: add 1.24.1
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--sys-auth/AusweisApp2/AusweisApp2-1.24.1.ebuild51
-rw-r--r--sys-auth/AusweisApp2/Manifest1
2 files changed, 52 insertions, 0 deletions
diff --git a/sys-auth/AusweisApp2/AusweisApp2-1.24.1.ebuild b/sys-auth/AusweisApp2/AusweisApp2-1.24.1.ebuild
new file mode 100644
index 000000000000..f1b6cc8c799f
--- /dev/null
+++ b/sys-auth/AusweisApp2/AusweisApp2-1.24.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Official authentication app for German ID cards and residence permits"
+HOMEPAGE="https://www.ausweisapp.bund.de/"
+SRC_URI="https://github.com/Governikus/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="EUPL-1.2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig"
+
+RDEPEND="
+ dev-libs/openssl:0=
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtquickcontrols2:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwebsockets:5[qml]
+ dev-qt/qtwidgets:5
+ net-libs/http-parser:0=
+ sys-apps/pcsc-lite
+ virtual/udev"
+
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_SHARED_LIBS=OFF
+ -DQt=Qt5
+ )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/sys-auth/AusweisApp2/Manifest b/sys-auth/AusweisApp2/Manifest
index 3f7d4ec42746..a03ee2458ddd 100644
--- a/sys-auth/AusweisApp2/Manifest
+++ b/sys-auth/AusweisApp2/Manifest
@@ -1,2 +1,3 @@
DIST AusweisApp2-1.22.7.tar.gz 11406133 BLAKE2B 17bc9824035007bf62037562ebd38c2b3558660060c0eba302ac04e8e9d0eabc7c8cb69d064a1a02be213f91f823030e5afdab74d5614db2c1bc8318ca1f9f22 SHA512 4ea1d2c02e076121b340da6d16973de6dafe513d2e9c96b535063466c06137d8e2a325661478d0cfbd96f506a875dca8d4df6a53af657a8d2eb59e7ad7d1a472
DIST AusweisApp2-1.24.0.tar.gz 11472393 BLAKE2B 84bc4c75aeed01823c6301221898e51bbe31c579993b3e6d6d2e1197f3d53778f4d364e31dc9b71be0217ca15503fa510cce5c47e721cd6e07923d11ca6e2ac2 SHA512 80172f3b2a6cd2d80f991ce4c3825997a23725ae024653a77eca5083f8e2e82943b6f81978b77f6a9e6a99bf055867317bae2090a83555ca944ddbd696be53c3
+DIST AusweisApp2-1.24.1.tar.gz 11478160 BLAKE2B 6080542d7a4124e144978a83b68234781595b466ad25909af26d0a50902dfdc72170b2f946567826f63c3a704d6fbe13ebd81888ba62d761e631a79d3ed93d1f SHA512 cda1ecebff288c1bae29b7ec1d1270df609ea9b10824c6f1962fb9e21677149f11bbb447aa8a4b6176ec55bc953c1faee7f8a9ff34c8ae1be70e586d0662ffbc