summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-03-15 11:33:56 +0000
committerMarek Szuba <marecki@gentoo.org>2021-03-15 12:49:24 +0000
commitdb30e67f18623ad650f13671a41c241e7dcc4608 (patch)
treeac7586ad3160561405accd58d2ac3ffb931fb535
parentapp-emulation/protontricks: tag as ALLARCH in metadata (diff)
downloadgentoo-db30e67f18623ad650f13671a41c241e7dcc4608.tar.gz
gentoo-db30e67f18623ad650f13671a41c241e7dcc4608.tar.bz2
gentoo-db30e67f18623ad650f13671a41c241e7dcc4608.zip
dev-python/pyopencl: bump to 2021.1.3
Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--dev-python/pyopencl/Manifest1
-rw-r--r--dev-python/pyopencl/pyopencl-2021.1.3.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/pyopencl/Manifest b/dev-python/pyopencl/Manifest
index 13f75cb4bcae..c0dbc7aa13b8 100644
--- a/dev-python/pyopencl/Manifest
+++ b/dev-python/pyopencl/Manifest
@@ -1 +1,2 @@
DIST pyopencl-2020.3.1.tar.gz 357422 BLAKE2B de9cb6408e957e30f54797ce682ed17f3272dc82019bcd9a744a0696a7e344f47645a3549332da90e0bcc442f7a8ea9c6a12a375875a9728fa9814ca9d1a9b30 SHA512 459d6f060f4203e83276c47bf832f33fc4348dd59904ea55fe2a53684cb7c8eaad45875476d10dcb6653820f9cb1f7e013c6b854410b2040b2dfe847fc1f7658
+DIST pyopencl-2021.1.3.tar.gz 447070 BLAKE2B fcd8c5d06de9c14a7bcf3c3d37f89cb208adf0225cc88a081aefc86aac82a99026183f2c9975f34cd8247f784335e4ba6c0a09164ce01e527123b5c1dd952a76 SHA512 8799e73b3b1596387f619fd997f643228679fb1d9ab5ce6704da9df51922f96229efc98ab6b7a7361234848078b15bc67946a4188f4d17cb8760040b48b346e8
diff --git a/dev-python/pyopencl/pyopencl-2021.1.3.ebuild b/dev-python/pyopencl/pyopencl-2021.1.3.ebuild
new file mode 100644
index 000000000000..a9a305e869f5
--- /dev/null
+++ b/dev-python/pyopencl/pyopencl-2021.1.3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for OpenCL"
+HOMEPAGE="https://mathema.tician.de/software/pyopencl/
+ https://pypi.org/project/pyopencl/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples opengl"
+
+COMMON="dev-python/numpy[${PYTHON_USEDEP}]"
+RDEPEND="${COMMON}
+ >=dev-python/appdirs-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/decorator-3.2.0[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ >=dev-python/pytools-2017.6[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=virtual/opencl-2"
+DEPEND="${COMMON}
+ dev-python/pybind11[${PYTHON_USEDEP}]"
+
+# The test suite fails if there are no OpenCL platforms available, and
+# even if there is one (which requires the presence of both an OpenCL
+# runtime *and* hardware supported by it - simply emerging any runtime
+# is not enough) the vast majority of tests end up skipped because by
+# default the portage user hasn't got sufficient privileges to talk
+# to the GPU.
+RESTRICT="test"
+
+python_configure_all() {
+ local myconf=()
+ if use opengl; then
+ myconf+=(--cl-enable-gl)
+ fi
+
+ "${EPYTHON}" configure.py \
+ "${myconf[@]}"
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}