summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2019-08-09 13:27:59 -0400
committerMike Gilbert <floppym@gentoo.org>2019-08-09 14:27:49 -0400
commitdb5be9ad1db918407163716fdda4e5b0ada01775 (patch)
tree12d2a02f7a70eb11bf3a5e807d12c0f1819c9446
parentacct-user/polkitd: new user (102) (diff)
downloadgentoo-db5be9ad.tar.gz
gentoo-db5be9ad.tar.bz2
gentoo-db5be9ad.zip
sys-auth/polkit: depend on acc-user/polkitd
Package-Manager: Portage-2.3.71, Repoman-2.3.16_p24 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
-rw-r--r--sys-auth/polkit/polkit-0.116-r1.ebuild (renamed from sys-auth/polkit/polkit-0.116.ebuild)26
1 files changed, 8 insertions, 18 deletions
diff --git a/sys-auth/polkit/polkit-0.116.ebuild b/sys-auth/polkit/polkit-0.116-r1.ebuild
index b3fdcd99dd81..4b9c7900a5f5 100644
--- a/sys-auth/polkit/polkit-0.116.ebuild
+++ b/sys-auth/polkit/polkit-0.116-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit autotools pam pax-utils systemd user xdg-utils
+inherit autotools pam pax-utils systemd xdg-utils
DESCRIPTION="Policy framework for controlling privileges for system-wide services"
HOMEPAGE="https://www.freedesktop.org/wiki/Software/polkit https://gitlab.freedesktop.org/polkit/polkit"
@@ -17,6 +17,7 @@ IUSE="consolekit elogind examples gtk +introspection jit kde nls pam selinux sys
REQUIRED_USE="^^ ( consolekit elogind systemd )"
BDEPEND="
+ acct-user/polkitd
app-text/docbook-xml-dtd:4.1.2
app-text/docbook-xsl-stylesheets
dev-libs/gobject-introspection-common
@@ -40,6 +41,7 @@ DEPEND="
systemd? ( sys-apps/systemd:0=[policykit] )
"
RDEPEND="${DEPEND}
+ acct-user/polkitd
selinux? ( sec-policy/selinux-policykit )
"
PDEPEND="
@@ -62,16 +64,6 @@ QA_MULTILIB_PATHS="
usr/lib/polkit-1/polkit-agent-helper-1
usr/lib/polkit-1/polkitd"
-pkg_setup() {
- local u=polkitd
- local g=polkitd
- local h=/var/lib/polkit-1
-
- enewgroup ${g}
- enewuser ${u} -1 -1 ${h} ${g}
- esethome ${u} ${h}
-}
-
src_prepare() {
default
@@ -122,20 +114,18 @@ src_compile() {
src_install() {
default
- fowners -R polkitd:root /{etc,usr/share}/polkit-1/rules.d
-
- diropts -m0700 -o polkitd -g polkitd
- keepdir /var/lib/polkit-1
-
if use examples; then
insinto /usr/share/doc/${PF}/examples
doins src/examples/{*.c,*.policy*}
fi
+ diropts -m 0700 -o polkitd
+ keepdir /usr/share/polkit-1/rules.d
+
find "${ED}" -name '*.la' -delete || die
}
pkg_postinst() {
- chown -R polkitd:root "${EROOT}"/{etc,usr/share}/polkit-1/rules.d
- chown -R polkitd:polkitd "${EROOT}"/var/lib/polkit-1
+ chmod 0700 "${EROOT}"/{etc,usr/share}/polkit-1/rules.d
+ chown polkitd "${EROOT}"/{etc,usr/share}/polkit-1/rules.d
}