summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2016-12-03 15:53:00 +0900
committerBenda Xu <heroxbd@gentoo.org>2016-12-03 15:53:13 +0900
commitdb66f1581ef9988fe4eb434ddf256ffbd55771e8 (patch)
treeb89e4757dea67391cac29edf07339424fe265626
parentdev-ruby/rrdtool-bindings: add ruby21 (diff)
downloadgentoo-db66f158.tar.gz
gentoo-db66f158.tar.bz2
gentoo-db66f158.zip
app-misc/neofetch: support Prefix.
Package-Manager: portage-2.3.2
-rw-r--r--app-misc/neofetch/neofetch-1.9.1.ebuild11
1 files changed, 11 insertions, 0 deletions
diff --git a/app-misc/neofetch/neofetch-1.9.1.ebuild b/app-misc/neofetch/neofetch-1.9.1.ebuild
index c7bbb2e43e92..241401a24952 100644
--- a/app-misc/neofetch/neofetch-1.9.1.ebuild
+++ b/app-misc/neofetch/neofetch-1.9.1.ebuild
@@ -4,6 +4,8 @@
EAPI=6
+inherit prefix
+
DESCRIPTION="Simple information system script"
HOMEPAGE="https://github.com/dylanaraps/neofetch"
SRC_URI="https://github.com/dylanaraps/${PN}/archive/${PV}/${P}.tar.gz"
@@ -24,3 +26,12 @@ RDEPEND="${DEPEND}
media-libs/imlib2
media-gfx/imagemagick
)"
+
+src_prepare() {
+ hprefixify ${PN}
+ default
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+}