summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-11-27 11:04:53 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-11-27 12:07:51 +0100
commitdb68d18893d159debe758f0896a1633f9fe9feeb (patch)
treee2303d895a2ae22640591d62bafa12d03bf22e1f
parentkde-frameworks/ktexteditor: Drop 5.88.0 (r0) (diff)
downloadgentoo-db68d18893d159debe758f0896a1633f9fe9feeb.tar.gz
gentoo-db68d18893d159debe758f0896a1633f9fe9feeb.tar.bz2
gentoo-db68d18893d159debe758f0896a1633f9fe9feeb.zip
dev-libs/rinutils: 0.10.0 version bump
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-libs/rinutils/Manifest1
-rw-r--r--dev-libs/rinutils/rinutils-0.10.0.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-libs/rinutils/Manifest b/dev-libs/rinutils/Manifest
index 25e21185dff9..98c589ec2359 100644
--- a/dev-libs/rinutils/Manifest
+++ b/dev-libs/rinutils/Manifest
@@ -1 +1,2 @@
+DIST rinutils-0.10.0.tar.xz 17268 BLAKE2B 2c651b70295d10690ca76bf1349ce83728cd5398fe4babf821ee6a0d61d4c7d107c6c68595e19a841fb5baaa0057237357b3917acd61c02599781bf0252fd512 SHA512 d3780b34b4eda4658f65cf7555553430441fcd45fb2d4fdba22a8f48c0df09c6c0a4e9543262c797c0602e2f9bace2d3f41514ae202ee13183286c9fb1f38677
DIST rinutils-0.8.0.tar.xz 17112 BLAKE2B 362cf1e00092347e17a2a7da259316013af19f66ecb435b9e061355c7e3797b695b2334c86595380e70b6ea168fa50d4bcb055e75fa407601368d5a869a6d721 SHA512 06bbcdb5092762bf2ed92d4082eca17e8dc0e822ce8634f8ec8782fe7eccb4b954c081dbba3f1e2f72e0285607a813f020d4277af77accc43135bde50153359d
diff --git a/dev-libs/rinutils/rinutils-0.10.0.ebuild b/dev-libs/rinutils/rinutils-0.10.0.ebuild
new file mode 100644
index 000000000000..fc60f8875451
--- /dev/null
+++ b/dev-libs/rinutils/rinutils-0.10.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Set of C headers containing macros and static functions"
+HOMEPAGE="https://www.shlomifish.org/open-source/projects/ https://github.com/shlomif/rinutils"
+SRC_URI="https://github.com/shlomif/${PN}/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_APPLYING_RPATH=OFF
+ -DWITH_TEST_SUITE=OFF # tests require perl
+ )
+
+ cmake_src_configure
+}