summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffrey Lin <jeffrey@icurse.nl>2021-06-18 23:58:45 -0400
committerSam James <sam@gentoo.org>2022-01-19 02:36:46 +0000
commitdb6f1ad5edce356930cecb857d94a4fd58c7e9ee (patch)
tree58f8e27b6405ea07c6a95f55a2ac404916efddde
parentdev-java/failureaccess: initial import (diff)
downloadgentoo-db6f1ad5.tar.gz
gentoo-db6f1ad5.tar.bz2
gentoo-db6f1ad5.zip
dev-java/guava: add 30.1.1
Going back to SLOT 0 as upstream claims "APIs without `@Beta` will remain binary-compatible for the indefinite future." [1] [1]: https://github.com/google/guava#important-warnings Bug: https://bugs.gentoo.org/760111 Closes: https://bugs.gentoo.org/809974 Signed-off-by: Jeffrey Lin <jeffrey@icurse.nl> Closes: https://github.com/gentoo/gentoo/pull/21318 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-java/guava/Manifest1
-rw-r--r--dev-java/guava/guava-30.1.1.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-java/guava/Manifest b/dev-java/guava/Manifest
index 0b9dae4eb856..23aa60425858 100644
--- a/dev-java/guava/Manifest
+++ b/dev-java/guava/Manifest
@@ -1 +1,2 @@
DIST guava-20.0.tar.gz 2522092 BLAKE2B 2ca76a71d0c169b80bfaa3e9847b2e465c57aabc0a67622a69519808fa8455146228747dc20e999ebc20ef7cd5fec1cfa82f6c025e9378011619cfedbc2c7d6c SHA512 e89eee8e66502f208878af286c660393712b12fb37647ec70719ca7c5184686c8dc5fc59d45c1813d792ecad9421e2c077dab075f76b1907c04f9f6e80567ac9
+DIST guava-30.1.1.tar.gz 5404546 BLAKE2B 818ef4b17c4f0c8e92c327f046434a3bb428ac35d6e95edd6d6be558c755d138a8ac7f8ad2032073cad131890d8f838e896fff84ba217f8305be8bd65c619a48 SHA512 23b30d886a3200b8f998897ca7bc424b2d223a4fecb03ab644e08a989a85f008e30ef093055e6305c4148a1eb8919c407e35d19f492c5b189830bd115e9484f2
diff --git a/dev-java/guava/guava-30.1.1.ebuild b/dev-java/guava/guava-30.1.1.ebuild
new file mode 100644
index 000000000000..fef771e0e062
--- /dev/null
+++ b/dev-java/guava/guava-30.1.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Skeleton command:
+# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri https://codeload.github.com/google/guava/tar.gz/refs/tags/v30.1.1 --slot 0 --keywords "" --ebuild guava-30.1.1.ebuild
+
+EAPI=7
+
+JAVA_PKG_IUSE="doc source"
+#JAVA_TESTING_FRAMEWORKS="junit-5"
+MAVEN_ID="com.google.guava:guava:${PV}-jre"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="A collection of Google's core Java libraries"
+HOMEPAGE="https://github.com/google/guava"
+SRC_URI="https://codeload.github.com/google/guava/tar.gz/v${PV} -> ${P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# Common dependencies
+# POM: pom.xml
+# com.google.code.findbugs:jsr305:3.0.2 -> !!!groupId-not-found!!!
+# com.google.errorprone:error_prone_annotations:2.5.1 -> >=dev-java/error-prone-annotations-2.7.1:0
+# com.google.guava:failureaccess:1.0.1 -> >=dev-java/failureaccess-30.1.1:0
+# com.google.guava:listenablefuture:9999.0-empty-to-avoid-conflict-with-guava -> !!!artifactId-not-found!!!
+# com.google.j2objc:j2objc-annotations:1.3 -> !!!groupId-not-found!!!
+# org.checkerframework:checker-qual:3.8.0 -> >=dev-java/checker-framework-qual-3.14.0:0
+
+CDEPEND="
+ >=dev-java/error-prone-annotations-2.7.1:0
+ >=dev-java/failureaccess-30.1.1:0
+ dev-java/jsr305:0
+"
+
+DEPEND="
+ >=dev-java/checker-framework-qual-3.14.0:0
+ dev-java/j2objc-annotations:0
+ >=virtual/jdk-1.8:*
+ ${CDEPEND}
+"
+
+RDEPEND=">=virtual/jre-1.8:*
+ ${CDEPEND}
+"
+
+S="${WORKDIR}/${P}"
+
+JAVA_GENTOO_CLASSPATH="error-prone-annotations,failureaccess,jsr305"
+
+src_configure() {
+ JAVA_GENTOO_CLASSPATH_EXTRA="$(java-pkg_getjars --build-only checker-framework-qual,j2objc-annotations)"
+}
+
+JAVA_SRC_DIR="${PN}/src"
+
+JAVA_TEST_SRC_DIR="${PN}-tests/"