summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-09-05 14:58:18 -0400
committerMatt Turner <mattst88@gentoo.org>2023-09-05 16:28:26 -0400
commitdb7517524195194439fe72f6d536f4844f033103 (patch)
tree738f7d4c5c8b119158ed08bfa017a42df576f3cf
parentdev-lang/vala: Drop old versions (diff)
downloadgentoo-db7517524195194439fe72f6d536f4844f033103.tar.gz
gentoo-db7517524195194439fe72f6d536f4844f033103.tar.bz2
gentoo-db7517524195194439fe72f6d536f4844f033103.zip
dev-libs/gjs: Drop old versions
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--dev-libs/gjs/Manifest1
-rw-r--r--dev-libs/gjs/gjs-1.77.1.ebuild68
2 files changed, 0 insertions, 69 deletions
diff --git a/dev-libs/gjs/Manifest b/dev-libs/gjs/Manifest
index 54ed7debbf2d..8a1c3f1163b5 100644
--- a/dev-libs/gjs/Manifest
+++ b/dev-libs/gjs/Manifest
@@ -1,3 +1,2 @@
DIST gjs-1.76.2.tar.xz 646232 BLAKE2B 66466eeb5f956d5041f4e63ba977dc9a688455770c39bcedd63576f56fde9821ed3c827c470f7e3befbbf7828fbd197706637da458876ec129d6c16323e414e8 SHA512 26b024874ce69a6f58b5fabe006b8d5417971db9de00e21ecd352715b4535f405d162bb81c0cf6b20313f0f78833962080ac1cb9bd42cfff9cf6a74340458540
-DIST gjs-1.77.1.tar.xz 650292 BLAKE2B dde0f9073ef6f87e4f76002d69e6397ac94ae6a9c711b4a35378a8e56191c1a06ae1ee14db5a3078d3f1ec443c6eeb245bdcec7c8702c8e4a581e08530c81ce5 SHA512 2a94406725a59e05485ebfcc6ba6b2a0c26f40833a46d6520caff576dd8495a14eb733cf0788af1ea4b5c9c11edd692637db41f6350fb4a3bf2e1c01267130cc
DIST gjs-1.77.2.tar.xz 651784 BLAKE2B 9734fa9c0f4662c1bb233aef9398690295168c5758fe33a27bff5eebb0edee3dad6da28ebeb555337928278c99b5eb7fa1651445bdb8e212d9b672eb9ae08616 SHA512 2b804e6b039801b55e9d700794e390c927b00e2dd738dcada95867b3ba957e1a193367c2babb4a941b8aead301ca68e5b8ece655a13a3989708072a96600eba4
diff --git a/dev-libs/gjs/gjs-1.77.1.ebuild b/dev-libs/gjs/gjs-1.77.1.ebuild
deleted file mode 100644
index be95ea793e8f..000000000000
--- a/dev-libs/gjs/gjs-1.77.1.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit flag-o-matic gnome.org meson virtualx
-
-DESCRIPTION="Javascript bindings for GNOME"
-HOMEPAGE="https://wiki.gnome.org/Projects/Gjs https://gitlab.gnome.org/GNOME/gjs"
-
-LICENSE="MIT || ( MPL-1.1 LGPL-2+ GPL-2+ )"
-SLOT="0"
-IUSE="+cairo examples readline sysprof test"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-libs/glib-2.66.0:2
- dev-libs/libffi:=
- >=dev-libs/gobject-introspection-1.71.1:=
- >=dev-lang/spidermonkey-102.2.0:102
- cairo? ( x11-libs/cairo[X,glib] )
- readline? ( sys-libs/readline:0= )
-"
-DEPEND="${RDEPEND}
- sysprof? ( >=dev-util/sysprof-capture-3.40.1:4 )
- test? (
- sys-apps/dbus
- >=x11-libs/gtk+-3.20:3[introspection]
- )
-"
-BDEPEND="
- virtual/pkgconfig
-"
-
-src_configure() {
- append-cppflags -DG_DISABLE_CAST_CHECKS
-
- # On musl, it's required that either gjs, pixman or gnome-shell to be built
- # with a larger stack otherwise librsvg fails to render a particular SVG, as
- # a result we fail to get gdm or gnome-shell running (greeted with a fail
- # whale screen). The bug has been reported to librsvg. This is ideally just
- # a temporary workaround until we understand what exactly needs a larger
- # stack size, as it's not sufficient to do just librsvg.
- #
- # Please refer to:
- # https://gitlab.gnome.org/GNOME/librsvg/-/issues/686
- # https://gitlab.gnome.org/GNOME/librsvg/-/issues/874
- #
- # TODO: Find an actual fix instead of increasing the stack
- use elibc_musl && append-ldflags -Wl,-z,stack-size=2097152
-
- # FIXME: add systemtap/dtrace support, like in glib:2
- local emesonargs=(
- $(meson_feature cairo)
- $(meson_feature readline)
- $(meson_feature sysprof profiler)
- -Dinstalled_tests=false
- $(meson_use !test skip_dbus_tests)
- $(meson_use !test skip_gtk_tests)
- -Db_pch=True # TODO this has to go
- )
- meson_src_configure
-}
-
-src_test() {
- virtx meson_src_test
-}