summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-31 16:24:47 +0100
committerMichał Górny <mgorny@gentoo.org>2022-10-31 16:49:15 +0100
commitdb94d35b8036d41bf9f41c1ec14c38e3af9b2af1 (patch)
treedfefa6f1d2cc78e59cf3997b92dd6f9dd6a89e31
parentdev-python/argparse-manpage: Bump to v4 (diff)
downloadgentoo-db94d35b.tar.gz
gentoo-db94d35b.tar.bz2
gentoo-db94d35b.zip
dev-python/yappi: Bump to 1.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/yappi/Manifest1
-rw-r--r--dev-python/yappi/yappi-1.4.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/yappi/Manifest b/dev-python/yappi/Manifest
index f99179deb040..c0c1e736d320 100644
--- a/dev-python/yappi/Manifest
+++ b/dev-python/yappi/Manifest
@@ -1 +1,2 @@
DIST yappi-1.3.6.gh.tar.gz 937785 BLAKE2B eb98d51f450091e66429affcc12f4329629bfc466dd8db9c5e77f5385a6b7bb551fd336825d64d94141ae41129618025a716a1b4e0718b022e67978330900bf0 SHA512 f55555042363581535eb4dfca096b1c698fb32720e5d1740d72ee7290f162ec44f0ed05936d6d85fc63f347e6be19b182550bd6e6593b65616d11d109fce8cbc
+DIST yappi-1.4.0.gh.tar.gz 938290 BLAKE2B 98a9c82d101e64f70f589b51ee461e1967c0fada75ab98e0de8f0446254e7ad73e25b842c85464953b9f81fc54d2007151dfc91e4176068a7cb320176c8828d2 SHA512 c557c67cfce29db1a526a2d385af28cd241eae46a653e9b4f7308a6f52ff1ede49b9211af09889c63eae3eeb38d55813a8026161b1184fccf4db4add8a022541
diff --git a/dev-python/yappi/yappi-1.4.0.ebuild b/dev-python/yappi/yappi-1.4.0.ebuild
new file mode 100644
index 000000000000..5e588ab2fbb2
--- /dev/null
+++ b/dev-python/yappi/yappi-1.4.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Yet Another Python Profiler"
+HOMEPAGE="
+ https://pypi.org/project/yappi/
+ https://github.com/sumerc/yappi/
+"
+SRC_URI="
+ https://github.com/sumerc/yappi/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/gevent[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+PATCHES=(
+ "${FILESDIR}/yappi-1.2.5-warnings.patch"
+)
+
+python_test() {
+ local -x PYTHONPATH=tests
+ eunittest
+}