summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-08 00:20:28 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-08 01:45:17 +0100
commitdbcfca9e2a120bed48063b160d545dc67c75901c (patch)
tree793bfff33449332ffd4cc900d53b079af582cdd1
parentnet-firewall/pglinux: Fix UnnecessarySlashStrip (diff)
downloadgentoo-dbcfca9e2a120bed48063b160d545dc67c75901c.tar.gz
gentoo-dbcfca9e2a120bed48063b160d545dc67c75901c.tar.bz2
gentoo-dbcfca9e2a120bed48063b160d545dc67c75901c.zip
dev-python/botocore: Bump to 1.19.51
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.19.51.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 3276b825289e..9f8bc511cab1 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -2,3 +2,4 @@ DIST botocore-1.19.30.tar.gz 7224700 BLAKE2B 50712be7e6e4a8a22607d567a8d227bbc6d
DIST botocore-1.19.36.tar.gz 7291325 BLAKE2B d1f79298a0f47d704418cac8390a5d500b1f300fc9bdbc0b215a3630adb70c29a951c6dff2a6ebfde42872cbc3af4c442d09fa0233b2c957521e6a5e05816c60 SHA512 420ad7c59496b2b74ba6ecde8dc40ac3e47c5676335f7471448fcdde5b70bda3bd7516963788d8a7a940aaa9cf488b6529e6fbd2842806f58520cd8e2dc15a60
DIST botocore-1.19.43.tar.gz 7374325 BLAKE2B 7def5221bee4774a6b8a33e6499e499588ff18f8b144e669bdf9b01ae4a3e370e3aed5a3a960360123e57299da9b0293aa8da9108fe114f8ae34521b2920f479 SHA512 a1b97cbb779d8c8fe3495dd18d3d635e38c5c49e5b5fb31b7764029cf3063a7fda44711defc45783b3afb844bead46e686705af57472a7ff27af8b7e21645ad5
DIST botocore-1.19.50.tar.gz 7382888 BLAKE2B 7de2ef7a7d051427191b13cdd47d3ebd9b4de505e3e17aa7dfb42de9a5eebffa2f06317a559631d219acc4380cc68c7dcfa1d6b0dc9cb123b2fa0315dd81df4e SHA512 7d1a8ff53e22fc265d8ac6492c0607f8948c9aa5862abaded93c605c3a3e4e98e535308e5ec1500a480636e03dbc3d849ec2b1dbf0efb22dffa841ce1cb551f9
+DIST botocore-1.19.51.tar.gz 7385977 BLAKE2B 505dd818f001b11f248582ec0f24bb7aac2e0d9bd343670d23eeb7ec14420bb7b97835a737de9464ffe5d76a43d311feee0e19860b35fddfc8398da4d00739b3 SHA512 03209809f75a5916df03d312fb877a3e129a8677ebd4e7785bbf8311a55823fe6c8faa62c78908fe0d003dd1695e0593a961d73c98dec2a8a7260ce53d6603cf
diff --git a/dev-python/botocore/botocore-1.19.51.ebuild b/dev-python/botocore/botocore-1.19.51.ebuild
new file mode 100644
index 000000000000..fa25adc1c1ff
--- /dev/null
+++ b/dev-python/botocore/botocore-1.19.51.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}