summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-22 00:48:23 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-22 00:49:55 +0100
commitdbd45c3117201a83ccbfb7757afaba5aa1c189a2 (patch)
treed32a345c2a1bcb88278a19fa5a8c2ae92ca079aa
parentnet-libs/libomemo: Add flag static-libs (diff)
downloadgentoo-dbd45c3117201a83ccbfb7757afaba5aa1c189a2.tar.gz
gentoo-dbd45c3117201a83ccbfb7757afaba5aa1c189a2.tar.bz2
gentoo-dbd45c3117201a83ccbfb7757afaba5aa1c189a2.zip
xfce-extra/xfce4-panel-profiles: Bump to 1.0.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--xfce-extra/xfce4-panel-profiles/Manifest1
-rw-r--r--xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.13.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-panel-profiles/Manifest b/xfce-extra/xfce4-panel-profiles/Manifest
index c2c8c0025f1a..583cb39f755a 100644
--- a/xfce-extra/xfce4-panel-profiles/Manifest
+++ b/xfce-extra/xfce4-panel-profiles/Manifest
@@ -1 +1,2 @@
DIST xfce4-panel-profiles-1.0.12.tar.bz2 83399 BLAKE2B 82f62b7472ae8e271a8c41151c2153e62f1589b868cd4a682f0e56acfa3aedcb6104b14ef99f776d09fe6ac854420905ce335c9d3d05d524570db70d847731d8 SHA512 cf308a1a9d68832a3b907787754791d6e8b227400d21a0bde2ed99d7afbb64c6137bbe4b7ab6ceb4c896a67ecbac29d41089c857d432467cbaba631a7ef77505
+DIST xfce4-panel-profiles-1.0.13.tar.bz2 86671 BLAKE2B 0bf2d39aa2d7d21a99a9a7245e5de9e717b628f0eded2736db70cc87c4f6e1e1d10aecdc6586c43c6355747e68a2ceb1920d5309bf38ede07c1167c590dc116f SHA512 648324e5dd95ab0a513829d7d816e2113ae677d9ad6ac9b01d73c6b4105b54d5e773150d5440ad35a37b4dc75478f40a24e0223decf940f3cf658241547ce75a
diff --git a/xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.13.ebuild b/xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.13.ebuild
new file mode 100644
index 000000000000..27462fad6085
--- /dev/null
+++ b/xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.13.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit python-single-r1 xdg-utils
+
+DESCRIPTION="Simple application to manage Xfce panel layouts"
+HOMEPAGE="https://git.xfce.org/apps/xfce4-panel-profiles/about/"
+SRC_URI="https://archive.xfce.org/src/apps/xfce4-panel-profiles/$(ver_cut 1-2)/${P}.tar.bz2"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+BDEPEND="${PYTHON_DEPS}"
+RDEPEND="${BDEPEND}
+ dev-libs/gobject-introspection
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+ ')
+ x11-libs/gtk+:3[introspection]
+ xfce-base/libxfce4ui[introspection]
+ xfce-base/xfce4-panel"
+
+src_configure() {
+ # home-made configure script, yay!
+ ./configure \
+ --prefix="${EPREFIX}/usr" \
+ --python="${EPYTHON}" \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}