summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-08-26 09:45:53 +0100
committerMarek Szuba <marecki@gentoo.org>2022-08-26 09:47:55 +0100
commitdbead06bf1293b255672bdc2627343cad93ad6f2 (patch)
treea26e481c3075a516387b8cb28d28979e6068392b
parentnet-misc/anydesk: 6.2.0 (diff)
downloadgentoo-dbead06b.tar.gz
gentoo-dbead06b.tar.bz2
gentoo-dbead06b.zip
app-backup/borgmatic: add 1.7.1
Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--app-backup/borgmatic/Manifest1
-rw-r--r--app-backup/borgmatic/borgmatic-1.7.1.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/app-backup/borgmatic/Manifest b/app-backup/borgmatic/Manifest
index 7c2a851ea67e..04bdd7cdd05a 100644
--- a/app-backup/borgmatic/Manifest
+++ b/app-backup/borgmatic/Manifest
@@ -1,2 +1,3 @@
DIST borgmatic-1.6.1.tar.gz 300375 BLAKE2B b56c31da62591b8bfd3c0146e77cab7ab28f942c59ca0f6cf7342d80bc31249dfcbd59fae13025a0fe464de326b6758169be983d2b741ecc37062961541fb892 SHA512 c48fb89167ce188feeb9d51ae9caabf985f9c583d09840d3dd4aaf772a4acbd3c22399958740820b9fbf61603769a604dc92b72448e2c7196fae855549f3c6d5
DIST borgmatic-1.6.6.tar.gz 323601 BLAKE2B b40d8f00e3b7bbd343336cf4c6992e34d8289de451c184717827e8e43519b84d4bb9b8cff6a835a7cc502d2e93045f0196d744e4b6ad800de1276e11c3189cec SHA512 f1a6dfa344ebee89e88f1aa6b43d8493c80815c637d8e0f7f6314462fd511b576e62246d957023ab2f9a68875d2818e2b8ef00cbf3339dc35a93d6ebad0bed19
+DIST borgmatic-1.7.1.tar.gz 333344 BLAKE2B 0076fac9a01715d24dd8dfa9ca93099c94cfe33f65850c089a337b3f95b6c52706d0e6b15200532c0fcca9401f97c02d6ebabd700e42f5d9bb3516e04e7fa0a4 SHA512 6cf0c71a88f0f893f63bb2de7c466af87cad3eff57a6105a6bece2c1acddb962fa14c4d63944c37a3465dc3c09151003daa28e5045a897875552ff7de227d5fc
diff --git a/app-backup/borgmatic/borgmatic-1.7.1.ebuild b/app-backup/borgmatic/borgmatic-1.7.1.ebuild
new file mode 100644
index 000000000000..85a3ea05cce7
--- /dev/null
+++ b/app-backup/borgmatic/borgmatic-1.7.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 systemd
+
+DESCRIPTION="Automatically create, prune and verify backups with borgbackup"
+HOMEPAGE="https://torsion.org/borgmatic/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv"
+
+# borg is called as an external tool, hence no pythonic stuff
+RDEPEND="app-backup/borgbackup
+ $(python_gen_cond_dep '
+ <dev-python/colorama-0.5[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ <dev-python/ruamel-yaml-0.18.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ')"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ >=dev-python/flexmock-0.10.10[${PYTHON_USEDEP}]
+ ')
+ )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.5.1-no_test_coverage.patch
+ "${FILESDIR}"/${PN}-1.5.16-systemd_service_bin_path.patch
+)
+
+# test_borgmatic_version_matches_news_version tries to run the 'borgmatic'
+# executable so making it work would require passing --install
+# to distutils_enable_tests. Given that this is the only test requiring
+# this and that all it does is make sure the NEWS file has been updated
+# for the current version, just skip it.
+EPYTEST_DESELECT=(
+ tests/integration/commands/test_borgmatic.py::test_borgmatic_version_matches_news_version
+)
+
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+ systemd_dounit sample/systemd/borgmatic.{service,timer}
+ keepdir /etc/borgmatic
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "To generate a sample configuration file, run:"
+ elog " generate-borgmatic-config"
+ else
+ ewarn "Please note that since version 1.7.0 ${PN} no longer supports old-style command-line action flags like '--create', '--list', etc."
+ ewarn "Make sure all your scripts use actions, e.g. 'create', 'list' and so on"
+ fi
+ elog
+ elog "Systemd users wishing to periodically run borgmatic can use the provided timer and service units."
+}