summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-01 08:07:30 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-01 09:32:00 +0100
commitdbf0a72c4b499a2b371026fa6c496378ab18a20b (patch)
tree014ee889b6651131c27be9c6b2f61a2a9c8ac5b1
parentsci-libs/volk: enable py3.10 (diff)
downloadgentoo-dbf0a72c.tar.gz
gentoo-dbf0a72c.tar.bz2
gentoo-dbf0a72c.zip
dev-python/hypothesis: Bump to 6.24.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.24.1.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index efa74efc5699..1c128c496f75 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -2,3 +2,4 @@ DIST hypothesis-python-6.22.0.tar.gz 9166539 BLAKE2B 386c7fd4f9ff0d4d199f686f257
DIST hypothesis-python-6.23.2.tar.gz 9167318 BLAKE2B 0a1ccf0235c64dd69705e48f67c132021898a024e8ae035d2ffc8a416c45443931ffff4a67a13f1c1ee7bbc2201e6f4ca5363568f0ed2ea4743ae46569e45ef1 SHA512 704b8d8c15e1fd510206c8d07f6a0f0bc81249bbc036978e4864e8ce234e35bab89069b0d5a0e958c57fe31fdb63fcc454502ac633d6fd986aaea9841383f36b
DIST hypothesis-python-6.23.4.tar.gz 9167755 BLAKE2B c953e54abf704f1e4d8ab74abb046c19a9bd7e1f32ae7a17133d2b042ce5a06063999249284e0afa2d650575b69bca646e52bfdb3648ac2972077f4d74b82557 SHA512 9d178545bb6c6cb8ecebbaeefea16b5d7390691536b724742b94a94d881ccc4b2f1b82f865fd7860b0f9b688c19aa60929aabf2e7ba8ce255ee5bbf79ed873ab
DIST hypothesis-python-6.24.0.tar.gz 9168076 BLAKE2B 550b42c39712f47c74d935b24a5bba98a50ac38b839d94a487a655ce1938d382a30b443107deadaf2b97fb89ea8f53df5aaceaabf23e0f8e221a45120163cb91 SHA512 2bc815876a295b366c4b167e7e13bfe11683b0d0111263f6129ab0ef441151554298c43bf1caa4345eff2d7e9a11bd63450e7b1bf00f8ece4dd49b3f4469defa
+DIST hypothesis-python-6.24.1.tar.gz 9168432 BLAKE2B 4d8e548cd001cd279076990034716692983b799e81063e377fa3f5636671d2bceba718f7ba05d97843968610d2c0d444ad7bb00a774f59aad9b1f17210222001 SHA512 ae321f386be0b9e5b79630b98fc14a24ba3c9285ec9bab880c52fe462800a952bfff07a398199080a59c6e7c32f0700a6f1f36692bb6f3d332cb817441ff5d6f
diff --git a/dev-python/hypothesis/hypothesis-6.24.1.ebuild b/dev-python/hypothesis/hypothesis-6.24.1.ebuild
new file mode 100644
index 000000000000..119bf66a0917
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.24.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' python3_{7..9})
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+distutils_enable_tests --install pytest
+
+python_prepare() {
+ if ! use cli || ! has "${EPYTHON}" python3.{7..9}; then
+ sed -i -e '/console_scripts/d' setup.py || die
+ fi
+}
+
+python_test() {
+ distutils_install_for_testing
+ epytest tests/cover tests/pytest tests/quality \
+ -p no:pytest-describe \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}