summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2019-01-27 18:03:47 +0100
committerAndrey Utkin <andrey_utkin@gentoo.org>2019-01-28 01:50:07 +0000
commitdbf6d26091cc8c3ff2e5ef24b91810846e236518 (patch)
treeb36c56c4d8a44cf09e478822438b364ad1b290b4
parentnet-im/swift: drop old version (diff)
downloadgentoo-dbf6d26091cc8c3ff2e5ef24b91810846e236518.tar.gz
gentoo-dbf6d26091cc8c3ff2e5ef24b91810846e236518.tar.bz2
gentoo-dbf6d26091cc8c3ff2e5ef24b91810846e236518.zip
net-im/spectrum2: bump to version 2.0.10
Also bumped to EAPI=7. Package-Manager: Portage-2.3.56, Repoman-2.3.12 Signed-off-by: Conrad Kostecki <conrad@kostecki.com> Signed-off-by: Andrey Utkin <andrey_utkin@gentoo.org>
-rw-r--r--net-im/spectrum2/Manifest1
-rw-r--r--net-im/spectrum2/spectrum2-2.0.10.ebuild122
2 files changed, 123 insertions, 0 deletions
diff --git a/net-im/spectrum2/Manifest b/net-im/spectrum2/Manifest
index f17b84864021..d19142bc269d 100644
--- a/net-im/spectrum2/Manifest
+++ b/net-im/spectrum2/Manifest
@@ -1 +1,2 @@
+DIST spectrum2-2.0.10.tar.gz 844427 BLAKE2B cb57bede4bfe996219ca5d0e62167643eb51fe44fd607400de8c2640f3892af9d089b6d62d7c25485049ef2a37066b3f6de46bfb5a6b7107fef6eb31dcf736f3 SHA512 b74f6f543aaa923a589b8b0b1007dec260af6fb66e5475c0294216713568dd93f4f52f39e6cbe4c6263efb0a479ac4d8095709d758e4faac81fc7d4712fd0b2c
DIST spectrum2-2.0.9.tar.gz 842688 BLAKE2B 32cdb95c161aa97338895fb144200ac94d200aefb58300a8f55b03457b3aae1a0ef4a60311f0e2be8e3f3e331625d04ecd61a9583d07794c4398762e1348b939 SHA512 f111133d3d327619ebbeeaa8c329b09dbdbef9c66ec7bc06eb6eac8c54e144cbf2d81d2751699bf97ae1d1bf0a94581f3971394a7f06b9a4d69f6248f1497982
diff --git a/net-im/spectrum2/spectrum2-2.0.10.ebuild b/net-im/spectrum2/spectrum2-2.0.10.ebuild
new file mode 100644
index 000000000000..285dd6d49820
--- /dev/null
+++ b/net-im/spectrum2/spectrum2-2.0.10.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit cmake-utils python-single-r1 systemd user
+
+DESCRIPTION="An open source instant messaging transport"
+HOMEPAGE="https://www.spectrum.im"
+SRC_URI="https://github.com/SpectrumIM/spectrum2/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug doc frotz irc mysql postgres purple sms +sqlite test twitter whatsapp xmpp"
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+RDEPEND="
+ dev-libs/boost:=
+ dev-libs/expat
+ dev-libs/libev:=
+ dev-libs/log4cxx
+ dev-libs/jsoncpp:=
+ dev-libs/openssl:0=
+ dev-libs/popt
+ dev-libs/protobuf:=
+ net-dns/libidn:0=
+ net-im/swift:=
+ net-misc/curl
+ sys-libs/zlib:=
+ frotz? ( !games-engines/frotz )
+ irc? ( net-im/libcommuni )
+ mysql? (
+ || (
+ dev-db/mariadb-connector-c
+ dev-db/mysql-connector-c
+ )
+ )
+ postgres? ( dev-libs/libpqxx:= )
+ purple? (
+ dev-libs/glib
+ net-im/pidgin:=
+ )
+ sms? ( app-mobilephone/smstools )
+ sqlite? ( dev-db/sqlite:3 )
+ twitter? ( net-misc/curl )
+ whatsapp? ( net-im/transwhat )"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ ${RDEPEND}
+ doc? ( app-doc/doxygen )
+ test? (
+ dev-python/sleekxmpp[${PYTHON_USEDEP}]
+ dev-util/cppunit
+ net-irc/ngircd
+ )
+"
+
+PATCHES=( "${FILESDIR}/${PN}-2.0.9-remove_debug_cflags.patch" )
+
+# Tests are currently restricted, as they do completly fail
+RESTRICT="test"
+
+pkg_setup() {
+ enewgroup spectrum
+ enewuser spectrum -1 -1 /var/lib/spectrum2 spectrum
+
+ use test && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ # Respect users LDFLAGS
+ sed -i -e "s/-Wl,-export-dynamic/& ${LDFLAGS}/" spectrum/src/CMakeLists.txt || die
+
+ # Respect users CFLAGS, when compiling for debug mode
+ # Since Spectrum2 searches for a qt4 compiled libcommuni,
+ # it must be patched, to find the qt5 compiled libcommuni,
+ # See: https://github.com/SpectrumIM/spectrum2/pull/253
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ use debug && CMAKE_BUILD_TYPE="Debug"
+
+ local mycmakeargs=(
+ -DENABLE_DOCS="$(usex doc)"
+ -DENABLE_FROTZ="$(usex frotz)"
+ -DENABLE_IRC="$(usex irc)"
+ -DENABLE_MYSQL="$(usex mysql)"
+ -DENABLE_PQXX="$(usex postgres)"
+ -DENABLE_PURPLE="$(usex purple)"
+ -DENABLE_SMSTOOLS3="$(usex sms)"
+ -DENABLE_SQLITE3="$(usex sqlite)"
+ -DENABLE_TESTS="$(usex test)"
+ -DENABLE_TWITTER="$(usex twitter)"
+ -DENABLE_XMPP="$(usex xmpp)"
+ -DLIB_INSTALL_DIR="$(get_libdir)"
+ )
+
+ cmake-utils_src_configure
+}
+
+src_test() {
+ cd tests/libtransport && "${EPYTHON}" ../start.py || die
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ diropts -o spectrum -g spectrum
+ keepdir /var/log/spectrum2 /var/lib/spectrum2
+ diropts
+
+ newinitd "${FILESDIR}"/spectrum2.initd spectrum2
+ systemd_newunit "${FILESDIR}"/spectrum2.service spectrum2.service
+ systemd_newtmpfilesd "${FILESDIR}"/spectrum2.tmpfiles spectrum2.conf
+
+ einstalldocs
+}