summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2022-02-27 11:44:05 -0600
committerWilliam Hubbs <williamh@gentoo.org>2022-02-27 11:44:38 -0600
commitdc0e098d124e67185b34e2b6e382272334e1bee3 (patch)
treedd1ceb3c2113ef34c2705ee1d8d8555c7bb319e2
parentx11-misc/py3status: version bump (diff)
downloadgentoo-dc0e098d124e67185b34e2b6e382272334e1bee3.tar.gz
gentoo-dc0e098d124e67185b34e2b6e382272334e1bee3.tar.bz2
gentoo-dc0e098d124e67185b34e2b6e382272334e1bee3.zip
mail-client/aerc: 0.8.2-r1 bump
Closes: https://bugs.gentoo.org/834145 Closes: https://bugs.gentoo.org/834146 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: William Hubbs <williamh@gentoo.org>
-rw-r--r--mail-client/aerc/aerc-0.8.2-r1.ebuild71
-rw-r--r--mail-client/aerc/files/0001-fix-desktop-file.patch38
2 files changed, 109 insertions, 0 deletions
diff --git a/mail-client/aerc/aerc-0.8.2-r1.ebuild b/mail-client/aerc/aerc-0.8.2-r1.ebuild
new file mode 100644
index 000000000000..a85c8b992279
--- /dev/null
+++ b/mail-client/aerc/aerc-0.8.2-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module xdg
+
+DESCRIPTION="Email client for your terminal"
+HOMEPAGE="https://aerc-mail.org"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.sr.ht/~rjarry/aerc"
+else
+ SRC_URI="https://git.sr.ht/~rjarry/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-vendor.tar.xz"
+ KEYWORDS="~amd64 ~ppc64"
+fi
+
+LICENSE="Apache-2.0 BSD BSD-2 MIT"
+SLOT="0"
+IUSE="notmuch"
+
+DEPEND="notmuch? ( net-mail/notmuch:= )"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ >=app-text/scdoc-1.9.7
+ >=dev-lang/go-1.13
+"
+
+PATCHES=(
+ "${FILESDIR}"/0001-fix-desktop-file.patch
+)
+
+src_unpack() {
+ if [[ ${PV} == *9999 ]]; then
+ git-r3_src_unpack
+ go-module_live_vendor
+ else
+ go-module_src_unpack
+ fi
+}
+
+src_compile() {
+ LDFLAGS= \
+ emake GOFLAGS="-mod=vendor $(usex notmuch "-tags=notmuch" "")" \
+ PREFIX="${EPREFIX}/usr"VERSION=${PV} all
+}
+
+src_install() {
+ emake PREFIX="${EPREFIX}/usr" DESTDIR="${ED}" install
+ einstalldocs
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "If you want to allow your users to activate html email"
+ elog "processing via w3m as shown in the tutorial, make sure you"
+ elog "emerge net-proxy/dante and www-client/w3m"
+ fi
+
+ local v
+ for v in ${REPLACING_VERSIONS}; do
+ if ver_test $v -lt 0.3.0-r1; then
+ elog "The dependencies on net-proxy/dante and www-client/w3m"
+ elog "have been removed since they are optional."
+ elog "Please emerge them before the next --depclean if you"
+ elog "need to use them."
+ fi
+ done
+ xdg_pkg_postinst
+}
diff --git a/mail-client/aerc/files/0001-fix-desktop-file.patch b/mail-client/aerc/files/0001-fix-desktop-file.patch
new file mode 100644
index 000000000000..935e98034fbc
--- /dev/null
+++ b/mail-client/aerc/files/0001-fix-desktop-file.patch
@@ -0,0 +1,38 @@
+From 39f7819cfe26f00921cb653a5d34974ce7af8d55 Mon Sep 17 00:00:00 2001
+From: William Hubbs <w.d.hubbs@gmail.com>
+Date: Sun, 27 Feb 2022 11:15:54 -0600
+Subject: [PATCH aerc] fix desktop file
+
+This was reported to me by a user of Gentoo (I'm a maintainer there) in
+the following bug.
+
+Bug: https://bugs.gentoo.org/834145
+Signed-off-by: William Hubbs <w.d.hubbs@gmail.com>
+---
+ contrib/aerc.desktop | 5 ++---
+ 1 file changed, 2 insertions(+), 3 deletions(-)
+
+diff --git a/contrib/aerc.desktop b/contrib/aerc.desktop
+index 235da5a..ddd43ae 100644
+--- a/contrib/aerc.desktop
++++ b/contrib/aerc.desktop
+@@ -13,6 +13,8 @@ Type=Application
+ Icon=utilities-terminal
+ Terminal=true
+ Exec=aerc %u
++Actions=compose;
++MimeType=x-scheme-handler/mailto;
+
+ [Desktop Action compose]
+ Name=Compose mail
+@@ -20,7 +22,4 @@ Name=Compose mail
+ # enable as default mailto: handler using
+ # xdg-mime default aerc.desktop x-scheme-handler/mailto
+ Exec=aerc %u
+-MimeType=x-scheme-handler/mailto;
+-Type=Application
+ Icon=utilities-terminal
+-Terminal=true
+--
+2.34.1
+