summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2020-08-29 20:58:54 -0400
committerAaron Bauman <bman@gentoo.org>2020-08-29 20:59:34 -0400
commitdc1bf48271799c32439727e29fd2738ebfdfaa8e (patch)
treeecbf27dda455ad00166f3eae008718cc5279974b
parentnet-misc/socket-burst-dampener: Remove old version (diff)
downloadgentoo-dc1bf482.tar.gz
gentoo-dc1bf482.tar.bz2
gentoo-dc1bf482.zip
app-text/pdf2html: port to EAPI7
* Fix QA issues on echo calls * Fix patches * Use PATCHES=( ) Signed-off-by: Aaron Bauman <bman@gentoo.org>
-rw-r--r--app-text/pdf2html/files/pdf2html-1.4-gentoo.patch4
-rw-r--r--app-text/pdf2html/files/pdf2html-1.4-libpng15.patch4
-rw-r--r--app-text/pdf2html/pdf2html-1.4.ebuild22
3 files changed, 15 insertions, 15 deletions
diff --git a/app-text/pdf2html/files/pdf2html-1.4-gentoo.patch b/app-text/pdf2html/files/pdf2html-1.4-gentoo.patch
index 715b829b1c2a..de1b4b4f379f 100644
--- a/app-text/pdf2html/files/pdf2html-1.4-gentoo.patch
+++ b/app-text/pdf2html/files/pdf2html-1.4-gentoo.patch
@@ -1,5 +1,5 @@
---- pbm2png.c.orig 2003-09-16 20:12:55.000000000 +0900
-+++ pbm2png.c 2004-02-21 22:09:57.415786664 +0900
+--- a/pbm2png.c
++++ b/pbm2png.c
@@ -145,15 +145,13 @@
sprintf(string,"%s%d.html",basename,index);
f=fopen(string,"w");
diff --git a/app-text/pdf2html/files/pdf2html-1.4-libpng15.patch b/app-text/pdf2html/files/pdf2html-1.4-libpng15.patch
index 72a0e1b65af9..7e5635332df8 100644
--- a/app-text/pdf2html/files/pdf2html-1.4-libpng15.patch
+++ b/app-text/pdf2html/files/pdf2html-1.4-libpng15.patch
@@ -1,5 +1,5 @@
---- pbm2png.c
-+++ pbm2png.c
+--- a/pbm2png.c
++++ b/pbm2png.c
@@ -23,6 +23,7 @@
#include <stdlib.h>
#include <string.h>
diff --git a/app-text/pdf2html/pdf2html-1.4.ebuild b/app-text/pdf2html/pdf2html-1.4.ebuild
index 745c02563434..3dfc5cf35421 100644
--- a/app-text/pdf2html/pdf2html-1.4.ebuild
+++ b/app-text/pdf2html/pdf2html-1.4.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-inherit eutils toolchain-funcs
+EAPI=7
+
+inherit toolchain-funcs
DESCRIPTION="Converts pdf files to html files"
HOMEPAGE="http://atrey.karlin.mff.cuni.cz/~clock/twibright/pdf2html/"
@@ -19,22 +20,21 @@ RDEPEND="${DEPEND}
app-text/ghostscript-gpl
>=media-gfx/imagemagick-6"
-src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-gentoo.patch \
- "${FILESDIR}"/${P}-libpng15.patch
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+ "${FILESDIR}"/${P}-libpng15.patch
+)
src_compile() {
tc-export CC
# Rewrite the Makefile as that's simpler
- echo "LDLIBS=-lpng" > Makefile
- echo "all: pbm2png" >> Makefile
+ echo "LDLIBS=-lpng" > Makefile || die "echo failed"
+ echo "all: pbm2png" >> Makefile || die "echo #2 failed"
emake
- echo "pbm2eps9: pbm2eps9.o printer.o" > Makefile
+ echo "pbm2eps9: pbm2eps9.o printer.o" > Makefile || die "echo #3 failed"
emake pbm2eps9
- echo "cp \"${EPREFIX}\"/usr/share/${P}/*.png ." >> pdf2html
+ echo "cp \"${EPREFIX}\"/usr/share/${P}/*.png ." >> pdf2html || die "echo #4 failed"
}
src_install() {