summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-07-31 13:24:10 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-07-31 15:09:10 +0200
commitdc28233b0349e0b685c1f9b55815df06bbf24827 (patch)
treec37919deb3521c661d429f2f3732781b67b6cf32
parentapp-i18n/nkf: new upstream release (diff)
downloadgentoo-dc28233b0349e0b685c1f9b55815df06bbf24827.tar.gz
gentoo-dc28233b0349e0b685c1f9b55815df06bbf24827.tar.bz2
gentoo-dc28233b0349e0b685c1f9b55815df06bbf24827.zip
dev-ros/amcl: Bump to 1.16.1.
Package-Manager: Portage-2.3.44, Repoman-2.3.10
-rw-r--r--dev-ros/amcl/Manifest1
-rw-r--r--dev-ros/amcl/amcl-1.16.1.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-ros/amcl/Manifest b/dev-ros/amcl/Manifest
index 4a97915f4fab..cc2197df1073 100644
--- a/dev-ros/amcl/Manifest
+++ b/dev-ros/amcl/Manifest
@@ -1 +1,2 @@
DIST navigation-1.16.0.tar.gz 336708 BLAKE2B 74fdc7c3afb00bfbded011678c90b22cc95fe45b126c9a8a4bb9a80f8676ed0ade32e02ad77ec643f167d9719e71347750b6f7993f61cf743fc018d1412436d6 SHA512 ee6336627c2e095ef089534c19b7258f394858a6c04ad49b3aa6e1d0acca67c245c2743f04752be137864dba216c3aa38e34c3e40e3db7839308be3adbc808d6
+DIST navigation-1.16.1.tar.gz 336908 BLAKE2B 0f22db60352a0f50938ae18104ecad72c2e06eedeb2da8f6afe09bdc346868fcd71c90b0243c366b9fd0e7a26fef7551ab6a4febe87ab8d66af5ce3497c68770 SHA512 f6742f5afcaff2d1fc699e2695845b148bb16523e301f79577a8073fcc829541158b7c463f2e5bd9f69571f8b4042dbfacfe563de54b16193b5a31721c5f6faf
diff --git a/dev-ros/amcl/amcl-1.16.1.ebuild b/dev-ros/amcl/amcl-1.16.1.ebuild
new file mode 100644
index 000000000000..e02f95f8cedd
--- /dev/null
+++ b/dev-ros/amcl/amcl-1.16.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Probabilistic localization system for a robot moving in 2D"
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/rosbag
+ dev-libs/boost:=
+ dev-ros/roscpp
+ dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2_ros
+ dev-ros/tf2_geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] dev-python/python_orocos_kdl[${PYTHON_USEDEP}] dev-ros/map_server[${PYTHON_USEDEP}] )
+"