summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-26 05:29:16 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-26 05:29:16 +0100
commitdc2b6eaa19bcbbc736a94e90931b540417334a0d (patch)
tree9e690879e9ef386223c2f1f81f7a439387eafd39
parentdev-python/typing-extensions: Bump to 4.10.0 (diff)
downloadgentoo-dc2b6eaa.tar.gz
gentoo-dc2b6eaa.tar.bz2
gentoo-dc2b6eaa.zip
dev-python/urwid-readline: Bump to 0.14
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/urwid-readline/Manifest1
-rw-r--r--dev-python/urwid-readline/urwid-readline-0.14.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/urwid-readline/Manifest b/dev-python/urwid-readline/Manifest
index 1f65402c361c..1c168c21fa8b 100644
--- a/dev-python/urwid-readline/Manifest
+++ b/dev-python/urwid-readline/Manifest
@@ -1 +1,2 @@
DIST urwid_readline-0.13.gh.tar.gz 8356 BLAKE2B 3de62c98fb2a17ce91c023c32d1bcbfaa8a6280bbb20b654bac65d37c02eec2d87f0bceace600cbe934352efb984073b1fa29b626cb3bb4a114660d646f41eb0 SHA512 49087b2b0e47d6adba317941b6be99d7d61fd66ae28fa2ed89730c24cc04b8fa4ce20cb8eb35ebab56f838491432684bb8892463439dcd5d06d087b509182d3d
+DIST urwid_readline-0.14.gh.tar.gz 8369 BLAKE2B 7253f91b43ef212ded70792629a605fd238cdea1ad1b301ae43eadaa9d61cad9f077367203dd3636a6463c77b34ef6d0a347939634e8125e22eababe900f61ca SHA512 cc24cc72110f6cecbd71f6bda355adc74acf9697dd0636c35a679767e1406a4a15ef53fb03e2e69d20a523f09020fe17b9cf6ac41f1516af52ed9b9736c77d14
diff --git a/dev-python/urwid-readline/urwid-readline-0.14.ebuild b/dev-python/urwid-readline/urwid-readline-0.14.ebuild
new file mode 100644
index 000000000000..4943672cfb7a
--- /dev/null
+++ b/dev-python/urwid-readline/urwid-readline-0.14.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=urwid_readline-${PV}
+DESCRIPTION="Text input widget for urwid that supports readline shortcuts"
+HOMEPAGE="
+ https://github.com/rr-/urwid_readline/
+ https://pypi.org/project/urwid-readline/
+"
+SRC_URI="
+ https://github.com/rr-/urwid_readline/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/urwid[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest