summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-01-03 14:00:51 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2020-01-03 14:00:51 -0600
commitdc43abbfdb9598691308eb2ae4eb32394116fb11 (patch)
tree7b940835bf7f0950cd6ac09115617d7790c1272a
parentsys-boot/plymouth: made udev dependency optional (diff)
downloadgentoo-dc43abbfdb9598691308eb2ae4eb32394116fb11.tar.gz
gentoo-dc43abbfdb9598691308eb2ae4eb32394116fb11.tar.bz2
gentoo-dc43abbfdb9598691308eb2ae4eb32394116fb11.zip
app-crypt/certbot: remove acme dir correctly
Fixes: https://bugs.gentoo.org/703926 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--app-crypt/certbot/certbot-1.0.0-r1.ebuild7
-rw-r--r--app-crypt/certbot/certbot-9999.ebuild5
2 files changed, 6 insertions, 6 deletions
diff --git a/app-crypt/certbot/certbot-1.0.0-r1.ebuild b/app-crypt/certbot/certbot-1.0.0-r1.ebuild
index 37c17aa225d3..dd227e9e27f7 100644
--- a/app-crypt/certbot/certbot-1.0.0-r1.ebuild
+++ b/app-crypt/certbot/certbot-1.0.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -7,12 +7,11 @@ PYTHON_COMPAT=(python{2_7,3_5,3_6,3_7})
if [[ ${PV} == 9999* ]]; then
EGIT_REPO_URI="https://github.com/certbot/certbot.git"
inherit git-r3
- S=${WORKDIR}/${P}/${PN}
else
SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
- S=${WORKDIR}/certbot-${PV}/certbot
fi
+S=${WORKDIR}/${P}/${PN}
inherit distutils-r1
@@ -47,6 +46,6 @@ DEPEND="
python_test() {
# acme is not installed, removing it here is fine, the dir just confuses tests
- rm -R acme
+ rm -R ../acme
pytest -vv ${PN} || die
}
diff --git a/app-crypt/certbot/certbot-9999.ebuild b/app-crypt/certbot/certbot-9999.ebuild
index fba37e4616cb..d53164ebcea2 100644
--- a/app-crypt/certbot/certbot-9999.ebuild
+++ b/app-crypt/certbot/certbot-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -11,6 +11,7 @@ else
SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
fi
+S=${WORKDIR}/${P}/${PN}
inherit distutils-r1
@@ -45,6 +46,6 @@ DEPEND="
python_test() {
# acme is not installed, removing it here is fine, the dir just confuses tests
- rm -R acme
+ rm -R ../acme
pytest -vv ${PN} || die
}