summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-24 08:07:02 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-24 09:01:54 +0200
commitdc47e8bab737559a7480e7c8119cbe487f745c84 (patch)
tree8db28a8f15701d088fbd39e068d467d39e14e47f
parentdev-python/pytest-forked: Enable py3.12 (diff)
downloadgentoo-dc47e8bab737559a7480e7c8119cbe487f745c84.tar.gz
gentoo-dc47e8bab737559a7480e7c8119cbe487f745c84.tar.bz2
gentoo-dc47e8bab737559a7480e7c8119cbe487f745c84.zip
dev-python/pyopengl: Bump to 3.1.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pyopengl/Manifest1
-rw-r--r--dev-python/pyopengl/pyopengl-3.1.7.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/pyopengl/Manifest b/dev-python/pyopengl/Manifest
index 4727acc3ce96..e31f19e52701 100644
--- a/dev-python/pyopengl/Manifest
+++ b/dev-python/pyopengl/Manifest
@@ -1,2 +1,3 @@
DIST PyOpenGL-3.1.6.tar.gz 1903892 BLAKE2B 7d1109a09703a7113aa9cc02994662df77bea1da63e81a8adbdc812514b71e04bfa51dad9e48c0e0b98327e4f7deda7a8590c340a38127d38e91659f38739220 SHA512 b6f2f083df0fd7cf8f8a1077f42fa388bce94c0edde00ed6492104af8306c9925b74649cd2c222be4205b0892e7975de2f7591d0f0bcd9540eb53c0de95fec00
+DIST PyOpenGL-3.1.7.tar.gz 1896446 BLAKE2B 3fd4c84bb59157b4a6ee09c2a5ecd0e4f548bf03a84d735acfd92453eafb92102677a2b9c98831a92be33e873630c815dee453745d630a4d6b044771a13c945c SHA512 add1b4d02e7297f00f82a9c9249d6665029073fe620a1650491af9102a76a16e9320b5f227275b0c273ff5a616c284fd9f25f0f425848676c37cab9f3c22ae2e
DIST pyopengl-3.1.6-glut-font-egl.patch 1430 BLAKE2B 4b8962045b1efce2b4ec8ca759689d880e8df074e98c8c680172fd01d6cfbae33148cef41c46c7d1231674836d0009626ccedd873fcfe35f644fe9a2aaab2d5e SHA512 a0c491bca31cff312a2f431f89109cbf3aff276aee375325cacc5c6ebe37ad2119072ad7658e11b56efd62b18b8ed2642de999c79b0c999414e44c2b1ec7225b
diff --git a/dev-python/pyopengl/pyopengl-3.1.7.ebuild b/dev-python/pyopengl/pyopengl-3.1.7.ebuild
new file mode 100644
index 000000000000..eb23b2548a26
--- /dev/null
+++ b/dev-python/pyopengl/pyopengl-3.1.7.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=PyOpenGL
+PYTHON_REQ_USE="tk?"
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi virtualx
+
+DESCRIPTION="Python OpenGL bindings"
+HOMEPAGE="
+ https://pyopengl.sourceforge.net/
+ https://github.com/mcfletch/pyopengl/
+ https://pypi.org/project/PyOpenGL/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="tk"
+
+RDEPEND="
+ media-libs/freeglut
+ virtual/opengl
+ x11-libs/libXi
+ x11-libs/libXmu
+ tk? ( dev-tcltk/togl )
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+# The tests need an X server with the GLX extension. Software rendering
+# under Xvfb works but only with llvmpipe, not softpipe or swr.
+BDEPEND="
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pygame[${PYTHON_USEDEP},opengl,X]
+ !prefix? (
+ media-libs/mesa[llvm]
+ x11-base/xorg-server[-minimal,xorg]
+ )
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ virtx distutils-r1_src_test
+}