summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-10 09:24:39 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-10 10:25:03 +0200
commitdc71632d3b87f09fb7376d5a42a29803a4705820 (patch)
tree282f062489e8ef7a41777edd4a65948d94745279
parentdev-python/starlette: Bump to 0.20.3 (diff)
downloadgentoo-dc71632d3b87f09fb7376d5a42a29803a4705820.tar.gz
gentoo-dc71632d3b87f09fb7376d5a42a29803a4705820.tar.bz2
gentoo-dc71632d3b87f09fb7376d5a42a29803a4705820.zip
dev-python/ubelt: Bump to 1.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/ubelt/Manifest1
-rw-r--r--dev-python/ubelt/ubelt-1.1.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/ubelt/Manifest b/dev-python/ubelt/Manifest
index bdf228c9bd92..838a925fd567 100644
--- a/dev-python/ubelt/Manifest
+++ b/dev-python/ubelt/Manifest
@@ -1,2 +1,3 @@
DIST ubelt-1.0.1.tar.gz 242552 BLAKE2B da4ceb039b926f942c593563e77b42ebfb39a75bfc2953a6eadf2430bda8ebe25faeb4a00714fc110486715da15515fa316d3705d9853a7eb93320ee694d1127 SHA512 150f1c76b5814441fe0bfd50017f37ede4d463cc4e23f152ac634e7531d83f28560415ad26527cd40a7ebdab546d7edd711a1ba0c728ef63791219bf4866099c
DIST ubelt-1.1.0.gh.tar.gz 259127 BLAKE2B 064b106d5f03b106828079e024c3845ed55077f6bc4a69be4a7d05aa803b172104f2271626c9ab287b7b225711eb6490b49f0fa69f24729899e62a094069de16 SHA512 5a256f91d70ff218e595b852de11080f31ddd8ba29cc67a4a38f4c85ae69c0bda23c494d117926290901c5e6267b2d5eb2fc440951e0b598cca23cca6bf45c79
+DIST ubelt-1.1.1.gh.tar.gz 263082 BLAKE2B c146cfa7084b1d04d5a16443e5f8bdd4858992c2de1ff68a28c0febc74728da6320f45661cea69f88530a2fb88ca421cfc103f7f9f6ff420cf65152cbd61576d SHA512 d4d77013920563f3b2e5f47365624a4a794d84047eeb2eccaf2888f8d574c38b047393e550399e0d7ea7df373dabd40acce05ac56db4f0099da8f2a39113fc5c
diff --git a/dev-python/ubelt/ubelt-1.1.1.ebuild b/dev-python/ubelt/ubelt-1.1.1.ebuild
new file mode 100644
index 000000000000..04c09d5462ff
--- /dev/null
+++ b/dev-python/ubelt/ubelt-1.1.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A stdlib like feel, and extra batteries. Hashing, Caching, Timing, Progress"
+HOMEPAGE="
+ https://github.com/Erotemic/ubelt/
+ https://pypi.org/project/ubelt/
+"
+SRC_URI="
+ https://github.com/Erotemic/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ >=dev-python/numpy-1.19.2[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.1[${PYTHON_USEDEP}]
+ dev-python/xdoctest[${PYTHON_USEDEP}]
+ >=dev-python/xxhash-1.0.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # relies on passwd home being equal to ${HOME}
+ ubelt/util_path.py::userhome:0
+)