summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMagnus Granberg <zorry@gentoo.org>2024-03-10 22:48:13 +0100
committerSam James <sam@gentoo.org>2024-03-14 05:37:19 +0000
commitdc81acaa3d063c520e7306f336a2a0e7375f35a9 (patch)
tree5643daeeacfd49770ebfd098561a1636616838d1
parentdev-util/buildbot-react-grid-view: add 3.11.1 (diff)
downloadgentoo-dc81acaa3d063c520e7306f336a2a0e7375f35a9.tar.gz
gentoo-dc81acaa3d063c520e7306f336a2a0e7375f35a9.tar.bz2
gentoo-dc81acaa3d063c520e7306f336a2a0e7375f35a9.zip
dev-util/buildbot-www-react: add 3.11.1
Signed-off-by: Magnus Granberg <zorry@gentoo.org> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-util/buildbot-www-react/Manifest1
-rw-r--r--dev-util/buildbot-www-react/buildbot-www-react-3.11.1.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-util/buildbot-www-react/Manifest b/dev-util/buildbot-www-react/Manifest
index 8a50a24b0865..41104c3b82c3 100644
--- a/dev-util/buildbot-www-react/Manifest
+++ b/dev-util/buildbot-www-react/Manifest
@@ -1,2 +1,3 @@
DIST buildbot-www-react-3.11.0.tar.gz 339509 BLAKE2B 274ac1e27537fb10918720dee4ca017289741c4da49c24af25cdb9ce342dccdc61e1b03d669521a8aa54e9265eefdead062869f0db1176d2ea9de5d147d2459b SHA512 3f110a9195f6a1206392f54f78bc82e4a17a386fed2316ae94f5a6648bde7603e948453161f80018064a403c661fcddceaf57c1c480527f0b7ae9e5906e714af
+DIST buildbot-www-react-3.11.1.tar.gz 339534 BLAKE2B 720f4446d599b7df12d75b875755d2533d7f7fcf82e4d5ba83f820ccaa7ef9a9edfec652a6956e79d808eb816b737a7af91371c39b59ab681c9c7ebfdd331ef5 SHA512 dbef84ff3989b166a826b346887e5b5496b3078ddd2b2cdc9375990c0022b3085d74077786f554f085246ac10e95dc9b08f4111c218d0a956e9819e2f85bc672
DIST buildbot-www-react-3.9.0.tar.gz 38431 BLAKE2B e32edbd846c131670f8bc3c84fbc9456bd5757a09ed1e3b145f8cbb13707a31866527b3d1d16b7d77a2cf05d90923037841034c835ba5d7bc92ee47d9a00be92 SHA512 bdc1db5a21ff47b8f8c416e1eae38b561b2480d7643b91b598ae25bf6ffa362e6eeadf90c6a0e109dca6b80c15400562529d7b4dfe9e0ed1588e33a69b8c132f
diff --git a/dev-util/buildbot-www-react/buildbot-www-react-3.11.1.ebuild b/dev-util/buildbot-www-react/buildbot-www-react-3.11.1.ebuild
new file mode 100644
index 000000000000..278991d26bc3
--- /dev/null
+++ b/dev-util/buildbot-www-react/buildbot-www-react-3.11.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="BuildBot base web interface, use with buildbot-react-{console-view,grid-view}..."
+HOMEPAGE="https://buildbot.net/
+ https://github.com/buildbot/buildbot
+ https://pypi.org/project/buildbot-www-react/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~amd64-linux ~x86-linux"
+
+RDEPEND="~dev-util/buildbot-pkg-${PV}[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}"