summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-11-27 17:53:28 +0100
committerDavid Seifert <soap@gentoo.org>2021-11-27 17:53:28 +0100
commitdc8406f199ae8e581e62890925b005e046e42d71 (patch)
treec57365bdb64d8949a440914c8c0b6d95e243892b
parentdev-libs/cppcodec: update EAPI 7 -> 8 (diff)
downloadgentoo-dc8406f1.tar.gz
gentoo-dc8406f1.tar.bz2
gentoo-dc8406f1.zip
dev-libs/cppcodec: sync live ebuild
Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--dev-libs/cppcodec/cppcodec-9999.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-libs/cppcodec/cppcodec-9999.ebuild b/dev-libs/cppcodec/cppcodec-9999.ebuild
index 3f142b6b6db7..c378468fac29 100644
--- a/dev-libs/cppcodec/cppcodec-9999.ebuild
+++ b/dev-libs/cppcodec/cppcodec-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit cmake-utils
+inherit cmake
DESCRIPTION="C++11 library to encode/decode base64, base64url, base32, base32hex and hex"
HOMEPAGE="https://github.com/tplgy/cppcodec"
@@ -16,7 +16,7 @@ if [[ ${PV} == *9999 ]]; then
EGIT_SUBMODULES=()
else
SRC_URI="https://github.com/tplgy/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~ppc64 ~x86"
+ KEYWORDS="amd64 ~ppc64 x86"
fi
LICENSE="MIT"
@@ -31,5 +31,5 @@ src_configure() {
local mycmakeargs=(
-DBUILD_TESTING=$(usex test)
)
- cmake-utils_src_configure
+ cmake_src_configure
}