summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-06 10:18:48 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-06 11:00:34 +0100
commitdcabe6ab0ea97c7e50260881354b097fb6aefb44 (patch)
treec5c2bc1d1703a49a56c9997061d92001daf488a8
parentwww-client/qutebrowser: update 9999 (diff)
downloadgentoo-dcabe6ab0ea97c7e50260881354b097fb6aefb44.tar.gz
gentoo-dcabe6ab0ea97c7e50260881354b097fb6aefb44.tar.bz2
gentoo-dcabe6ab0ea97c7e50260881354b097fb6aefb44.zip
dev-python/GitPython: Bump to 3.1.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/GitPython/GitPython-3.1.12.ebuild59
-rw-r--r--dev-python/GitPython/Manifest2
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/GitPython/GitPython-3.1.12.ebuild b/dev-python/GitPython/GitPython-3.1.12.ebuild
new file mode 100644
index 000000000000..ea75cc97716d
--- /dev/null
+++ b/dev-python/GitPython/GitPython-3.1.12.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+TEST_P=GitPython-${PV}
+GITDB_P=gitdb-4.0.5
+SMMAP_P=smmap-3.0.4
+
+DESCRIPTION="Library used to interact with Git repositories"
+HOMEPAGE="https://github.com/gitpython-developers/GitPython https://pypi.org/project/GitPython/"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz
+ test? (
+ https://dev.gentoo.org/~mgorny/dist/${TEST_P}.gitbundle
+ https://dev.gentoo.org/~mgorny/dist/${GITDB_P}.gitbundle
+ https://dev.gentoo.org/~mgorny/dist/${SMMAP_P}.gitbundle
+ )"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-vcs/git
+ >=dev-python/gitdb-4.0.1[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ >=dev-python/ddt-1.1.1[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests unittest
+
+src_test() {
+ git config --global user.email "travis@ci.com" || die
+ git config --global user.name "Travis Runner" || die
+
+ git clone "${DISTDIR}/${TEST_P}.gitbundle" "${T}"/test || die
+ git clone "${DISTDIR}/${GITDB_P}.gitbundle" \
+ "${T}"/test/git/ext/gitdb || die
+ git clone "${DISTDIR}/${SMMAP_P}.gitbundle" \
+ "${T}"/test/git/ext/gitdb/gitdb/ext/smmap || die
+
+ cd "${T}"/test || die
+ TRAVIS=1 ./init-tests-after-clone.sh || die
+ cat test/fixtures/.gitconfig >> ~/.gitconfig || die
+ rm -r test/performance || die
+ # tests requiring network access
+ sed -i -e 's:test_fetch_error:_&:' test/test_remote.py || die
+ rm test/test_installation.py || die
+ # broken with git 2.30+
+ sed -i -e 's:test_index_file_diffing:_&:' test/test_index.py || die
+
+ distutils-r1_src_test
+}
diff --git a/dev-python/GitPython/Manifest b/dev-python/GitPython/Manifest
index e0a3f6916b77..b12d3e4aee09 100644
--- a/dev-python/GitPython/Manifest
+++ b/dev-python/GitPython/Manifest
@@ -1,4 +1,6 @@
DIST GitPython-3.1.11.gitbundle 4421698 BLAKE2B 96a4be2b12149c34f0e81580cb8906920a107f9856da585779f8d13590fb14c838a5e73d8831692ea81dd0ed73e17cdab1020b50cb49c7f193d54c1e838d9385 SHA512 64a443e0c517627045d98f7a60b6cdd817f6af3d12f5619cca7c4e24f9ce42018c2aca427365d633e4aaeb5e99d99a944d85b2286c34be1c17e85e441d9693c3
DIST GitPython-3.1.11.tar.gz 170908 BLAKE2B b327f38bbe9d92caf8b5ba6f3c1e353ad00bad2c3e7b3ae59991eaee5a5dd9f228fd80b86fd7e908fa71563e369d7340070ddc0e093549bfc8378cdf20ba9723 SHA512 fe4baf9c8b3668f29fbc476ec2ba0a8d58a50ffe596b9f3037ddb4cb5c0c7faf0d34c6efac7567074f1b28b866e42dad19c91a5381eef606d3b3ff74b77649de
+DIST GitPython-3.1.12.gitbundle 8721154 BLAKE2B d00ba18e53797ebc2067de8422506db0fafc27860cd3f99a36ad4740956518cfcab98d8211d595e1347c22df3d0ac13557881f471829c429db1527099f53438e SHA512 c84c76668bbc593998cf834d18d0207ae282cf0fd6fd22e5491435884855bb2b6699b61e51b35e6bbcfc4cd2f3c15aa9b435115fe5b0957ab4c63c7aa640ed6b
+DIST GitPython-3.1.12.tar.gz 171126 BLAKE2B e74a613f5269893f29f41add6f39c34497613b728b14c4c65c5fcbd52bee52a2ef53c4db3bc63f843ce4ec1e63f3988029852e9195677db32b704d0429480130 SHA512 4a2915991831fcf0dc0326d9e9be0f06fba1e93560d07c19fad5cbcb9ff04262e7d2225c5174a8c2f55e4c44b1c027bec4ff61d7dc137d8bf110ab96026742cc
DIST gitdb-4.0.5.gitbundle 1497722 BLAKE2B 8ee85368db7f408f96f0b48250f1ed96c8df28b0439d355ce2eecbdcc5dc94382883510c57142e7e4b6ba7cd8e82b1140eca538b45692dbe8c55bce32e1b5b4f SHA512 2c55a8e402a61ebcc362a8aee4a6154705d8ff2f5e582d13c855562dd074427681f4147641fe76681b76c99ec46040c7577dfca8bbfd575fc52772a9a6f17326
DIST smmap-3.0.4.gitbundle 276552 BLAKE2B 2d17b927b2c644d2f1984168ee99fe5a9a58392401ac0b2894a1d5e5f9c292f32311a7a5d7669bd93c642ff791f4801d61ef3236c1dafa1434e99a17fd8751f6 SHA512 6deb282c6ece3b556c59c458b5242ff362b903441db63c005a0ab1ac055b3f974f9b34f30e0a4a41ef9246696e08b191254f72db61a8f24d4eb2f0e48a08937b