summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 15:44:44 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 16:36:27 +0200
commitdcd4313cf70a0129066398e7cf2adf2e5b06aa73 (patch)
tree3aaec5d76e89a6ed8d918663c5aec69a6157ac91
parentdev-ros/rosmsg: Initial import. Ebuild by me. (diff)
downloadgentoo-dcd4313cf70a0129066398e7cf2adf2e5b06aa73.tar.gz
gentoo-dcd4313cf70a0129066398e7cf2adf2e5b06aa73.tar.bz2
gentoo-dcd4313cf70a0129066398e7cf2adf2e5b06aa73.zip
dev-ros/rosnode: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
-rw-r--r--dev-ros/rosnode/Manifest1
-rw-r--r--dev-ros/rosnode/metadata.xml5
-rw-r--r--dev-ros/rosnode/rosnode-1.11.14.ebuild25
-rw-r--r--dev-ros/rosnode/rosnode-9999.ebuild25
4 files changed, 56 insertions, 0 deletions
diff --git a/dev-ros/rosnode/Manifest b/dev-ros/rosnode/Manifest
new file mode 100644
index 000000000000..84bda7639707
--- /dev/null
+++ b/dev-ros/rosnode/Manifest
@@ -0,0 +1 @@
+DIST ros_comm-1.11.14.tar.gz 945041 SHA256 8e7beff35711b1918501c69cca4f29648d4d4207878edab069bcd59d515c78f3 SHA512 be768faa0a2f45c464e963934a95dc617cac6c3fcec2388602a27846774c25b882b5139099ce10d1d051a21d5938819942e079836d14618071bc7ad90ee78bab WHIRLPOOL e047ce984086655294c20dbf0715cc29f51ec358f075f02de80c5de0d4ef8059990dc8312d78d7a7fa91c4a974dc21cba15d6eacafe02fd3df527770e50f75a5
diff --git a/dev-ros/rosnode/metadata.xml b/dev-ros/rosnode/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/dev-ros/rosnode/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/rosnode/rosnode-1.11.14.ebuild b/dev-ros/rosnode/rosnode-1.11.14.ebuild
new file mode 100644
index 000000000000..1d4acc8351d8
--- /dev/null
+++ b/dev-ros/rosnode/rosnode-1.11.14.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Command-line tool for displaying debug information about ROS nodes"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/genmsg[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"
diff --git a/dev-ros/rosnode/rosnode-9999.ebuild b/dev-ros/rosnode/rosnode-9999.ebuild
new file mode 100644
index 000000000000..1d4acc8351d8
--- /dev/null
+++ b/dev-ros/rosnode/rosnode-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Command-line tool for displaying debug information about ROS nodes"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/genmsg[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"