summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNiccolò Scatena <speedjack95@gmail.com>2019-02-10 00:47:06 +0100
committerAaron Bauman <bman@gentoo.org>2019-02-12 19:04:18 -0500
commitdcd8d505572b7922e9939f5eaa442fa210f38052 (patch)
tree91a7b631bcd1f4b2da401f8aa1e495a78643705f
parentdev-libs/swaylock: Add 9999 live version (diff)
downloadgentoo-dcd8d505.tar.gz
gentoo-dcd8d505.tar.bz2
gentoo-dcd8d505.zip
dev-libs/sway: various fixes
- Use ${PN} wherever possible; - Remove bash-completion use flag: bash completions should be always installed (see [1]); - Remove clipboard use flag and related dep: makes no sense to add this here, if the user wants to add utilities to handle the clipboard under wayland it is just and emerge away; wl-clipboard has nothing to do with sway; - Rename use flag: doc -> man (doc is a global use flag used to install additional documentation that most users does not want); - The sway tray feature (enabled by the tray use flag) now requires a logind provider: reflect this in REQUIRED_USE (fixes #677748); - Fix order of (R)DEPEND; - Remove required use gdk-pixbuf[jpeg]: the jpeg use flag is not required to be enabled. If the user wants support for JPEG images, he can manually enable it in gdk-pixbuf (as for other img formats); - Remove libcap dep: the fcaps eclass automatically adds it if filecaps use flag is enabled; - Dependency dbus is no longer required with tray (now uses sd-bus from logind): remove anything related to it; - Move scdoc and wayland-protocols dependencies to BDEPEND; - Add dep on xkeyboard-config: see bug #674640; - Add man-pages parameter to meson (fixes bug #677654); - Disable swaybar man page installation when swaybar use flag is disabled; - Use $MY_PV in sway-version arg to meson to reflect upstream version in sway --version; - Add a reminder to set XDG_RUNTIME_DIR if it's not set by the environment. This is needed in systems without logind/consolekit. [1] www.gentoo.org/support/news-items/2014-11-25-bash-completion-2_1-r90.html Closes: https://bugs.gentoo.org/672590 Closes: https://bugs.gentoo.org/675978 Closes: https://bugs.gentoo.org/674640 Closes: https://bugs.gentoo.org/677654 Closes: https://bugs.gentoo.org/677748 Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Niccolò Scatena <speedjack95@gmail.com> Signed-off-by: Aaron Bauman <bman@gentoo.org>
-rw-r--r--dev-libs/sway/metadata.xml5
-rw-r--r--dev-libs/sway/sway-1.0_beta1.ebuild66
-rw-r--r--dev-libs/sway/sway-1.0_beta2.ebuild66
-rw-r--r--dev-libs/sway/sway-1.0_rc1-r1.ebuild (renamed from dev-libs/sway/sway-1.0_rc1.ebuild)79
-rw-r--r--dev-libs/sway/sway-9999.ebuild79
5 files changed, 174 insertions, 121 deletions
diff --git a/dev-libs/sway/metadata.xml b/dev-libs/sway/metadata.xml
index ebb759791eb7..86644eb41bb5 100644
--- a/dev-libs/sway/metadata.xml
+++ b/dev-libs/sway/metadata.xml
@@ -13,7 +13,7 @@
<email>hilobakho@gmail.com</email>
<name>Mykyta Holubakha</name>
</maintainer>
- <maintainer restrict="&gt;=dev-libs/sway-1.0_beta1" type="person">
+ <maintainer type="person">
<email>speedjack95@gmail.com</email>
<name>Niccolò Scatena</name>
</maintainer>
@@ -30,11 +30,10 @@
something else.
</longdescription>
<use>
- <flag name="clipboard">Install 'wl-clipboard': clipboard management</flag>
<flag name="elogind">Enable support for rootless session via elogind</flag>
- <flag name="filecaps">Use Linux capability SYS_CAP_ADMIN rather than set*id for sway binary</flag>
<flag name="fish-completion">Enable fish completion support</flag>
<flag name="gdk-pixbuf">Enable additional image format support via the <pkg>x11-libs/gdk-pixbuf</pkg> library</flag>
+ <flag name="man">Build and install man pages</flag>
<flag name="swaybar">Install 'swaybar': sway's status bar component</flag>
<flag name="swaybg">Install 'swaybg': allows to set a desktop background image</flag>
<flag name="swaygrab">Install 'swaygrab': allows taking screenshots or screencasts</flag>
diff --git a/dev-libs/sway/sway-1.0_beta1.ebuild b/dev-libs/sway/sway-1.0_beta1.ebuild
index 76a39cb5232c..e01722890535 100644
--- a/dev-libs/sway/sway-1.0_beta1.ebuild
+++ b/dev-libs/sway/sway-1.0_beta1.ebuild
@@ -1,52 +1,63 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-if [[ ${PV} == 9999 ]] ; then
- EGIT_REPO_URI="https://github.com/swaywm/sway.git"
+inherit eutils fcaps meson pam
+
+DESCRIPTION="i3-compatible Wayland window manager"
+HOMEPAGE="https://swaywm.org"
+
+if [[ ${PV} == 9999 ]]; then
inherit git-r3
+ EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
else
# Version format: major.minor-beta.betanum
- SWAY_PV="$(ver_cut 1-2)-$(ver_cut 3).$(ver_cut 4)"
- SRC_URI="https://github.com/swaywm/sway/archive/${SWAY_PV}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/sway-${SWAY_PV}"
+ MY_PV="$(ver_cut 1-2)-$(ver_cut 3).$(ver_cut 4)"
+ SRC_URI="https://github.com/swaywm/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${MY_PV}"
KEYWORDS="~amd64 ~x86"
fi
-inherit eutils fcaps meson pam
-
-DESCRIPTION="i3-compatible Wayland window manager"
-HOMEPAGE="https://swaywm.org"
-
LICENSE="MIT"
SLOT="0"
IUSE="elogind fish-completion +swaybar +swaybg +swaylock systemd +tray wallpapers X zsh-completion"
REQUIRED_USE="?? ( elogind systemd )"
-RDEPEND="~dev-libs/wlroots-0.1[systemd=,elogind=,X=]
+DEPEND="
>=dev-libs/json-c-0.13:0=
>=dev-libs/libinput-1.6.0:0=
dev-libs/libpcre
dev-libs/wayland
- >=dev-libs/wayland-protocols-1.14
x11-libs/cairo
x11-libs/libxkbcommon
x11-libs/pango
x11-libs/pixman
elogind? ( >=sys-auth/elogind-237 )
- swaybar? ( x11-libs/gdk-pixbuf:2[jpeg] )
- swaybg? ( x11-libs/gdk-pixbuf:2[jpeg] )
+ swaybar? ( x11-libs/gdk-pixbuf:2 )
+ swaybg? ( x11-libs/gdk-pixbuf:2 )
swaylock? (
virtual/pam
- x11-libs/gdk-pixbuf:2[jpeg]
+ x11-libs/gdk-pixbuf:2
)
systemd? ( >=sys-apps/systemd-237 )
tray? ( >=sys-apps/dbus-1.10 )
- X? ( x11-libs/libxcb:0=[xkb] )"
-DEPEND="${RDEPEND}"
-BDEPEND="app-text/scdoc
- virtual/pkgconfig"
+ X? ( x11-libs/libxcb:0=[xkb] )
+"
+if [[ ${PV} == 9999 ]]; then
+ DEPEND+="~dev-libs/wlroots-9999[elogind=,filecaps?,systemd=,X=]"
+else
+ DEPEND+=">=dev-libs/wlroots-0.1[elogind=,filecaps?,systemd=,X=]"
+fi
+RDEPEND="
+ x11-misc/xkeyboard-config
+ ${DEPEND}
+"
+BDEPEND="
+ app-text/scdoc
+ >=dev-libs/wayland-protocols-1.14
+ virtual/pkgconfig
+"
FILECAPS=( cap_sys_admin usr/bin/sway )
@@ -60,7 +71,6 @@ src_prepare() {
src_configure() {
local emesonargs=(
- "-Dsway-version=${SWAY_PV}"
$(meson_use wallpapers default-wallpaper)
$(meson_use zsh-completion zsh-completions)
$(meson_use fish-completion fish-completions)
@@ -69,6 +79,10 @@ src_configure() {
"-Dwerror=false"
)
+ if [[ ${PV} != 9999 ]]; then
+ emesonargs+=("-Dsway-version=${MY_PV}")
+ fi
+
meson_src_configure
}
@@ -81,15 +95,17 @@ src_install() {
pkg_postinst() {
elog "You must be in the input group to allow sway to access input devices!"
local dbus_cmd=""
- if use tray ; then
- elog ""
- optfeature "experimental xembed tray icons support" kde-plasma/xembed-sni-proxy
+ if use tray; then
dbus_cmd="dbus-launch --sh-syntax --exit-with-session "
fi
- if ! use systemd && ! use elogind ; then
+ if ! use systemd && ! use elogind; then
fcaps_pkg_postinst
elog ""
elog "If you use ConsoleKit2, remember to launch sway using:"
elog "exec ck-launch-session ${dbus_cmd}sway"
+ elog ""
+ elog "If your system does not set the XDG_RUNTIME_DIR environment"
+ elog "variable, you must set it manually to run Sway. See wiki"
+ elog "for details: https://wiki.gentoo.org/wiki/Sway"
fi
}
diff --git a/dev-libs/sway/sway-1.0_beta2.ebuild b/dev-libs/sway/sway-1.0_beta2.ebuild
index 1812f7f4dc80..0ab105873298 100644
--- a/dev-libs/sway/sway-1.0_beta2.ebuild
+++ b/dev-libs/sway/sway-1.0_beta2.ebuild
@@ -1,52 +1,63 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-if [[ ${PV} == 9999 ]] ; then
- EGIT_REPO_URI="https://github.com/swaywm/sway.git"
+inherit eutils fcaps meson
+
+DESCRIPTION="i3-compatible Wayland window manager"
+HOMEPAGE="https://swaywm.org"
+
+if [[ ${PV} == 9999 ]]; then
inherit git-r3
+ EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
else
# Version format: major.minor-beta.betanum
- SWAY_PV="$(ver_cut 1-2)-$(ver_cut 3).$(ver_cut 4)"
- SRC_URI="https://github.com/swaywm/sway/archive/${SWAY_PV}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/sway-${SWAY_PV}"
+ MY_PV="$(ver_cut 1-2)-$(ver_cut 3).$(ver_cut 4)"
+ SRC_URI="https://github.com/swaywm/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${MY_PV}"
KEYWORDS="~amd64 ~x86"
fi
-inherit eutils fcaps meson
-
-DESCRIPTION="i3-compatible Wayland window manager"
-HOMEPAGE="https://swaywm.org"
-
LICENSE="MIT"
SLOT="0"
IUSE="elogind fish-completion +pam +swaybar +swaybg +swayidle +swaylock +swaymsg +swaynag systemd +tray wallpapers X zsh-completion"
REQUIRED_USE="?? ( elogind systemd )"
-RDEPEND="~dev-libs/wlroots-0.2[systemd=,elogind=,X=]
+DEPEND="
>=dev-libs/json-c-0.13:0=
>=dev-libs/libinput-1.6.0:0=
dev-libs/libpcre
dev-libs/wayland
- >=dev-libs/wayland-protocols-1.14
x11-libs/cairo
x11-libs/libxkbcommon
x11-libs/pango
x11-libs/pixman
elogind? ( >=sys-auth/elogind-237 )
- swaybar? ( x11-libs/gdk-pixbuf:2[jpeg] )
- swaybg? ( x11-libs/gdk-pixbuf:2[jpeg] )
+ swaybar? ( x11-libs/gdk-pixbuf:2 )
+ swaybg? ( x11-libs/gdk-pixbuf:2 )
swaylock? (
pam? ( virtual/pam )
- x11-libs/gdk-pixbuf:2[jpeg]
+ x11-libs/gdk-pixbuf:2
)
systemd? ( >=sys-apps/systemd-237 )
tray? ( >=sys-apps/dbus-1.10 )
- X? ( x11-libs/libxcb:0= )"
-DEPEND="${RDEPEND}"
-BDEPEND="app-text/scdoc
- virtual/pkgconfig"
+ X? ( x11-libs/libxcb:0= )
+"
+if [[ ${PV} == 9999 ]]; then
+ DEPEND+="~dev-libs/wlroots-9999[elogind=,filecaps?,systemd=,X=]"
+else
+ DEPEND+=">=dev-libs/wlroots-0.2[elogind=,filecaps?,systemd=,X=]"
+fi
+RDEPEND="
+ x11-misc/xkeyboard-config
+ ${DEPEND}
+"
+BDEPEND="
+ app-text/scdoc
+ >=dev-libs/wayland-protocols-1.14
+ virtual/pkgconfig
+"
FILECAPS=( cap_sys_admin usr/bin/sway )
@@ -67,7 +78,6 @@ src_prepare() {
src_configure() {
local emesonargs=(
- "-Dsway-version=${SWAY_PV}"
$(meson_use wallpapers default-wallpaper)
$(meson_use zsh-completion zsh-completions)
$(meson_use fish-completion fish-completions)
@@ -76,22 +86,28 @@ src_configure() {
"-Dwerror=false"
)
+ if [[ ${PV} != 9999 ]]; then
+ emesonargs+=("-Dsway-version=${MY_PV}")
+ fi
+
meson_src_configure
}
pkg_postinst() {
elog "You must be in the input group to allow sway to access input devices!"
local dbus_cmd=""
- if use tray ; then
- elog ""
- optfeature "experimental xembed tray icons support" kde-plasma/xembed-sni-proxy
+ if use tray; then
dbus_cmd="dbus-launch --sh-syntax --exit-with-session "
fi
- if ! use systemd && ! use elogind ; then
+ if ! use systemd && ! use elogind; then
fcaps_pkg_postinst
elog ""
elog "If you use ConsoleKit2, remember to launch sway using:"
elog "exec ck-launch-session ${dbus_cmd}sway"
+ elog ""
+ elog "If your system does not set the XDG_RUNTIME_DIR environment"
+ elog "variable, you must set it manually to run Sway. See wiki"
+ elog "for details: https://wiki.gentoo.org/wiki/Sway"
fi
if use swaylock && ! use pam; then
fcaps cap_sys_admin usr/bin/swaylock
diff --git a/dev-libs/sway/sway-1.0_rc1.ebuild b/dev-libs/sway/sway-1.0_rc1-r1.ebuild
index 95621d2f0721..47262ad9b430 100644
--- a/dev-libs/sway/sway-1.0_rc1.ebuild
+++ b/dev-libs/sway/sway-1.0_rc1-r1.ebuild
@@ -3,59 +3,64 @@
EAPI=7
-inherit eutils fcaps meson
+inherit eutils meson
DESCRIPTION="i3-compatible Wayland window manager"
HOMEPAGE="https://swaywm.org"
if [[ ${PV} == 9999 ]]; then
inherit git-r3
- EGIT_REPO_URI="https://github.com/swaywm/sway.git"
+ EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
else
MY_PV=${PV/_rc/-rc}
- SRC_URI="https://github.com/swaywm/sway/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/swaywm/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
S="${WORKDIR}/${PN}-${MY_PV}"
fi
LICENSE="MIT"
SLOT="0"
-IUSE="bash-completion clipboard doc elogind fish-completion +swaybar +swaybg +swayidle +swaylock +swaymsg +swaynag systemd +tray wallpapers X zsh-completion"
-REQUIRED_USE="?? ( elogind systemd )"
+IUSE="elogind fish-completion +man +swaybar +swaybg +swayidle +swaylock +swaymsg +swaynag systemd tray wallpapers X zsh-completion"
+REQUIRED_USE="?? ( elogind systemd )
+ tray? ( || ( elogind systemd ) )"
-RDEPEND="
- >=dev-libs/wlroots-0.3[elogind=,systemd=,X=]
+DEPEND="
>=dev-libs/json-c-0.13:0=
>=dev-libs/libinput-1.6.0:0=
dev-libs/libpcre
dev-libs/wayland
- >=dev-libs/wayland-protocols-1.14
x11-libs/cairo
x11-libs/libxkbcommon
x11-libs/pango
x11-libs/pixman
- sys-libs/libcap
- clipboard? ( dev-libs/wl-clipboard )
elogind? ( >=sys-auth/elogind-239 )
- swaybar? ( x11-libs/gdk-pixbuf:2[jpeg] )
- swaybg? ( x11-libs/gdk-pixbuf:2[jpeg] )
+ swaybar? ( x11-libs/gdk-pixbuf:2 )
+ swaybg? ( x11-libs/gdk-pixbuf:2 )
swayidle? ( dev-libs/swayidle )
swaylock? ( dev-libs/swaylock )
systemd? ( >=sys-apps/systemd-239 )
- tray? ( >=sys-apps/dbus-1.10 )
- X? ( x11-libs/libxcb:0= )"
-DEPEND="${RDEPEND}"
+ X? ( x11-libs/libxcb:0= )
+"
+if [[ ${PV} == 9999 ]]; then
+ DEPEND+="~dev-libs/wlroots-9999[elogind=,systemd=,X=]"
+else
+ DEPEND+=">=dev-libs/wlroots-0.3[elogind=,systemd=,X=]"
+fi
+RDEPEND="
+ x11-misc/xkeyboard-config
+ ${DEPEND}
+"
BDEPEND="
- dev-libs/wayland-protocols
- doc? ( >=app-text/scdoc-1.8.1 )
- virtual/pkgconfig"
-
-FILECAPS=( cap_sys_admin usr/bin/sway )
+ >=dev-libs/wayland-protocols-1.14
+ virtual/pkgconfig
+ man? ( >=app-text/scdoc-1.8.1 )
+"
src_prepare() {
default
- use swaybar || sed -e "s/subdir('swaybar')//g" -i meson.build || die
+ use swaybar || sed -e "s/subdir('swaybar')//g" -e "/sway-bar.[0-9].scd/d" \
+ -e "/completions\/[a-z]\+\/_\?swaybar/d" -i meson.build || die
use swaybg || sed -e "s/subdir('swaybg')//g" -i meson.build || die
use swaymsg || sed -e "s/subdir('swaymsg')//g" -e "/swaymsg.[0-9].scd/d" \
-e "/completions\/[a-z]\+\/_\?swaymsg/d" -i meson.build || die
@@ -65,36 +70,44 @@ src_prepare() {
src_configure() {
local emesonargs=(
- $(meson_use bash-completion bash-completions)
- $(meson_use fish-completion fish-completions)
+ -Dman-pages=$(usex man enabled disabled)
+ -Dtray=$(usex tray enabled disabled)
+ -Dxwayland=$(usex X enabled disabled)
$(meson_use wallpapers default-wallpaper)
+ $(meson_use fish-completion fish-completions)
$(meson_use zsh-completion zsh-completions)
- "-Dtray=$(usex tray enabled disabled)"
- "-Dxwayland=$(usex X enabled disabled)"
+ "-Dbash-completions=true"
"-Dwerror=false"
)
+
if use swaybar || use swaybg; then
emesonargs+=("-Dgdk-pixbuf=enabled")
else
emesonargs+=("-Dgdk-pixbuf=disabled")
fi
+
if [[ ${PV} != 9999 ]]; then
- emesonargs+=("-Dsway-version=${PV}")
+ emesonargs+=("-Dsway-version=${MY_PV}")
fi
meson_src_configure
}
-pkg_postinst() {
- elog "You must be in the input group to allow sway to access input devices!"
- local dbus_cmd=""
- if use tray; then
- dbus_cmd="dbus-launch --sh-syntax --exit-with-session "
+pkg_preinst() {
+ if ! use systemd && ! use elogind; then
+ fowners root:0 /usr/bin/sway
+ fperms 4511 /usr/bin/sway
fi
+}
+
+pkg_postinst() {
if ! use systemd && ! use elogind; then
- fcaps_pkg_postinst
elog ""
elog "If you use ConsoleKit2, remember to launch sway using:"
- elog "exec ck-launch-session ${dbus_cmd}sway"
+ elog "exec ck-launch-session sway"
+ elog ""
+ elog "If your system does not set the XDG_RUNTIME_DIR environment"
+ elog "variable, you must set it manually to run Sway. See wiki"
+ elog "for details: https://wiki.gentoo.org/wiki/Sway"
fi
}
diff --git a/dev-libs/sway/sway-9999.ebuild b/dev-libs/sway/sway-9999.ebuild
index 95621d2f0721..f1d3935e2f12 100644
--- a/dev-libs/sway/sway-9999.ebuild
+++ b/dev-libs/sway/sway-9999.ebuild
@@ -3,59 +3,64 @@
EAPI=7
-inherit eutils fcaps meson
+inherit eutils meson
DESCRIPTION="i3-compatible Wayland window manager"
HOMEPAGE="https://swaywm.org"
if [[ ${PV} == 9999 ]]; then
inherit git-r3
- EGIT_REPO_URI="https://github.com/swaywm/sway.git"
+ EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
else
MY_PV=${PV/_rc/-rc}
- SRC_URI="https://github.com/swaywm/sway/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/swaywm/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
S="${WORKDIR}/${PN}-${MY_PV}"
fi
LICENSE="MIT"
SLOT="0"
-IUSE="bash-completion clipboard doc elogind fish-completion +swaybar +swaybg +swayidle +swaylock +swaymsg +swaynag systemd +tray wallpapers X zsh-completion"
-REQUIRED_USE="?? ( elogind systemd )"
+IUSE="elogind fish-completion +man +swaybar +swaybg +swayidle +swaylock +swaymsg +swaynag systemd tray wallpapers X zsh-completion"
+REQUIRED_USE="?? ( elogind systemd )
+ tray? ( || ( elogind systemd ) )"
-RDEPEND="
- >=dev-libs/wlroots-0.3[elogind=,systemd=,X=]
+DEPEND="
>=dev-libs/json-c-0.13:0=
>=dev-libs/libinput-1.6.0:0=
dev-libs/libpcre
dev-libs/wayland
- >=dev-libs/wayland-protocols-1.14
x11-libs/cairo
x11-libs/libxkbcommon
x11-libs/pango
x11-libs/pixman
- sys-libs/libcap
- clipboard? ( dev-libs/wl-clipboard )
elogind? ( >=sys-auth/elogind-239 )
- swaybar? ( x11-libs/gdk-pixbuf:2[jpeg] )
- swaybg? ( x11-libs/gdk-pixbuf:2[jpeg] )
+ swaybar? ( x11-libs/gdk-pixbuf:2 )
+ swaybg? ( x11-libs/gdk-pixbuf:2 )
swayidle? ( dev-libs/swayidle )
swaylock? ( dev-libs/swaylock )
systemd? ( >=sys-apps/systemd-239 )
- tray? ( >=sys-apps/dbus-1.10 )
- X? ( x11-libs/libxcb:0= )"
-DEPEND="${RDEPEND}"
+ X? ( x11-libs/libxcb:0= )
+"
+if [[ ${PV} == 9999 ]]; then
+ DEPEND+="~dev-libs/wlroots-9999[elogind=,systemd=,X=]"
+else
+ DEPEND+=">=dev-libs/wlroots-0.3[elogind=,systemd=,X=]"
+fi
+RDEPEND="
+ x11-misc/xkeyboard-config
+ ${DEPEND}
+"
BDEPEND="
- dev-libs/wayland-protocols
- doc? ( >=app-text/scdoc-1.8.1 )
- virtual/pkgconfig"
-
-FILECAPS=( cap_sys_admin usr/bin/sway )
+ >=dev-libs/wayland-protocols-1.14
+ virtual/pkgconfig
+ man? ( >=app-text/scdoc-1.8.1 )
+"
src_prepare() {
default
- use swaybar || sed -e "s/subdir('swaybar')//g" -i meson.build || die
+ use swaybar || sed -e "s/subdir('swaybar')//g" -e "/sway-bar.[0-9].scd/d" \
+ -e "/completions\/[a-z]\+\/_\?swaybar/d" -i meson.build || die
use swaybg || sed -e "s/subdir('swaybg')//g" -i meson.build || die
use swaymsg || sed -e "s/subdir('swaymsg')//g" -e "/swaymsg.[0-9].scd/d" \
-e "/completions\/[a-z]\+\/_\?swaymsg/d" -i meson.build || die
@@ -65,36 +70,40 @@ src_prepare() {
src_configure() {
local emesonargs=(
- $(meson_use bash-completion bash-completions)
- $(meson_use fish-completion fish-completions)
+ -Dman-pages=$(usex man enabled disabled)
+ -Dtray=$(usex tray enabled disabled)
+ -Dxwayland=$(usex X enabled disabled)
$(meson_use wallpapers default-wallpaper)
+ $(meson_use fish-completion fish-completions)
$(meson_use zsh-completion zsh-completions)
- "-Dtray=$(usex tray enabled disabled)"
- "-Dxwayland=$(usex X enabled disabled)"
+ "-Dbash-completions=true"
"-Dwerror=false"
)
+
if use swaybar || use swaybg; then
emesonargs+=("-Dgdk-pixbuf=enabled")
else
emesonargs+=("-Dgdk-pixbuf=disabled")
fi
- if [[ ${PV} != 9999 ]]; then
- emesonargs+=("-Dsway-version=${PV}")
- fi
meson_src_configure
}
-pkg_postinst() {
- elog "You must be in the input group to allow sway to access input devices!"
- local dbus_cmd=""
- if use tray; then
- dbus_cmd="dbus-launch --sh-syntax --exit-with-session "
+pkg_preinst() {
+ if ! use systemd && ! use elogind; then
+ fowners root:0 /usr/bin/sway
+ fperms 4511 /usr/bin/sway
fi
+}
+
+pkg_postinst() {
if ! use systemd && ! use elogind; then
- fcaps_pkg_postinst
elog ""
elog "If you use ConsoleKit2, remember to launch sway using:"
- elog "exec ck-launch-session ${dbus_cmd}sway"
+ elog "exec ck-launch-session sway"
+ elog ""
+ elog "If your system does not set the XDG_RUNTIME_DIR environment"
+ elog "variable, you must set it manually to run Sway. See wiki"
+ elog "for details: https://wiki.gentoo.org/wiki/Sway"
fi
}