summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-02 09:29:57 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-02 10:51:19 +0200
commitdcdfa9ed943c21ff06d3ba8f3c8b0f1b6e928219 (patch)
tree6713acc27bba4ff7038a6932387e2f3d7845242f
parentdev-python/decorator: Bump to 5.0.0 (diff)
downloadgentoo-dcdfa9ed.tar.gz
gentoo-dcdfa9ed.tar.bz2
gentoo-dcdfa9ed.zip
dev-python/nbformat: Bump to 5.1.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/nbformat/Manifest1
-rw-r--r--dev-python/nbformat/nbformat-5.1.3.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/nbformat/Manifest b/dev-python/nbformat/Manifest
index 7451ce253e0a..49e579fbea11 100644
--- a/dev-python/nbformat/Manifest
+++ b/dev-python/nbformat/Manifest
@@ -1 +1,2 @@
DIST nbformat-5.1.2.gh.tar.gz 152275 BLAKE2B 2a0758f33952547e5ef91f0ac0a8b98b97b882a8797c38feff6710a3a0824637f41396b152403e155e1af9805b7a85c189ba2a609076c591562e5f4bb783da29 SHA512 4fd574373c2f325b6d078a062878d139d741d30f9101f3344e0c7fc19bdf714f8ef71994134e76c90e1301102aac55cc490df8344f3ceb407002437f35d03944
+DIST nbformat-5.1.3.gh.tar.gz 130922 BLAKE2B 866eb53dd3f04c09f4a08303c5e84b672cc826d2d9b369cd85038b6c4075e74dce88fbcae80fc9b5450faf1c4971d121abe35e0a2ce2a8e73e020d2bed3a5594 SHA512 b4bc3d51d6e940ce1e2b1f5ca1005cf3d466b2b7b589383a31c4d2908c4e539344f4c8fb9e92993469d4d66f363c35082f0c16b8a63aa61e19fb24fa5ac910fd
diff --git a/dev-python/nbformat/nbformat-5.1.3.ebuild b/dev-python/nbformat/nbformat-5.1.3.ebuild
new file mode 100644
index 000000000000..40d57268d3bc
--- /dev/null
+++ b/dev-python/nbformat/nbformat-5.1.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_REQ_USE='sqlite'
+
+inherit distutils-r1
+
+DESCRIPTION="Reference implementation of the Jupyter Notebook format"
+HOMEPAGE="https://jupyter.org"
+# missing on pypi
+SRC_URI="
+ https://github.com/jupyter/nbformat/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/jsonschema-2.4.0[${PYTHON_USEDEP}]
+ dev-python/ipython_genutils[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-4.1[${PYTHON_USEDEP}]
+ dev-python/jupyter_core[${PYTHON_USEDEP}]
+ "
+BDEPEND="
+ test? (
+ dev-python/fastjsonschema[${PYTHON_USEDEP}]
+ dev-python/testpath[${PYTHON_USEDEP}]
+ )
+ "
+
+distutils_enable_sphinx docs \
+ dev-python/numpydoc
+distutils_enable_tests pytest