summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2018-09-09 21:57:35 +0200
committerThomas Deutschmann <whissi@gentoo.org>2018-09-09 22:40:57 +0200
commitdce5f03eaecc1889f45c8d5c470d54cea74f464e (patch)
treec8ce36cede15f1d548c69731602736cb0714be8f
parentapp-emulation/xen: bump to 4.10.1-r2 (diff)
downloadgentoo-dce5f03eaecc1889f45c8d5c470d54cea74f464e.tar.gz
gentoo-dce5f03eaecc1889f45c8d5c470d54cea74f464e.tar.bz2
gentoo-dce5f03eaecc1889f45c8d5c470d54cea74f464e.zip
app-admin/mongo-tools: bump to 4.0.2
Package-Manager: Portage-2.3.48, Repoman-2.3.10
-rw-r--r--app-admin/mongo-tools/Manifest1
-rw-r--r--app-admin/mongo-tools/mongo-tools-4.0.2.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/app-admin/mongo-tools/Manifest b/app-admin/mongo-tools/Manifest
index 9c4a955c7323..2393b43b60e2 100644
--- a/app-admin/mongo-tools/Manifest
+++ b/app-admin/mongo-tools/Manifest
@@ -14,3 +14,4 @@ DIST mongo-tools-3.6.6.tar.gz 4723751 BLAKE2B 876d46c47190398d1218a760bdeb8167c9
DIST mongo-tools-3.6.7.tar.gz 4723244 BLAKE2B 82a61b8e72122a9a2b80aceeaa6767fcb13740c324c83c53b18297d9138807950dc656506ffd8a694d2f697c934342541c0ca6f62539bb07be266093e82a17a6 SHA512 5367259f27cf21234db2f69693fc2e21051b42b1acc7eaf8f9b366ed264943cff179c8565239fe36bb1d5d21f5e08ec58ff0df5d4c60526d321d63389f37fac2
DIST mongo-tools-4.0.0.tar.gz 10872217 BLAKE2B 84e92178c0e4827926de525a70d6124635d59e270a3d37e23ec8653cc64d99bb7489fa6266917437ca45aa3ca5e00bc59b81e65c5b72e717db2701c6f7327bec SHA512 d67c4aca9b41266109adc39bb1a642206738fda393e1f9f05570c02a00a02e29ec71c71e67ad232c72d66543ae7e7bfe07fbcf26958d48ed0e631da452c1904d
DIST mongo-tools-4.0.1.tar.gz 10872813 BLAKE2B 21b36c550ee7147b013414d24042ca720d3fdb961759d8857b0ffb3ba1aa3f7f3bcb363c97287d1c7084dae246f9d7f49d2d0d5c8a11bc939fa9d3113b4c2b6e SHA512 69355ca7c8d97a9a8b257aa1cde672b3b4af7ceb5b37e2cf601746e102ca6ac290ec35c20728fdb6736dd28feb8e6b6e1b948e88fd2fb4c9b53c8a3cd3688d67
+DIST mongo-tools-4.0.2.tar.gz 10872395 BLAKE2B 6d02a51677509abb5a00f7f4f324a2c979d7e55ebd55754023c80e51e9e8121bea84692574739f83882c0426074c0a3a5c5df2cb8cba58ee80c06e5a75504a8d SHA512 45971d96c512a920c40052f0d11097e88db137e975125de375a63e8f0eefbe22ae5252d239455c60e12ef65e0abce7a658dfb9dda0cbcc153718bb6711cf5e43
diff --git a/app-admin/mongo-tools/mongo-tools-4.0.2.ebuild b/app-admin/mongo-tools/mongo-tools-4.0.2.ebuild
new file mode 100644
index 000000000000..8461951acd0c
--- /dev/null
+++ b/app-admin/mongo-tools/mongo-tools-4.0.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PV=${PV/_rc/-rc}
+MY_P=${PN}-r${MY_PV}
+
+DESCRIPTION="A high-performance, open source, schema-free document-oriented database"
+HOMEPAGE="https://www.mongodb.com"
+SRC_URI="https://github.com/mongodb/mongo-tools/archive/r${MY_PV}.tar.gz -> mongo-tools-${MY_PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="sasl ssl"
+
+RDEPEND="!<dev-db/mongodb-3.0.0"
+DEPEND="${RDEPEND}
+ dev-lang/go:=
+ net-libs/libpcap
+ sasl? ( dev-libs/cyrus-sasl )
+ ssl? ( dev-libs/openssl:0= )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ default
+
+ # 1) ensure we use bash wrt #582906
+ # 2) do not substitute version because it uses git
+ sed -e 's@/bin/sh@/bin/bash@g' \
+ -e '/^sed/,+3d' \
+ -e '/^stty/d' \
+ -e '/^mv/d' \
+ -i build.sh || die
+
+ # build pie to avoid text relocations wrt #582854
+ # skip on ppc64 wrt #610984
+ if ! use ppc64; then
+ sed -i 's/\(go build\)/\1 -buildmode=pie/g' build.sh || die
+ fi
+}
+
+src_compile() {
+ local myconf=()
+
+ if use sasl; then
+ myconf+=(sasl)
+ fi
+
+ if use ssl; then
+ myconf+=(ssl)
+ fi
+
+ ./build.sh "${myconf[@]}" || die "build failed"
+}
+
+src_install() {
+ dobin bin/*
+}