summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-07-07 09:00:54 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-07-07 12:53:08 +0200
commitdcf6ca0184d4d1eb0ce1de00e20968b3cecbacdd (patch)
tree3cb86d046063132e58dcb54a50505a6e2cd436e8
parentapp-office/kalendar: 22.04.3 version bump (diff)
downloadgentoo-dcf6ca0184d4d1eb0ce1de00e20968b3cecbacdd.tar.gz
gentoo-dcf6ca0184d4d1eb0ce1de00e20968b3cecbacdd.tar.bz2
gentoo-dcf6ca0184d4d1eb0ce1de00e20968b3cecbacdd.zip
dev-libs/kopeninghours: 22.04.3 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-libs/kopeninghours/Manifest1
-rw-r--r--dev-libs/kopeninghours/kopeninghours-22.04.3.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-libs/kopeninghours/Manifest b/dev-libs/kopeninghours/Manifest
index 31f7cd5bada5..2d798135bbc9 100644
--- a/dev-libs/kopeninghours/Manifest
+++ b/dev-libs/kopeninghours/Manifest
@@ -1,2 +1,3 @@
DIST kopeninghours-21.12.3.tar.xz 68916 BLAKE2B d80275c195231ca52e0042149d685224c9ffadd6d341ddce1af6f46df451442e924f282119c91ab004dcabb64b112de559bbbcddc2a91daee5cf9a76b84fb4bb SHA512 42bdbe8172ff5ff89469786f3d544db4a07bc0d1de9a54b8525dc8789d0f4328159ee815c07595463f190073433de567fb2d3496d261daa46aac70354b3da6ae
DIST kopeninghours-22.04.2.tar.xz 69172 BLAKE2B 7117c219aac659df2725cf2600cdafa4a676937303fe4bc8e151108759790a8123aa896f51ce3eb8f91477a5911d0d459791ff4b8cb73c45781223339a482ef3 SHA512 f27993e33922dd260c4a7b67cede7c0155ccb5f8b7d30a4fa9e1fe1fa4b80d3f0dd613edf06a0bade43a77bcfc1f8aa2173fbc7f2b4fa659948395b2c3554c3e
+DIST kopeninghours-22.04.3.tar.xz 69160 BLAKE2B 8875d1ee869c6cae8730e83ff8144e45a6ab24aff02ec85084022ab30f9274a2f7c5bd4e0bf88f27c3626ee580a6fac9e2446fa711823011b305ba9bdf1d88c9 SHA512 68e49cd35db2f381cfd88787ed2085e69c6485de87c2cd5783675784cb169d274115d9bc36cde6ed447d6cff6922278330ac1aa819a0d996f2a5b861f6f1bf7e
diff --git a/dev-libs/kopeninghours/kopeninghours-22.04.3.ebuild b/dev-libs/kopeninghours/kopeninghours-22.04.3.ebuild
new file mode 100644
index 000000000000..84b2cccc98d6
--- /dev/null
+++ b/dev-libs/kopeninghours/kopeninghours-22.04.3.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="true"
+ECM_TEST="true"
+KDE_GEAR="true"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.92.0
+QTMIN=5.15.4
+PYTHON_COMPAT=( python3_{8..11} )
+inherit ecm kde.org python-single-r1
+
+DESCRIPTION="Library for parsing and evaluating OSM opening hours expressions"
+HOMEPAGE="https://api.kde.org/kopeninghours/html/index.html
+https://invent.kde.org/libraries/kopeninghours"
+
+LICENSE="LGPL-2+"
+SLOT="5"
+KEYWORDS="~amd64"
+IUSE="python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="
+ >=dev-libs/kpublictransport-${PVCUT}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=kde-frameworks/kholidays-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ sys-libs/zlib
+ python? (
+ $(python_gen_cond_dep '
+ >=dev-libs/boost-1.70:=[python,${PYTHON_USEDEP}]
+ ')
+ )
+"
+RDEPEND="${DEPEND}
+ ${PYTHON_DEPS}
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+"
+
+PATCHES=( "${FILESDIR}"/${PN}-22.04.0-boostpython.patch )
+
+pkg_setup() {
+ ecm_pkg_setup
+ python_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBOOSTPYTHON_VERSION_MAJOR_MINOR=${EPYTHON}
+ $(cmake_use_find_package python Boost)
+ )
+ ecm_src_configure
+}
+
+src_install() {
+ ecm_src_install
+ python_optimize
+}