summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-27 09:08:34 +0000
committerSam James <sam@gentoo.org>2021-01-27 09:12:04 +0000
commitdd1f2fcc8f9a58365b2b83599717336fec0683f3 (patch)
tree7c4560f7e8211bed9077af11b02db23a89868899
parentdev-ml/async_unix: bump to 0.14.0 (diff)
downloadgentoo-dd1f2fcc8f9a58365b2b83599717336fec0683f3.tar.gz
gentoo-dd1f2fcc8f9a58365b2b83599717336fec0683f3.tar.bz2
gentoo-dd1f2fcc8f9a58365b2b83599717336fec0683f3.zip
dev-ml/async: bump to 0.14.0
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-ml/async/Manifest1
-rw-r--r--dev-ml/async/async-0.14.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-ml/async/Manifest b/dev-ml/async/Manifest
index d0c778ae6386..5b79a9b5ae79 100644
--- a/dev-ml/async/Manifest
+++ b/dev-ml/async/Manifest
@@ -1 +1,2 @@
+DIST async-0.14.0.tar.gz 65025 BLAKE2B 39e2bef8df12a9733b9ff11ce1bba22b095f79532ff27999e617db5c145e57ab2e1f7f9435a5952312a84dd75b24d76fd4279c524be933e8ded5be7b00d6729a SHA512 3e57ea742ab28d008e1c0b39a6fc6d0ac3ca78b644f678f79b9ceb8d9acb23fcd45fed52f744906ab6d9b87955a27a8e4512043db45a7c836323d96433124b5c
DIST async-0.9.0.tar.gz 17856 BLAKE2B b7206641936aa430ddc35091b89c465fe0abd98883c9206f3a978372dc016a35f41a228adf906def56f894eafabdb223463a77fc690e373bbd5284c590871924 SHA512 93c0fa4d6e7d1c4dff1f460db8ec95b3eea1d7c19fda117bb9efc8711f4908d2922467c33f66659395169ead9b37931da16a85a031d6073fc9296c218f2c55bb
diff --git a/dev-ml/async/async-0.14.0.ebuild b/dev-ml/async/async-0.14.0.ebuild
new file mode 100644
index 000000000000..5f2a17b7ce82
--- /dev/null
+++ b/dev-ml/async/async-0.14.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Jane Street Capital's asynchronous execution library"
+HOMEPAGE="https://github.com/janestreet/async"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+# Need qtest_lib, netkit_sockets
+# Unpackaged test deps
+RESTRICT="test"
+
+RDEPEND="
+ dev-ml/async_extra:=
+ dev-ml/async_kernel:=
+ dev-ml/async_unix:=
+ dev-ml/core:=
+ dev-ml/core_kernel:=
+ dev-ml/ppx_jane:=
+ dev-ml/textutils:=
+"
+DEPEND="${RDEPEND}"