summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2024-04-30 10:36:31 -0700
committerPatrick McLean <chutzpah@gentoo.org>2024-04-30 10:37:04 -0700
commitdd22216d80551641fd19620410c76195e689887f (patch)
tree348510faaf3a6fe025b1a7a9bfd1423367893d26
parentdev-libs/cpuinfo: drop 2023.11.04 (diff)
downloadgentoo-dd22216d80551641fd19620410c76195e689887f.tar.gz
gentoo-dd22216d80551641fd19620410c76195e689887f.tar.bz2
gentoo-dd22216d80551641fd19620410c76195e689887f.zip
app-admin/ansible-modules-hashivault: add 5.2.1
Closes: https://bugs.gentoo.org/929270 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
-rw-r--r--app-admin/ansible-modules-hashivault/Manifest1
-rw-r--r--app-admin/ansible-modules-hashivault/ansible-modules-hashivault-5.2.1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/app-admin/ansible-modules-hashivault/Manifest b/app-admin/ansible-modules-hashivault/Manifest
index dd593c9ebb12..c5d651fc237f 100644
--- a/app-admin/ansible-modules-hashivault/Manifest
+++ b/app-admin/ansible-modules-hashivault/Manifest
@@ -1,2 +1,3 @@
DIST ansible-modules-hashivault-4.6.8.tar.gz 94253 BLAKE2B 2b6a315cfd051a2e16d889a8784a9185b86b98b3d96ba19f6bdde8b628ce94622c360b60cb59dfcae790fc822f2c41eacd5428356b48324aa2704f0048821c2d SHA512 4b3487e553e6dea5fbefbb383ce22d018ed9f83378d601574badfb2be8dd3f98c54caf975690d3116df6cca970d8e2d3932f0d0ccb1f18f7145aee0beae79f96
DIST ansible-modules-hashivault-5.1.0.gh.tar.gz 100025 BLAKE2B 6bedb1269a5f39be777ab24e973a52a708d5871cf99f6e7018caa703bc4e8222fec9a40b6b5b980c67e2574034511fe810cba656278336dce0ca3b52f880bcb6 SHA512 cc442a80a4a15e013352202912af6db889afe793aa5baebd8056312eea42c7a819fdae32c9199ec297b9c4aa30719017bff964934d7f94571f368996328619ab
+DIST ansible-modules-hashivault-5.2.1.gh.tar.gz 101636 BLAKE2B 3395dc86917b8a35b6ff34f9c518969100fde0e0f760760cbf7c126f5f782e22a01bfe60e9dae89cef49839e80d4f5c0ff2731672cdd616c3eac545d6b507072 SHA512 374edef8c47a27c6a9cde55e8b9294b05c0f222a2ff21e68551558e197d6a938c17a88fa85f18e25f2123585ed0465507b2759036ac834a55ee68c13f54304b4
diff --git a/app-admin/ansible-modules-hashivault/ansible-modules-hashivault-5.2.1.ebuild b/app-admin/ansible-modules-hashivault/ansible-modules-hashivault-5.2.1.ebuild
new file mode 100644
index 000000000000..729da2c55e80
--- /dev/null
+++ b/app-admin/ansible-modules-hashivault/ansible-modules-hashivault-5.2.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Ansible module for hashicorp vault"
+HOMEPAGE="https://www.ansible.com/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/TerryHowe/ansible-modules-hashivault.git"
+else
+ SRC_URI="https://github.com/TerryHowe/ansible-modules-hashivault/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~arm64"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ >=app-admin/ansible-2.12.0[${PYTHON_USEDEP}]
+ >=dev-python/hvac-1.2.1[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+
+# The tests require a private instance of vault
+RESTRICT="test"
+
+python_prepare_all() {
+ sed -i 's:description-file:description_file:' setup.cfg || die
+ distutils-r1_python_prepare_all
+}