summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-07-06 10:45:35 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-07-06 10:53:25 +0000
commitdd40e012e16f581052aca2580300caeb1b1fb644 (patch)
treeb0cb0afb875e7f4aab4c30ecae5baf9b22f6a3d5
parentnet-misc/stunnel: reload configuration using HUP, bug #588054 (diff)
downloadgentoo-dd40e012e16f581052aca2580300caeb1b1fb644.tar.gz
gentoo-dd40e012e16f581052aca2580300caeb1b1fb644.tar.bz2
gentoo-dd40e012e16f581052aca2580300caeb1b1fb644.zip
dev-python/schema: Add the schema library to the tree.
schema is a library for validating Python data structures, such as those obtained from config-files, forms, external services or command-line parsing, converted from JSON/YAML (or something else) to Python data-types. Package-Manager: portage-2.2.28
-rw-r--r--dev-python/schema/Manifest1
-rw-r--r--dev-python/schema/metadata.xml8
-rw-r--r--dev-python/schema/schema-0.5.0.ebuild24
3 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/schema/Manifest b/dev-python/schema/Manifest
new file mode 100644
index 000000000000..dd42dd6b5f99
--- /dev/null
+++ b/dev-python/schema/Manifest
@@ -0,0 +1 @@
+DIST schema-0.5.0.tar.gz 8765 SHA256 fa982e925cfe56ce036b5776aff6179621cae5994b9066d17a33143fd5ddf883 SHA512 8eab5f8dc8e544d14c19b9355ffe5f542dd06003133bcd3fc642f95cf1da8286a0146fae666ba656450d4b564da6f0933b9d64ae54e88202b4c5c5150ffbc033 WHIRLPOOL eb73ab0b399bb123a109721f14f2283c5e7b1ed08d55ba7cc04ccece4b745979515cd5d1913e3f099738fdb64e83f5202ebbfacaed523cd0828245de62fac771
diff --git a/dev-python/schema/metadata.xml b/dev-python/schema/metadata.xml
new file mode 100644
index 000000000000..e24dd86faa2a
--- /dev/null
+++ b/dev-python/schema/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/schema/schema-0.5.0.ebuild b/dev-python/schema/schema-0.5.0.ebuild
new file mode 100644
index 000000000000..80c11187a678
--- /dev/null
+++ b/dev-python/schema/schema-0.5.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Library for validating Python data structures"
+HOMEPAGE="https://pypi.python.org/pypi/schema https://github.com/keleshev/schema"
+SRC_URI="
+ mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ https://github.com/keleshev/schema/archive/v${PV}.zip -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"