summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2019-09-30 23:09:42 +0100
committerJames Le Cuirot <chewi@gentoo.org>2019-09-30 23:09:42 +0100
commitdd5d473e63ad1c696ebde0622e92b739b4d05489 (patch)
tree383cd803b1f81c5bc390f9c65251711040bfd09c
parentdev-libs/angelscript: Bump to 2.34.0, drop old 2.33.0 (diff)
downloadgentoo-dd5d473e63ad1c696ebde0622e92b739b4d05489.tar.gz
gentoo-dd5d473e63ad1c696ebde0622e92b739b4d05489.tar.bz2
gentoo-dd5d473e63ad1c696ebde0622e92b739b4d05489.zip
app-emulation/gallium-nine-standalone: Bump to 0.5
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
-rw-r--r--app-emulation/gallium-nine-standalone/Manifest1
-rw-r--r--app-emulation/gallium-nine-standalone/files/0.5-flags.patch28
-rw-r--r--app-emulation/gallium-nine-standalone/gallium-nine-standalone-0.5.ebuild109
-rw-r--r--app-emulation/gallium-nine-standalone/gallium-nine-standalone-9999.ebuild2
4 files changed, 139 insertions, 1 deletions
diff --git a/app-emulation/gallium-nine-standalone/Manifest b/app-emulation/gallium-nine-standalone/Manifest
index 3d4616309b72..72d80c4764ef 100644
--- a/app-emulation/gallium-nine-standalone/Manifest
+++ b/app-emulation/gallium-nine-standalone/Manifest
@@ -1,2 +1,3 @@
DIST gallium-nine-standalone-0.3.tar.gz 63887 BLAKE2B bd198617a5d3d3830bd5127b63eed2c82bff037141ae72ff9237ad5062fdbe9b6797e233eaf86e06d92153487c53389eb094b0be3b0cbdbf3fe565292a15cbb0 SHA512 80fedca58523fbf318109d2d3d5420e97d26ebf5b89b9f1965165c7a33c9dab9c62a65f14b75569b5126c549f5df91beef372d54e94dc90c608932eeb6a59829
DIST gallium-nine-standalone-0.4.tar.gz 66820 BLAKE2B 7e7b0028f0c7e7c26fa1ee164e7e867fee39a5f315b750bfc3537e8720e9fbc625ca27fb28a58e8e521af455f8ab347d6fd6ca82786fe5ac9d76e368cd43466e SHA512 6af31e828400c6f711c76d91fb65215f4ba79c31b8d98f3e953b319593d96d1e5e78e07aca96529de37bbb89f3479a4d4db5f58e32ce7b98667284be10a9e532
+DIST gallium-nine-standalone-0.5.tar.gz 69056 BLAKE2B 6acfd500a31e480e2e09e751097beaa2bc94c574edd2b313adb707dc65447be1868ed190bf13549cc38eae945d421242a5d3b2c068486ad35347903e27e0bf80 SHA512 6223a851536c67d32e3a834d7a3c7b93fb59c226b127e1ee1b5a72a7cc93172173f5004ca4944a842015650ef80e8427a684109ae5a4a9e9ef838961e0767c78
diff --git a/app-emulation/gallium-nine-standalone/files/0.5-flags.patch b/app-emulation/gallium-nine-standalone/files/0.5-flags.patch
new file mode 100644
index 000000000000..7c0e883d697d
--- /dev/null
+++ b/app-emulation/gallium-nine-standalone/files/0.5-flags.patch
@@ -0,0 +1,28 @@
+diff -Naur a/tools/cross-wine32.in b/tools/cross-wine32.in
+--- a/tools/cross-wine32.in 2019-09-25 13:25:24.000000000 +0100
++++ b/tools/cross-wine32.in 2019-09-30 23:05:00.121344967 +0100
+@@ -5,8 +5,8 @@
+ pkgconfig = '@PKG_CONFIG@'
+
+ [properties]
+-c_args = ['-m32']
+-c_link_args = ['-m32', '-mwindows']
++c_args = @CFLAGS@ + ['-m32']
++c_link_args = @LDFLAGS@ + ['-m32', '-mwindows']
+ needs_exe_wrapper = true
+
+ [host_machine]
+diff -Naur a/tools/cross-wine64.in b/tools/cross-wine64.in
+--- a/tools/cross-wine64.in 2019-09-25 13:25:24.000000000 +0100
++++ b/tools/cross-wine64.in 2019-09-30 23:04:57.340283350 +0100
+@@ -5,8 +5,8 @@
+ pkgconfig = '@PKG_CONFIG@'
+
+ [properties]
+-c_args = ['-m64']
+-c_link_args = ['-m64', '-mwindows']
++c_args = @CFLAGS@ + ['-m64']
++c_link_args = @LDFLAGS@ + ['-m64', '-mwindows']
+ needs_exe_wrapper = true
+
+ [host_machine]
diff --git a/app-emulation/gallium-nine-standalone/gallium-nine-standalone-0.5.ebuild b/app-emulation/gallium-nine-standalone/gallium-nine-standalone-0.5.ebuild
new file mode 100644
index 000000000000..1358e3c9e1ce
--- /dev/null
+++ b/app-emulation/gallium-nine-standalone/gallium-nine-standalone-0.5.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson multilib-minimal toolchain-funcs
+
+MY_PN="wine-nine-standalone"
+DESCRIPTION="A standalone version of the WINE parts of Gallium Nine"
+HOMEPAGE="https://github.com/iXit/wine-nine-standalone"
+
+if [[ $PV = 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/iXit/${MY_PN}.git"
+else
+ SRC_URI="https://github.com/iXit/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+ KEYWORDS="-* ~amd64 ~x86"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+# We don't put Wine in RDEPEND because you can also use this with
+# Steam's Proton.
+
+RDEPEND="
+ media-libs/mesa[d3d9,dri3,X(+),${MULTILIB_USEDEP}]
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libxcb[${MULTILIB_USEDEP}]
+"
+
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+ virtual/wine[${MULTILIB_USEDEP}]
+ >=dev-util/meson-0.50.1
+"
+
+PATCHES=(
+ "${FILESDIR}"/0.5-flags.patch
+ "${FILESDIR}"/0.3-nine-dll-path.patch
+)
+
+bits() {
+ if [[ ${ABI} = amd64 ]]; then
+ echo 64
+ else
+ echo 32
+ fi
+}
+
+src_prepare() {
+ default
+
+ # Upstream includes a bootstrap.sh script with hardcoded CHOSTs to
+ # create the Meson cross files. We improve on that here but also
+ # inject CFLAGS and LDFLAGS, partly to simply respect these, and
+ # partly to allow d3d9-nine.dll to be loaded from a location outside
+ # WINEPREFIX. This avoids the need for the nine-install.sh script,
+ # which doesn't play well with our multi-Wine environment.
+ bootstrap_nine() {
+ local file=tools/cross-wine$(bits)
+ local g9dll=\"Z:${EPREFIX}/usr/$(get_libdir)/d3d9-nine.dll.so\"
+
+ sed \
+ -e "s!@PKG_CONFIG@!$(tc-getPKG_CONFIG)!" \
+ -e "s!@CFLAGS@!$(_meson_env_array "${CFLAGS} '-DG9DLL=${g9dll}'")!" \
+ -e "s!@LDFLAGS@!$(_meson_env_array "${LDFLAGS}")!" \
+ ${file}.in > ${file} || die
+ }
+
+ multilib_foreach_abi bootstrap_nine
+}
+
+multilib_src_configure() {
+ # We override bindir because otherwise the 32-bit exe is overwritten
+ # by the 64-bit exe and we need both of them.
+ local emesonargs=(
+ --cross-file "${S}/tools/cross-wine$(bits)"
+ --bindir "$(get_libdir)"
+ -Ddistro-independent=false
+ -Ddri2=false
+ )
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_install() {
+ meson_src_install
+}
+
+pkg_postinst() {
+ local bits=$(bits)
+
+ einfo "Don't remove the Z: drive from your WINEPREFIX as this relies on it."
+ einfo
+ einfo "To set up the ${bits}-bit library, launch your preferred Wine as follows:"
+ einfo " wine${bits/32} ${EPREFIX}/usr/$(get_libdir)/ninewinecfg.exe.so"
+
+ if use abi_x86_64 && use abi_x86_32; then
+ einfo
+ einfo "To set up the 32-bit library, launch your preferred Wine as follows:"
+ einfo " wine ${EPREFIX}/usr/$(ABI=x86 get_libdir)/ninewinecfg.exe.so"
+ fi
+}
diff --git a/app-emulation/gallium-nine-standalone/gallium-nine-standalone-9999.ebuild b/app-emulation/gallium-nine-standalone/gallium-nine-standalone-9999.ebuild
index 3c025087d82e..1358e3c9e1ce 100644
--- a/app-emulation/gallium-nine-standalone/gallium-nine-standalone-9999.ebuild
+++ b/app-emulation/gallium-nine-standalone/gallium-nine-standalone-9999.ebuild
@@ -38,7 +38,7 @@ DEPEND="
"
PATCHES=(
- "${FILESDIR}"/flags.patch
+ "${FILESDIR}"/0.5-flags.patch
"${FILESDIR}"/0.3-nine-dll-path.patch
)