summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-10-29 21:23:00 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-10-30 01:06:22 +0200
commitdd76a2dbc5912761d66cb7ea6e8341ba195579d4 (patch)
tree8b30d2f4f6198a9a507ae2dc0312c76129b3dc55
parentnet-misc/gallery-dl: drop old 1.21.2-r1 (diff)
downloadgentoo-dd76a2db.tar.gz
gentoo-dd76a2db.tar.bz2
gentoo-dd76a2db.zip
net-misc/gallery-dl: bump to 1.23.4
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--net-misc/gallery-dl/Manifest1
-rw-r--r--net-misc/gallery-dl/gallery-dl-1.23.4.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/net-misc/gallery-dl/Manifest b/net-misc/gallery-dl/Manifest
index 95486dece893..33d98d973381 100644
--- a/net-misc/gallery-dl/Manifest
+++ b/net-misc/gallery-dl/Manifest
@@ -2,3 +2,4 @@ DIST gallery-dl-1.22.4.tar.gz 467129 BLAKE2B f2f656b3255d091361bd2c80bb2647de47a
DIST gallery-dl-1.23.0.gh.tar.gz 473431 BLAKE2B 1f485477ea150585050f24fbe3605195b9b8ffca3d39d3dde5f2160c2ceb3dd75bb691cc14c178d236c690ff6d2effe147242abcb67feda7b77b829f440e2ac4 SHA512 8e17532c094c9516593f9009eca7139e60d7474a56c76bb07a68c03eae4e2e8e31c6bd1f167388d05a1104d5964e2d0b62272c506b2b6988b1832a36a492cbf9
DIST gallery-dl-1.23.1.gh.tar.gz 477797 BLAKE2B abb04762755cc941d3fef31ba2cf21eab4b0afa196a67276d26199a044950cf68607bf7bd4e26bd3631de1e715a7ca25248a658aac1ac56cbb3e2a6ef5b2d71b SHA512 898fd952cc6e590a11e4154449153bd48547c9f21cba6864c95953f9be18ad27391d8033e5350d41714b28ded5711ddefefd4ca0f3c13016972a16b028a0fc1d
DIST gallery-dl-1.23.3.gh.tar.gz 488200 BLAKE2B 88482c7f41da00447b6eeb6331d61f6c0f7eebc5c597f16bb197b2f3c431803c15179a27ba66909ca5354d9031667bbe4303653701cae96d9aadecb507f9df00 SHA512 ca7bf54ac3244fbf62398981b82094220c6cfe5c548b4a1bacddc67ab8abc87fa8f1f59bdeff4015ce9406ca289fa4ec8965c85b839acb9f218545f28d368d39
+DIST gallery-dl-1.23.4.gh.tar.gz 491268 BLAKE2B 55606eaab571cb907fa11efd1b0aa8af169f4eda8d3a28a2730b98dbe102a74df5237bf4d0ae32ee4f1703a9a61c0e60031528090bc5c183ab30ca34fdd27b00 SHA512 b02f68707432b1d3e0ec225d19fd9b8951c847af2b7213f9255252ea6ad099253945b8e5af18a544135e8f383fa5e30fdcce205e2cb6428469062da6c90f4c12
diff --git a/net-misc/gallery-dl/gallery-dl-1.23.4.ebuild b/net-misc/gallery-dl/gallery-dl-1.23.4.ebuild
new file mode 100644
index 000000000000..982779112300
--- /dev/null
+++ b/net-misc/gallery-dl/gallery-dl-1.23.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="sqlite,ssl,xml(+)"
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Download image galleries and collections from several image hosting sites"
+HOMEPAGE="https://github.com/mikf/gallery-dl"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mikf/${PN}.git"
+else
+ SRC_URI="https://github.com/mikf/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+# tests require network access
+RESTRICT="test"
+
+RDEPEND=">=dev-python/requests-2.11.0[${PYTHON_USEDEP}]"
+
+distutils_enable_tests setup.py
+
+python_compile_all() {
+ emake PYTHON=${EPYTHON} data/completion/{,_}gallery-dl man
+}
+
+pkg_postinst() {
+ optfeature "Pixiv Ugoira to WebM conversion" media-video/ffmpeg
+ optfeature "video downloads" net-misc/youtube-dl
+}