summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2016-03-22 19:30:07 +1300
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-03-27 22:56:21 +0200
commitdd82b7c9de8606fd024002e5153cf8f1f5d70fd7 (patch)
treeb3c46e665380dad55953884d956d91c9bc4f640f
parentdev-perl/Authen-Simple-Passwd: Added at 0.600.0 (diff)
downloadgentoo-dd82b7c9.tar.gz
gentoo-dd82b7c9.tar.bz2
gentoo-dd82b7c9.zip
dev-perl/HTTP-Request-AsCGI: Added at version 1.200.0
Used by dev-perl/Plack for tests. Previously maintained in ::perl-experimental since Jan 2008 by Torsten Veller, Michele Beltrame and Kent Fredric Package-Manager: portage-2.2.28
-rw-r--r--dev-perl/HTTP-Request-AsCGI/HTTP-Request-AsCGI-1.200.0.ebuild37
-rw-r--r--dev-perl/HTTP-Request-AsCGI/Manifest1
-rw-r--r--dev-perl/HTTP-Request-AsCGI/metadata.xml12
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-perl/HTTP-Request-AsCGI/HTTP-Request-AsCGI-1.200.0.ebuild b/dev-perl/HTTP-Request-AsCGI/HTTP-Request-AsCGI-1.200.0.ebuild
new file mode 100644
index 000000000000..32713e6ee8ab
--- /dev/null
+++ b/dev-perl/HTTP-Request-AsCGI/HTTP-Request-AsCGI-1.200.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=FLORA
+DIST_VERSION=1.2
+inherit perl-module
+
+DESCRIPTION="Set up a CGI environment from an HTTP::Request"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="
+ virtual/perl-Carp
+ dev-perl/Class-Accessor
+ >=dev-perl/HTTP-Message-1.530.0
+ virtual/perl-IO
+ dev-perl/URI
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+src_test() {
+ perl_rm_files "t/release-pod-syntax.t" "t/release-pod-coverage.t"
+ perl-module_src_test
+}
+src_install() {
+ perl-module_src_install
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
+ docinto examples
+ dodoc -r examples
+ fi
+}
diff --git a/dev-perl/HTTP-Request-AsCGI/Manifest b/dev-perl/HTTP-Request-AsCGI/Manifest
new file mode 100644
index 000000000000..06818f55e6bb
--- /dev/null
+++ b/dev-perl/HTTP-Request-AsCGI/Manifest
@@ -0,0 +1 @@
+DIST HTTP-Request-AsCGI-1.2.tar.gz 14173 SHA256 945bfb07c6d1af52773fb7845ba62e3a74111b35cbd2d5e43ef8319e55acbcea SHA512 5ea9fe149c7c938af5a089fafe4585f50ea98cd6bab0e06f6de5c8b89c2b749c2cf759fdd8aa70a2d65e34971d030342924c2eafd72b9290da3831eadcc29e89 WHIRLPOOL 81df32b5b2cfa21f91cc964100b12d4bbca6851d43ad76e4db8f1afa8172d546590d4619ee35b381a6e111de0aef1b18aae2d4928bf7c00a4e81b44e0700c9c8
diff --git a/dev-perl/HTTP-Request-AsCGI/metadata.xml b/dev-perl/HTTP-Request-AsCGI/metadata.xml
new file mode 100644
index 000000000000..decda735e0ee
--- /dev/null
+++ b/dev-perl/HTTP-Request-AsCGI/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">HTTP-Request-AsCGI</remote-id>
+ <remote-id type="cpan-module">HTTP::Request::AsCGI</remote-id>
+ </upstream>
+</pkgmetadata>