summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-27 11:26:44 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-27 11:29:43 +0200
commitddac6c4f8949bf3948b1f2fe2e24704af0403b15 (patch)
treef67f99d05194afdbca52d03a19ada8dd3f2752dc
parentdev-python/joblib: Remove old (diff)
downloadgentoo-ddac6c4f8949bf3948b1f2fe2e24704af0403b15.tar.gz
gentoo-ddac6c4f8949bf3948b1f2fe2e24704af0403b15.tar.bz2
gentoo-ddac6c4f8949bf3948b1f2fe2e24704af0403b15.zip
dev-python/google-api-core: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/google-api-core/Manifest1
-rw-r--r--dev-python/google-api-core/google-api-core-2.7.3.ebuild66
2 files changed, 0 insertions, 67 deletions
diff --git a/dev-python/google-api-core/Manifest b/dev-python/google-api-core/Manifest
index 4b4cd09b4db3..84c156f7fbff 100644
--- a/dev-python/google-api-core/Manifest
+++ b/dev-python/google-api-core/Manifest
@@ -1,3 +1,2 @@
-DIST google-api-core-2.7.3.tar.gz 164219 BLAKE2B c394fd95bff3ac393174372e0c49f9a7974a006de6f14d07af7b15b4c531d6dae7af8c38e00263289a895cb9dae9ef23368d793f5ae3649b9b029337a72cc0ef SHA512 2bf49738216cd52dad2bdfb3367e370390c366b49a8c3c4f6f49a2a3f17b27120d99933b57c8eb8c9a1f0f25ef5ea6d876cf8c3c6c759d3585d625e57b1153f9
DIST python-api-core-2.8.1.gh.tar.gz 164630 BLAKE2B 88db73f210ae5ee4aa2e7382ea34ef59fb51f88e196622556327c130057b74594884bbe21719bf12cc6ddc9975cf12ac71fa24ac4dfde4681b4742af57702b5d SHA512 f3bfa476562428246203592b53c22e8e52af167af10b1fa68afb51fe6e8ca8090e9231e4c297847d12c201ca791aa80153bee07f72939bc65920260ec50b3d38
DIST python-api-core-2.8.2.gh.tar.gz 164586 BLAKE2B bd62b20d1be52f0a2227d1663ee37ce31d991e0773ed793a3999b70c74e03a28ac188cc331027def0055a5b80e93378d9ec5baa389c65e7d2f183b37233be5ac SHA512 5844339cee71103650c446f002dcb13a632086d96dec1ed04a0ad5e4d3a61cc2a8e048da3e6445a50a0c009b0d25729f02865d28484bfee2a3427c829537e350
diff --git a/dev-python/google-api-core/google-api-core-2.7.3.ebuild b/dev-python/google-api-core/google-api-core-2.7.3.ebuild
deleted file mode 100644
index 060a7a5bb115..000000000000
--- a/dev-python/google-api-core/google-api-core-2.7.3.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 2020-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Core Library for Google Client Libraries"
-HOMEPAGE="https://github.com/googleapis/python-api-core/
- https://googleapis.dev/python/google-api-core/latest/index.html"
-SRC_URI="https://github.com/googleapis/${PN//google/python}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${P//google/python}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86"
-
-RDEPEND="
- dev-python/protobuf-python[${PYTHON_USEDEP}]
- dev-python/googleapis-common-protos[${PYTHON_USEDEP}]
- >=dev-python/google-auth-1.25.0[${PYTHON_USEDEP}]
- >=dev-python/requests-2.18.0[${PYTHON_USEDEP}]
- <dev-python/requests-3[${PYTHON_USEDEP}]
- !dev-python/namespace-google
-"
-BDEPEND="
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/proto-plus[${PYTHON_USEDEP}]
- dev-python/rsa[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # failing due to missing grpcio-status
- tests/asyncio/test_grpc_helpers_async.py::test_wrap_unary_errors
- tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_raised
- tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_read
- tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_aiter
- tests/asyncio/test_grpc_helpers_async.py::test_wrap_stream_errors_write
- tests/unit/test_grpc_helpers.py::test_wrap_unary_errors
- tests/unit/test_grpc_helpers.py::test_wrap_stream_errors_invocation
- tests/unit/test_grpc_helpers.py::test_wrap_stream_errors_iterator_initialization
- tests/unit/test_grpc_helpers.py::test_wrap_stream_errors_during_iteration
-)
-
-python_compile() {
- distutils-r1_python_compile
- find "${BUILD_DIR}" -name '*.pth' -delete || die
-}
-
-src_test() {
- rm -r google || die
- distutils-r1_src_test
-}
-
-python_test() {
- distutils_write_namespace google
- epytest -p no:aiohttp -p no:trio tests
-}