summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2021-08-18 14:46:13 -0400
committerRick Farina <zerochaos@gentoo.org>2021-08-18 14:46:26 -0400
commitddb69dd3c968ed5cb343375c6f35bc501f9b875e (patch)
treee36f773b0b26c8ebbcc4e77d2de97997ce50a1aa
parentapp-admin/exo: version bump to 1.40.3 - remove old. (diff)
downloadgentoo-ddb69dd3c968ed5cb343375c6f35bc501f9b875e.tar.gz
gentoo-ddb69dd3c968ed5cb343375c6f35bc501f9b875e.tar.bz2
gentoo-ddb69dd3c968ed5cb343375c6f35bc501f9b875e.zip
net-wireless/dump1090: fix 32 bit build
Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
-rw-r--r--net-wireless/dump1090/dump1090-5.0.ebuild4
-rw-r--r--net-wireless/dump1090/files/dump1090-5.0-32bit-fix.patch21
2 files changed, 25 insertions, 0 deletions
diff --git a/net-wireless/dump1090/dump1090-5.0.ebuild b/net-wireless/dump1090/dump1090-5.0.ebuild
index dc9893bd0a78..3307e87796d4 100644
--- a/net-wireless/dump1090/dump1090-5.0.ebuild
+++ b/net-wireless/dump1090/dump1090-5.0.ebuild
@@ -28,6 +28,10 @@ DEPEND="
RDEPEND="${DEPEND}"
BDEPEND="virtual/pkgconfig"
+PATCHES=(
+ "${FILESDIR}/${P}-32bit-fix.patch"
+)
+
src_prepare() {
default
sed -i -e '/CFLAGS/s# -O3 -g -Wall -Wmissing-declarations -Werror -W # #' Makefile || die
diff --git a/net-wireless/dump1090/files/dump1090-5.0-32bit-fix.patch b/net-wireless/dump1090/files/dump1090-5.0-32bit-fix.patch
new file mode 100644
index 000000000000..8425f3d9da06
--- /dev/null
+++ b/net-wireless/dump1090/files/dump1090-5.0-32bit-fix.patch
@@ -0,0 +1,21 @@
+From c97b83d3eded3e2232a9f938fee52771ebe09c9c Mon Sep 17 00:00:00 2001
+From: Oliver Jowett <oliver.jowett@flightaware.com>
+Date: Sat, 13 Mar 2021 20:24:01 +0800
+Subject: [PATCH] Maybe fix alignment warnings in arm neon code with recent gcc
+
+---
+ dsp-types.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/dsp-types.h b/dsp-types.h
+index a3ef98dab..962b608be 100644
+--- a/dsp-types.h
++++ b/dsp-types.h
+@@ -16,6 +16,6 @@ typedef union {
+ typedef struct {
+ int16_t I;
+ int16_t Q;
+-} __attribute__((__packed__)) sc16_t;
++} __attribute__((__packed__, __aligned__(2))) sc16_t;
+
+ #endif