summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-10-13 05:26:31 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-10-13 05:27:13 +0200
commitddc29801908fdacdbcc17df0d1e7d124479ae610 (patch)
tree7207708593514da6e9623e7982f40e3f1b77c1e3
parentdev-perl/Perl-Tidy: Version bump to 20190915 (diff)
downloadgentoo-ddc29801.tar.gz
gentoo-ddc29801.tar.bz2
gentoo-ddc29801.zip
dev-util/strace: add linux-5.3 compatibility
Closes: https://bugs.gentoo.org/695260 Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
-rw-r--r--dev-util/strace/files/strace-5.2-linux-5.3-compat.patch75
-rw-r--r--dev-util/strace/strace-5.2.ebuild2
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-util/strace/files/strace-5.2-linux-5.3-compat.patch b/dev-util/strace/files/strace-5.2-linux-5.3-compat.patch
new file mode 100644
index 000000000000..254326f04577
--- /dev/null
+++ b/dev-util/strace/files/strace-5.2-linux-5.3-compat.patch
@@ -0,0 +1,75 @@
+https://github.com/strace/strace/commit/60da39553ff92cf741bf7f54daff636bb28cbb3c
+https://bugs.gentoo.org/695260
+
+--- a/xlat/v4l2_pix_fmts.h
++++ b/xlat/v4l2_pix_fmts.h
+@@ -269,19 +269,23 @@ DIAG_POP_IGNORE_TAUTOLOGICAL_COMPARE
+ #else
+ # define V4L2_PIX_FMT_MPEG1 v4l2_fourcc('M', 'P', 'G', '1')
+ #endif
+-#if defined(V4L2_PIX_FMT_BGRA444) || (defined(HAVE_DECL_V4L2_PIX_FMT_BGRA444) && HAVE_DECL_V4L2_PIX_FMT_BGRA444)
++#if defined(V4L2_PIX_FMT_SGRBG12) || (defined(HAVE_DECL_V4L2_PIX_FMT_SGRBG12) && HAVE_DECL_V4L2_PIX_FMT_SGRBG12)
+ DIAG_PUSH_IGNORE_TAUTOLOGICAL_COMPARE
+-static_assert((V4L2_PIX_FMT_BGRA444) == (v4l2_fourcc('B', 'A', '1', '2')), "V4L2_PIX_FMT_BGRA444 != v4l2_fourcc('B', 'A', '1', '2')");
++static_assert((V4L2_PIX_FMT_SGRBG12) == (v4l2_fourcc('B', 'A', '1', '2')), "V4L2_PIX_FMT_SGRBG12 != v4l2_fourcc('B', 'A', '1', '2')");
+ DIAG_POP_IGNORE_TAUTOLOGICAL_COMPARE
+ #else
+-# define V4L2_PIX_FMT_BGRA444 v4l2_fourcc('B', 'A', '1', '2')
++# define V4L2_PIX_FMT_SGRBG12 v4l2_fourcc('B', 'A', '1', '2')
+ #endif
+-#if defined(V4L2_PIX_FMT_SGRBG12) || (defined(HAVE_DECL_V4L2_PIX_FMT_SGRBG12) && HAVE_DECL_V4L2_PIX_FMT_SGRBG12)
++#ifndef STRACE_WORKAROUND_FOR_V4L2_PIX_FMT_BGRA444
++# define STRACE_WORKAROUND_FOR_V4L2_PIX_FMT_BGRA444
++# undef V4L2_PIX_FMT_BGRA444
++#endif
++#if defined(V4L2_PIX_FMT_BGRA444) || (defined(HAVE_DECL_V4L2_PIX_FMT_BGRA444) && HAVE_DECL_V4L2_PIX_FMT_BGRA444)
+ DIAG_PUSH_IGNORE_TAUTOLOGICAL_COMPARE
+-static_assert((V4L2_PIX_FMT_SGRBG12) == (v4l2_fourcc('B', 'A', '1', '2')), "V4L2_PIX_FMT_SGRBG12 != v4l2_fourcc('B', 'A', '1', '2')");
++static_assert((V4L2_PIX_FMT_BGRA444) == (v4l2_fourcc('G', 'A', '1', '2')), "V4L2_PIX_FMT_BGRA444 != v4l2_fourcc('G', 'A', '1', '2')");
+ DIAG_POP_IGNORE_TAUTOLOGICAL_COMPARE
+ #else
+-# define V4L2_PIX_FMT_SGRBG12 v4l2_fourcc('B', 'A', '1', '2')
++# define V4L2_PIX_FMT_BGRA444 v4l2_fourcc('G', 'A', '1', '2')
+ #endif
+ #if defined(V4L2_PIX_FMT_RGBA444) || (defined(HAVE_DECL_V4L2_PIX_FMT_RGBA444) && HAVE_DECL_V4L2_PIX_FMT_RGBA444)
+ DIAG_PUSH_IGNORE_TAUTOLOGICAL_COMPARE
+@@ -1343,8 +1347,17 @@ const struct xlat v4l2_pix_fmts[] = {
+ XLAT(V4L2_PIX_FMT_H264_NO_SC),
+ XLAT(V4L2_PIX_FMT_PWC1),
+ XLAT(V4L2_PIX_FMT_MPEG1),
+- XLAT(V4L2_PIX_FMT_BGRA444),
+ XLAT(V4L2_PIX_FMT_SGRBG12),
++#ifndef STRACE_WORKAROUND_FOR_V4L2_PIX_FMT_BGRA444
++# define STRACE_WORKAROUND_FOR_V4L2_PIX_FMT_BGRA444
++/*
++* V4L2_PIX_FMT_BGRA444 was introduced in Linux commit v5.2-rc1~33^2~24 with
++* the value of v4l2_fourcc('B', 'A', '1', '2') and changed in commit
++* v5.2-rc5-403-g22be8233b34f as it clashed with V4L2_PIX_FMT_SGRBG12.
++*/
++# undef V4L2_PIX_FMT_BGRA444
++#endif
++ XLAT(V4L2_PIX_FMT_BGRA444),
+ XLAT(V4L2_PIX_FMT_RGBA444),
+ XLAT(V4L2_PIX_FMT_ABGR444),
+ XLAT(V4L2_PIX_FMT_SGBRG12),
+--- a/xlat/v4l2_pix_fmts.in
++++ b/xlat/v4l2_pix_fmts.in
+@@ -37,8 +37,17 @@ V4L2_PIX_FMT_RGB332 v4l2_fourcc('R', 'G', 'B', '1') /* 8 RGB-3-3-2 */
+ V4L2_PIX_FMT_H264_NO_SC v4l2_fourcc('A', 'V', 'C', '1') /* H264 without start codes */
+ V4L2_PIX_FMT_PWC1 v4l2_fourcc('P', 'W', 'C', '1') /* pwc older webcam */
+ V4L2_PIX_FMT_MPEG1 v4l2_fourcc('M', 'P', 'G', '1') /* MPEG-1 ES */
+-V4L2_PIX_FMT_BGRA444 v4l2_fourcc('B', 'A', '1', '2') /* 16 bbbbgggg rrrraaaa */
+ V4L2_PIX_FMT_SGRBG12 v4l2_fourcc('B', 'A', '1', '2') /* 12 GRGR.. BGBG.. */
++#ifndef STRACE_WORKAROUND_FOR_V4L2_PIX_FMT_BGRA444
++# define STRACE_WORKAROUND_FOR_V4L2_PIX_FMT_BGRA444
++/*
++ * V4L2_PIX_FMT_BGRA444 was introduced in Linux commit v5.2-rc1~33^2~24 with
++ * the value of v4l2_fourcc('B', 'A', '1', '2') and changed in commit
++ * v5.2-rc5-403-g22be8233b34f as it clashed with V4L2_PIX_FMT_SGRBG12.
++ */
++# undef V4L2_PIX_FMT_BGRA444
++#endif
++V4L2_PIX_FMT_BGRA444 v4l2_fourcc('G', 'A', '1', '2') /* 16 bbbbgggg rrrraaaa */
+ V4L2_PIX_FMT_RGBA444 v4l2_fourcc('R', 'A', '1', '2') /* 16 rrrrgggg bbbbaaaa */
+ V4L2_PIX_FMT_ABGR444 v4l2_fourcc('A', 'B', '1', '2') /* 16 aaaabbbb ggggrrrr */
+ V4L2_PIX_FMT_SGBRG12 v4l2_fourcc('G', 'B', '1', '2') /* 12 GBGB.. RGRG.. */
diff --git a/dev-util/strace/strace-5.2.ebuild b/dev-util/strace/strace-5.2.ebuild
index db378889c0d5..88a2db590c17 100644
--- a/dev-util/strace/strace-5.2.ebuild
+++ b/dev-util/strace/strace-5.2.ebuild
@@ -37,6 +37,8 @@ RDEPEND="
perl? ( dev-lang/perl )
"
+PATCHES=( "${FILESDIR}"/${P}-linux-5.3-compat.patch )
+
src_prepare() {
default